View Issue Details

IDProjectCategoryView StatusLast Update
0017976CentOS-7scl-utilspublic2021-05-25 12:33
Reporterpetrj Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0017976: Add devtoolset-10 collection to CentOS 7
Descriptionhttps://access.redhat.com/errata/RHEA-2020:5284
devtoolset-10 packages are available on CentOS 8 but missing from CentOS 7.
TagsNo tags attached.
abrt_hash
URL

Activities

Arimil

Arimil

2021-05-20 17:51

reporter   ~0038448

Here's a log showing which packages are failing:

```
Loaded plugins: fastestmirror, ovl
Loading mirror speeds from cached hostfile
 * base: mirrors.gigenet.com
 * centos-sclo-rh: mirrors.usinternet.com
 * centos-sclo-sclo: repos.hou.layerhost.com
 * epel: mirror.team-cymru.com
 * extras: mirrors.usinternet.com
 * updates: mirror.compevo.com
Resolving Dependencies
--> Running transaction check
---> Package devtoolset-10.x86_64 0:10.0-0.el7 will be installed
--> Processing Dependency: devtoolset-10-perftools for package: devtoolset-10-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-runtime for package: devtoolset-10-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-toolchain for package: devtoolset-10-10.0-0.el7.x86_64
--> Running transaction check
---> Package devtoolset-10-perftools.x86_64 0:10.0-0.el7 will be installed
--> Processing Dependency: devtoolset-10-oprofile for package: devtoolset-10-perftools-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-systemtap for package: devtoolset-10-perftools-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-valgrind for package: devtoolset-10-perftools-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-dyninst for package: devtoolset-10-perftools-10.0-0.el7.x86_64
---> Package devtoolset-10-runtime.x86_64 0:10.0-0.el7 will be installed
---> Package devtoolset-10-toolchain.x86_64 0:10.0-0.el7 will be installed
--> Processing Dependency: devtoolset-10-gcc for package: devtoolset-10-toolchain-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-gcc-c++ for package: devtoolset-10-toolchain-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-gcc-gfortran for package: devtoolset-10-toolchain-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-binutils for package: devtoolset-10-toolchain-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-gdb for package: devtoolset-10-toolchain-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-strace for package: devtoolset-10-toolchain-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-dwz for package: devtoolset-10-toolchain-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-elfutils for package: devtoolset-10-toolchain-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-memstomp for package: devtoolset-10-toolchain-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-ltrace for package: devtoolset-10-toolchain-10.0-0.el7.x86_64
--> Processing Dependency: devtoolset-10-make for package: devtoolset-10-toolchain-10.0-0.el7.x86_64
--> Running transaction check
---> Package devtoolset-10-binutils.x86_64 0:2.35-3.el7 will be installed
---> Package devtoolset-10-dwz.x86_64 0:0.12-1.1.el7 will be installed
---> Package devtoolset-10-dyninst.x86_64 0:10.1.0-5.el7 will be installed
---> Package devtoolset-10-elfutils.x86_64 0:0.180-3.el7 will be installed
--> Processing Dependency: devtoolset-10-elfutils-debuginfod-client(x86-64) = 0.180-3.el7 for package: devtoolset-10-elfutils-0.180-3.el7.x86_64
--> Processing Dependency: devtoolset-10-elfutils-libelf(x86-64) = 0.180-3.el7 for package: devtoolset-10-elfutils-0.180-3.el7.x86_64
--> Processing Dependency: devtoolset-10-elfutils-libs(x86-64) = 0.180-3.el7 for package: devtoolset-10-elfutils-0.180-3.el7.x86_64
--> Processing Dependency: libdw.so.dts.1(ELFUTILS_0.177)(64bit) for package: devtoolset-10-elfutils-0.180-3.el7.x86_64
---> Package devtoolset-10-gcc.x86_64 0:10.2.1-2.1.el7 will be installed
---> Package devtoolset-10-gcc-c++.x86_64 0:10.2.1-2.1.el7 will be installed
--> Processing Dependency: devtoolset-10-libstdc++-devel = 10.2.1-2.1.el7 for package: devtoolset-10-gcc-c++-10.2.1-2.1.el7.x86_64
---> Package devtoolset-10-gcc-gfortran.x86_64 0:10.2.1-2.1.el7 will be installed
--> Processing Dependency: devtoolset-10-libquadmath-devel = 10.2.1-2.1.el7 for package: devtoolset-10-gcc-gfortran-10.2.1-2.1.el7.x86_64
---> Package devtoolset-10-gdb.x86_64 0:9.2-9.sc1.el7 will be installed
---> Package devtoolset-10-ltrace.x86_64 0:0.7.91-1.el7 will be installed
---> Package devtoolset-10-make.x86_64 1:4.2.1-1.el7 will be installed
---> Package devtoolset-10-memstomp.x86_64 0:0.1.5-6.el7 will be installed
---> Package devtoolset-10-oprofile.x86_64 0:1.4.0-1.el7 will be installed
---> Package devtoolset-10-strace.x86_64 0:5.7-3.el7 will be installed
---> Package devtoolset-10-systemtap.x86_64 0:4.3-8.el7 will be installed
--> Processing Dependency: devtoolset-10-systemtap-client = 4.3-8.el7 for package: devtoolset-10-systemtap-4.3-8.el7.x86_64
--> Processing Dependency: devtoolset-10-systemtap-devel = 4.3-8.el7 for package: devtoolset-10-systemtap-4.3-8.el7.x86_64
---> Package devtoolset-10-valgrind.x86_64 1:3.16.1-5.el7 will be installed
--> Running transaction check
---> Package devtoolset-10-elfutils-debuginfod-client.x86_64 0:0.180-3.el7 will be installed
---> Package devtoolset-10-elfutils-libelf.x86_64 0:0.180-3.el7 will be installed
---> Package devtoolset-10-elfutils-libs.x86_64 0:0.180-3.el7 will be installed
---> Package devtoolset-10-libquadmath-devel.x86_64 0:10.2.1-2.1.el7 will be installed
---> Package devtoolset-10-libstdc++-devel.x86_64 0:10.2.1-2.1.el7 will be installed
---> Package devtoolset-10-systemtap-client.x86_64 0:4.3-8.el7 will be installed
--> Processing Dependency: devtoolset-10-systemtap-runtime = 4.3-8.el7 for package: devtoolset-10-systemtap-client-4.3-8.el7.x86_64
---> Package devtoolset-10-systemtap-devel.x86_64 0:4.3-8.el7 will be installed
--> Running transaction check
---> Package devtoolset-10-systemtap-runtime.x86_64 0:4.3-8.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package Arch Version Repository Size
================================================================================
Installing:
 devtoolset-10 x86_64 10.0-0.el7 centos-sclo-rh 5.1 k
Installing for dependencies:
 devtoolset-10-binutils x86_64 2.35-3.el7 centos-sclo-rh 6.3 M
 devtoolset-10-dwz x86_64 0.12-1.1.el7 centos-sclo-rh 98 k
 devtoolset-10-dyninst x86_64 10.1.0-5.el7 centos-sclo-rh 3.8 M
 devtoolset-10-elfutils x86_64 0.180-3.el7 centos-sclo-rh 430 k
 devtoolset-10-elfutils-debuginfod-client
                                     x86_64 0.180-3.el7 centos-sclo-rh 56 k
 devtoolset-10-elfutils-libelf x86_64 0.180-3.el7 centos-sclo-rh 207 k
 devtoolset-10-elfutils-libs x86_64 0.180-3.el7 centos-sclo-rh 265 k
 devtoolset-10-gcc x86_64 10.2.1-2.1.el7 centos-sclo-rh 31 M
 devtoolset-10-gcc-c++ x86_64 10.2.1-2.1.el7 centos-sclo-rh 12 M
 devtoolset-10-gcc-gfortran x86_64 10.2.1-2.1.el7 centos-sclo-rh 12 M
 devtoolset-10-gdb x86_64 9.2-9.sc1.el7 centos-sclo-rh 3.8 M
 devtoolset-10-libquadmath-devel x86_64 10.2.1-2.1.el7 centos-sclo-rh 173 k
 devtoolset-10-libstdc++-devel x86_64 10.2.1-2.1.el7 centos-sclo-rh 3.2 M
 devtoolset-10-ltrace x86_64 0.7.91-1.el7 centos-sclo-rh 134 k
 devtoolset-10-make x86_64 1:4.2.1-1.el7 centos-sclo-rh 463 k
 devtoolset-10-memstomp x86_64 0.1.5-6.el7 centos-sclo-rh 443 k
 devtoolset-10-oprofile x86_64 1.4.0-1.el7 centos-sclo-rh 1.8 M
 devtoolset-10-perftools x86_64 10.0-0.el7 centos-sclo-rh 2.5 k
 devtoolset-10-runtime x86_64 10.0-0.el7 centos-sclo-rh 19 k
 devtoolset-10-strace x86_64 5.7-3.el7 centos-sclo-rh 1.2 M
 devtoolset-10-systemtap x86_64 4.3-8.el7 centos-sclo-rh 14 k
 devtoolset-10-systemtap-client x86_64 4.3-8.el7 centos-sclo-rh 3.7 M
 devtoolset-10-systemtap-devel x86_64 4.3-8.el7 centos-sclo-rh 2.2 M
 devtoolset-10-systemtap-runtime x86_64 4.3-8.el7 centos-sclo-rh 437 k
 devtoolset-10-toolchain x86_64 10.0-0.el7 centos-sclo-rh 2.7 k
 devtoolset-10-valgrind x86_64 1:3.16.1-5.el7 centos-sclo-rh 11 M

Transaction Summary
================================================================================
Install 1 Package (+26 Dependent packages)

Total size: 94 M
Total download size: 56 k
Installed size: 283 M
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
http://mirror.mia11.us.leaseweb.net/centos/7.9.2009/sclo/x86_64/rh/Packages/d/devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article

https://wiki.centos.org/yum-errors

If above article doesn't help to resolve this issue please use https://bugs.centos.org/.

http://mirror.vacares.com/centos/7.9.2009/sclo/x86_64/rh/Packages/d/devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://repos.lax.layerhost.com/centos/7.9.2009/sclo/x86_64/rh/Packages/d/devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://repos.mia.quadranet.com/centos/7.9.2009/sclo/x86_64/rh/Packages/d/devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://mirrors.usinternet.com/centos/7.9.2009/sclo/x86_64/rh/Packages/d/devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://mirror.us-midwest-1.nexcess.net/CentOS/7.9.2009/sclo/x86_64/rh/Packages/d/devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://centos-distro.1gservers.com/7.9.2009/sclo/x86_64/rh/Packages/d/devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://mirrors.raystedman.org/centos/7.9.2009/sclo/x86_64/rh/Packages/d/devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://mirror.cybersecurity.nmt.edu/centos/7.9.2009/sclo/x86_64/rh/Packages/d/devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://mirrors.cmich.edu/centos/7.9.2009/sclo/x86_64/rh/Packages/d/devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64.rpm: [Errno 12] Timeout on http://mirrors.cmich.edu/centos/7.9.2009/sclo/x86_64/rh/Packages/d/devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64.rpm: (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds')
Trying other mirror.


Error downloading packages:
  devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64: [Errno 256] No more mirrors to try.
```
patl

patl

2021-05-20 19:05

reporter   ~0038449

> http://mirror.mia11.us.leaseweb.net/centos/7.9.2009/sclo/x86_64/rh/Packages/d/devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found

I can confirm this problem.

It looks like this RPM was corrupt (checksum failed), and then someone removed it without updating everything that requires it.
Arimil

Arimil

2021-05-21 13:00

reporter   ~0038454

This appears to be resolved for me.
JohnnyHughes

JohnnyHughes

2021-05-21 22:01

administrator   ~0038456

I think this was just normal updating time required for external mirrors. I checked the files on the main server and they seemed OK, then everything cleared up externally.

Sometimes it takes several hours for some mirrors to update after a major update set. But everything seems good now.
JohnnyHughes

JohnnyHughes

2021-05-21 22:02

administrator   ~0038457

If anyone is still having issues .. please let us know and we can check the mirror.
arrfab

arrfab

2021-05-25 11:58

administrator   ~0038462

Can someone create issue on infra tracker please ? https://pagure.io/centos-infra/issues
The pkgs are being filtered out by the sign+push script, as debuginfo pkgs are landing on debuginfo.centos.org (and so http://debuginfo.centos.org/centos/7/sclo/x86_64/devtoolset-10-elfutils-debuginfod-client-0.180-3.el7.x86_64.rpm)
Discussing with SCLo guys to see what does this package do and if that's even normal to have it on mirrors or not
But create a ticket on infra tracker please
arrfab

arrfab

2021-05-25 12:33

administrator   ~0038463

FWIW : https://pagure.io/centos-infra/issue/338

Issue History

Date Modified Username Field Change
2020-12-28 00:20 petrj New Issue
2021-05-20 17:51 Arimil Note Added: 0038448
2021-05-20 19:05 patl Note Added: 0038449
2021-05-21 13:00 Arimil Note Added: 0038454
2021-05-21 22:01 JohnnyHughes Note Added: 0038456
2021-05-21 22:02 JohnnyHughes Note Added: 0038457
2021-05-21 22:02 JohnnyHughes Status new => resolved
2021-05-21 22:02 JohnnyHughes Resolution open => fixed
2021-05-25 11:58 arrfab Note Added: 0038462
2021-05-25 12:33 arrfab Note Added: 0038463