View Issue Details

IDProjectCategoryView StatusLast Update
0017989CentOS-8kmod-kvdopublic2021-02-01 16:33
ReporterGermano Massullo Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version8.3.2011 
Summary0017989: no kmod for kernel 4.18.0-240.1.1.el8_3.x86_64
Descriptionkmod-kvdo does not work with kernel 4.18.0-240.1.1.el8_3.x86_64

kmod-kvdo-6.2.2.117-65.el8.x86_64

# find /lib/modules/ -name '*kvdo*'
/lib/modules/4.18.0-187.el8.x86_64/extra/kmod-kvdo
/lib/modules/4.18.0-187.el8.x86_64/extra/kmod-kvdo/vdo/kvdo.ko
/lib/modules/4.18.0-193.19.1.el8_2.x86_64/weak-updates/kmod-kvdo
/lib/modules/4.18.0-193.19.1.el8_2.x86_64/weak-updates/kmod-kvdo/vdo/kvdo.ko
/lib/modules/4.18.0-193.28.1.el8_2.x86_64/weak-updates/kmod-kvdo
/lib/modules/4.18.0-193.28.1.el8_2.x86_64/weak-updates/kmod-kvdo/vdo/kvdo.ko

# rpm -ql kmod-kvdo
/etc/depmod.d/kvdo.conf
/lib/modules/4.18.0-187.el8.x86_64
/lib/modules/4.18.0-187.el8.x86_64/extra
/lib/modules/4.18.0-187.el8.x86_64/extra/kmod-kvdo
/lib/modules/4.18.0-187.el8.x86_64/extra/kmod-kvdo/uds
/lib/modules/4.18.0-187.el8.x86_64/extra/kmod-kvdo/uds/uds.ko
/lib/modules/4.18.0-187.el8.x86_64/extra/kmod-kvdo/vdo
/lib/modules/4.18.0-187.el8.x86_64/extra/kmod-kvdo/vdo/kvdo.ko

# vdo create --name vdo_vol1 --vdoLogicalSize 16G --device /dev/vdb
Creating VDO vdo_vol1
vdo: ERROR - Kernel module kvdo not installed
vdo: ERROR - modprobe: FATAL: Module kvdo not found in directory /lib/modules/4.18.0-240.1.1.el8_3.x86_64
TagsNo tags attached.

Activities

toracat

toracat

2021-01-03 00:29

manager   ~0038154

@JohnnyHughes

Could you build/release kmod-kvdo-6.2.3.114-74.el8 ? This one should work with the el8_3 kernels.
paulsor

paulsor

2021-01-26 23:28

reporter   ~0038199

I am having the same issue with the ppc64le build...
[root@sppcos001 ~]# rpm -q kernel kmod-kvdo
kernel-4.18.0-193.28.1.el8_2.ppc64le
kernel-4.18.0-240.1.1.el8_3.ppc64le
kernel-4.18.0-240.10.1.el8_3.ppc64le
kmod-kvdo-6.2.2.117-65.el8.ppc64le
[root@sppcos001 ~]# rpm -ql kmod-kvdo | grep modules
/lib/modules/4.18.0-187.el8.ppc64le
/lib/modules/4.18.0-187.el8.ppc64le/extra
/lib/modules/4.18.0-187.el8.ppc64le/extra/kmod-kvdo
/lib/modules/4.18.0-187.el8.ppc64le/extra/kmod-kvdo/uds
/lib/modules/4.18.0-187.el8.ppc64le/extra/kmod-kvdo/uds/uds.ko
/lib/modules/4.18.0-187.el8.ppc64le/extra/kmod-kvdo/vdo
/lib/modules/4.18.0-187.el8.ppc64le/extra/kmod-kvdo/vdo/kvdo.ko
toracat

toracat

2021-01-27 00:29

manager   ~0038200

Reminder sent to: JohnnyHughes

Knock, knock.
JohnnyHughes

JohnnyHughes

2021-01-29 19:23

administrator   ~0038211

So .. who is booting the latest kernel?
JohnnyHughes

JohnnyHughes

2021-01-29 19:29

administrator   ~0038212

Looks like we need kmod-kvdo-6.2.3.114-74.el8 .. building now
JohnnyHughes

JohnnyHughes

2021-02-01 13:34

administrator   ~0038215

This is built and in the process of being released.
JohnnyHughes

JohnnyHughes

2021-02-01 16:33

administrator   ~0038216

resolved with the 02/01/2021 release

Issue History

Date Modified Username Field Change
2021-01-02 23:35 Germano Massullo New Issue
2021-01-03 00:29 toracat Status new => acknowledged
2021-01-03 00:29 toracat Note Added: 0038154
2021-01-26 23:28 paulsor Note Added: 0038199
2021-01-27 00:29 toracat Note Added: 0038200
2021-01-29 19:23 JohnnyHughes Note Added: 0038211
2021-01-29 19:29 JohnnyHughes Note Added: 0038212
2021-02-01 13:34 JohnnyHughes Note Added: 0038215
2021-02-01 16:33 JohnnyHughes Status acknowledged => resolved
2021-02-01 16:33 JohnnyHughes Resolution open => fixed
2021-02-01 16:33 JohnnyHughes Note Added: 0038216