View Issue Details

IDProjectCategoryView StatusLast Update
0018002CentOS-8qt5public2021-01-10 07:40
ReporterMokolea 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
Product Version8.3.2011 
Target VersionFixed in Version 
Summary0018002: qt-creator yum install error
Descriptionqt-creator still depends on libLLVM-9.so, libclang.so.9, ... which are not available anymore
Package qt-creator needs to be rebuilt to be dependent on current version 10 of llvm, clang
Steps To Reproduce$ sudo yum install qt-creator

Error:
 Problem: conflicting requests
  - nothing provides libLLVM-9.so()(64bit) needed by qt-creator-4.12.4-1.el8.x86_64
  - nothing provides libLLVM-9.so(LLVM_9)(64bit) needed by qt-creator-4.12.4-1.el8.x86_64
  - nothing provides libclang.so.9()(64bit) needed by qt-creator-4.12.4-1.el8.x86_64
  - nothing provides libclang.so.9(LLVM_9)(64bit) needed by qt-creator-4.12.4-1.el8.x86_64
...
TagsNo tags attached.

Activities

Mokolea

Mokolea

2021-01-09 13:10

reporter   ~0038166

EPEL repository
toracat

toracat

2021-01-10 07:40

manager   ~0038167

This is something EPEL needs to fix. There is already a BZ requesting to build qt-creator for EL8.3:

https://bugzilla.redhat.com/show_bug.cgi?id=1897123

Issue History

Date Modified Username Field Change
2021-01-08 17:47 Mokolea New Issue
2021-01-09 13:10 Mokolea Note Added: 0038166
2021-01-10 07:40 toracat Note Added: 0038167
2021-01-10 07:40 toracat Status new => closed
2021-01-10 07:40 toracat Resolution open => won't fix