View Issue Details

IDProjectCategoryView StatusLast Update
0018096CentOS-8-OTHERpublic2021-03-09 03:37
ReporterdefaultUser Assigned To 
Status newResolutionopen 
Summary0018096: Monitors quit working/not displayed in 'Displays'
DescriptionI have been using the following kernels from my GRUB menu:
CentOS Linux (4.18.0-240.15.1.el8_3.x86_64) 8 // broke it all
CentOS Linux (4.18.0-240.1.1.el8_3.x86_64) 8 // problem
CentOS Linux (4.18.0-193.28.1.el8_2.x86_64) 8 (Core) // works
CentOS Linux (4.18.0-193.19.1.el8_2.x86_64) 8 (Core) // works
CentOS Linux (0-rescure-blahHash ) 8 (Core) // not tested
System setup //lolwut

on my CentOS 8 desktop/server box, with a nvidia 750 Ti, and 260 GTX (will not buy nvidia in the future).

what does the '(Core)' mean?

I had issues with the 'Standard (Wayland)' login/DisplayManager option only working on the two monitors on the 750 Ti. 3rd was black, would not show windows, but would show the mouse. Eventually after messing with confs, GRUB options, etc, changing the login option to 'Standard (X11 display server) on Xorg', worked. All 3 monitors displayed 1920x1080 with enough performance for non-gaming (untested) desktop productivity, using default Noveau drivers. I stuck with this, security implications of X11 aside (though that is a concern). the 260 GTX 9/10 times has its fan at 100%, the other time, it is at 0, overheats, and freezes. It appears the kernel cannot read its temperature sensor right or something, but does display and I can wear earmuffs/headphone.

When updating to: CentOS Linux (4.18.0-240.1.1.el8_3.x86_64) 8, only the center monitor on the 750 Ti worked, and only at 1024x768 :(. Shows 'Unknown Display' as the only display in 'Displays'. Reverting to CentOS Linux (4.18.0-193.28.1.el8_2.x86_64) 8 (Core) fixes the problem. A few weeks went by using the old kernel, I figured I should try updating before posting here. CentOS Linux (4.18.0-240.15.1.el8_3.x86_64) 8 has the same issue, and reverting to previous kernels does not undo the change! I even opened /etc/dnf/dnf.conf and changed installation_limit to 6 kernels instead of 3, so it wouldn't touch the working ones.. unless it does anyway? Also the 'Standard (Wayland)' login option/DM is gone, which if it is more secure, maybe I want to go back to at some point.

I hope this belongs here. should I also/instead post on SO? I have been using ubuntu/debian linux for years, but typically on a laptop with one monitor, which always works and was sufficient for my Linux tasks. I am not going back to Windows after the abomination that was 8, 8.1, and then 10 -- not to mention cutting 7 support short. I haven't had to dig into the guts of Linux much, and new to CentOS/RHEL. I may be attributing too much to the kernel, when it is an issue with the DM or something. Feel free to educate, I am here to learn linux, how to identify and fix problems, and make this a better product.
Steps To Reproducesee above
Additional InformationI set:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_enforce_resources=lax"
to try and fix the fan issue on the 260 GTX. Implications, security/otherwise are unknown, but it was working before.

Trying to fix this myself, xrandr:
() $ xrandr --listproviders
Providers: number : 0

() $ xrandr -q
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768 76.00*

which looks like a problem, but I can't revert to the old state since the old kernels still have this issue now that I loaded the very latest.

lspci shows:
01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
01:00.1 Audio device: NVIDIA Corporation GM107 High Definition Audio Controller [GeForce 940MX] (rev a1)
02:00.0 VGA compatible controller: NVIDIA Corporation GT200 [GeForce GTX 260] (rev a1)

both cards detected.. okay.

lshw shows:
*-display UNCLAIMED
                description: VGA compatible controller
                product: GM107 [GeForce GTX 750 Ti]
                configuration: latency=0

aha! This shows 'UNCLAIMED' now, and the configuration is missing some things. It used to show:
configuration: depth=32 driver=nouveau latency=0 resolution=1920,1080

Also present are some weird entries:
       product: EFI VGA
       physical id: 2
       logical name: /dev/fb0
       capabilities: fb
       configuration: depth=32 resolution=1024,768

  *-power UNCLAIMED
       description: To Be Filled By O.E.M.
       product: To Be Filled By O.E.M.
       vendor: To Be Filled By O.E.M.
       physical id: 1
       version: To Be Filled By O.E.M.
       serial: To Be Filled By O.E.M.
       capacity: 32768mWh

What looks to be a default/generic/unknown (?) display, and some weird power/battery entry? this is a desktop.

/usr/sbin/pwmconfig (pwmconfig) used to show:
Found the following devices:
   hwmon0 is acpitz
   hwmon1 is nouveau
   hwmon2 is nouveau
   hwmon3 is asus
   hwmon4 is coretemp
   hwmon5 is nct6791

but now only shows:
Found the following devices:
   hwmon0 is acpitz
   hwmon1 is asus
   hwmon2 is coretemp
   hwmon3 is nct6791

.. missing the noveaus

though the 260 GTX fan is at a (relatively) nice ~40-50% instead of screaming at 100%

I re-ran sensors-detect, didn't seem to do anything.

lsmod did not seem to show me stuff that was useful, but I don't know my way around the kernel and its modules that well, so I may have missed something obvious.

opening /var/log/Xorg.0.log:
X.Org X Server 1.20.8
X Protocol Version 11, Revision 0
[ 40.493] Build Operating System: 4.19.34-300.el7.x86_64
[ 40.493] Current Operating System: Linux localhost.localdomain 4.18.0-240.15.1.el8_3.x86_64 #1 SMP Mon Mar 1 17:16:16 UTC 2021 x86_64
[ 40.493] Kernel command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-4.18.0-240.15.1.el8_3.x86_64 root=/dev/mapper/cl-00 ro crashkernel=auto resume=/dev/mapper/cl-02 rd.luks.uuid=luks-redactedUUID rhgb quiet quiet splash acpi_enforce_resources=lax
[ 40.493] Build Date: 04 January 2021 04:26:35PM
[ 40.493] Build ID: xorg-x11-server 1.20.8-6.1.el8_3
[ 40.493] Current version of pixman: 0.38.4

[ 40.493] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 40.493] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Mar 5 14:24:22 2021
[ 40.494] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 40.494] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 40.495] (==) No Layout section. Using the first Screen section.
[ 40.495] (==) No screen section available. Using defaults.
[ 40.495] (**) |-->Screen "Default Screen Section" (0)
[ 40.495] (**) | |-->Monitor "<default monitor>"
[ 40.495] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[ 40.495] (==) Automatically adding devices
[ 40.615] (==) Matched nouveau as autoconfigured driver 0
[ 40.616] (==) Matched modesetting as autoconfigured driver 1
[ 40.616] (==) Matched fbdev as autoconfigured driver 2
[ 40.616] (==) Matched vesa as autoconfigured driver 3
[ 40.736] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
[ 40.736] (EE) open /dev/dri/card0: No such file or directory
[ 40.736] (WW) Falling back to old probe method for modesetting
[ 40.736] (EE) open /dev/dri/card0: No such file or directory

is something going wrong with some kind of blasted DRM?? argh nvidia. I cut out parts that don't look useful.

note that the owner of this log file is 'gdm' instead of my username, like the older Xorg log files, for some reason.

some people have suggested deleting:
/usr/share/X11/xorg.conf/d/20-intel.conf (DNE for me)

but I am afraid to delete any progress I did/didn't make with Wayland, and the files worked fine before the kernel update.

I also heard I could try lightDM instead of GDM, or KDE plasma, but I had some issues there without the latest updates installed. Now that everything is broken, but latest versions, maybe I will try. I guess it could be worse and I could have zero display.

to summarize:
- issue with 260 GTX display not drawing windows, only mouse: temporarily resolved by logging in with 'Standard (X11 display server) on Xorg' instead of 'Standard (Wayland)', perhaps introducing critical security issues for convenience and productivity of 3rd monitor
- issue with 260 GTX fan speed in jet engine mode, perhaps due to kernel not reading temp sensor correctly
- more pressing issue with displays not working on first kernel update (4.18.0-240.1.1.el8_3.x86_64)
- critical issue with latest kernel update (4.18.0-240.15.1.el8_3.x86_64), breaking previous display configs/etc. whatever is going on for all others
+ 260 GTX fan speed is only at ~50%, but won't display the screen

This is noticeable at boot, the splash screen is now only visible on one monitor (with lower resolution) instead of mirroring on all 3. Any dev knows going from 3 1920x1080 monitors to one 1024x768 sucks. This page won't shrink right so I am scrolling all over to format this bug report. Any help is appreciated!

ARGH session timeout deleted this post! damn security conscious people I'm trying to become again :)
TagsNo tags attached.




2021-03-09 03:37

reporter   ~0038293

Edit: just noticed my xorg log states it is running Build Operating System: 4.19.34-300.el7.x86_64, but is definitely running 4.18.0-240.15.1.el8_3.x86_64. This discrepancy seems to be visible in this user's arch:

Issue History

Date Modified Username Field Change
2021-03-05 23:10 defaultUser New Issue
2021-03-09 03:37 defaultUser Note Added: 0038293