View Issue Details

IDProjectCategoryView StatusLast Update
0018123CentOS-7selinux-policypublic2021-03-24 12:51
Reportergostal Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
OS Version7 
Summary0018123: SELinux is preventing /usr/libexec/sssd/krb5_child from 'write' accesses on the key labeled unconfined_service_t.
DescriptionDescription of problem:
This problem first occurred after rebooting due to new kernel. My user is authenticated using LDAP server on AD.
The log in process is handled by sssd and I could not log in. Local authentication worked, though.

Some details can be found at:
https://forums.centos.org/viewtopic.php?f=47&t=77307

I don't know which update caused the problem and I seldom reboot, typically only when a
new kernel is installed, so it may be a while back.

I can probably reproduce the problem if I know how to clear the kerberos ticket cache which I don't. I would also have to clear the local SELinux policy I just created and I don't know how to do that, too. Other than that the problem should reoccurr if I log out and then try to log in again.

The log in problem was temporarily solved by manually creating a ticket cache using kinit and since the tickets are valid 24 hours there have been no subsequent log in problems since yesterday. I believe creating the local policy has solved the problem permanently given present circum stances.
  
SELinux is preventing /usr/libexec/sssd/krb5_child from 'write' accesses on the key labeled unconfined_service_t.

***** Plugin catchall (100. confidence) suggests **************************

If you believe that krb5_child should be allowed write access on key labeled unconfined_service_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'krb5_child' --raw | audit2allow -M my-krb5child
# semodule -i my-krb5child.pp

Additional Information:
Source Context system_u:system_r:sssd_t:s0
Target Context system_u:system_r:unconfined_service_t:s0
Target Objects Unknown [ key ]
Source krb5_child
Source Path /usr/libexec/sssd/krb5_child
Port <Unknown>
Host (removed)
Source RPM Packages sssd-krb5-common-1.16.5-10.el7_9.7.x86_64
Target RPM Packages
Policy RPM selinux-policy-3.13.1-268.el7_9.2.noarch
Selinux Enabled True
Policy Type targeted
Enforcing Mode Enforcing
Host Name (removed)
Platform Linux (removed) 3.10.0-1160.21.1.el7.x86_64 #1 SMP
                              Tue Mar 16 18:28:22 UTC 2021 x86_64 x86_64
Alert Count 16
First Seen 2021-03-22 12:53:37 CET
Last Seen 2021-03-23 16:34:35 CET
Local ID d22b06b8-8a25-4e96-9b15-e14085ce90c8

Raw Audit Messages
type=AVC msg=audit(1616513675.343:393): avc: denied { write } for pid=15928 comm="krb5_child" scontext=system_u:system_r:sssd_t:s0 tcontext=system_u:system_r:unconfined_service_t:s0 tclass=key permissive=0


type=SYSCALL msg=audit(1616513675.343:393): arch=x86_64 syscall=add_key success=no exit=EACCES a0=7f434ee08ed1 a1=7ffc7e5941d0 a2=0 a3=0 items=0 ppid=15898 pid=15928 auid=4294967295 uid=2627 gid=6009 euid=2627 suid=2627 fsuid=2627 egid=6009 sgid=6009 fsgid=6009 tty=(none) ses=4294967295 comm=krb5_child exe=/usr/libexec/sssd/krb5_child subj=system_u:system_r:sssd_t:s0 key=(null)

Hash: krb5_child,sssd_t,unconfined_service_t,key,write

Version-Release number of selected component:
selinux-policy-3.13.1-268.el7_9.2.noarch
Additional Informationreporter: libreport-2.1.11.1
hashmarkername: setroubleshoot
kernel: 3.10.0-1160.21.1.el7.x86_64
reproducible: Not sure how to reproduce the problem
type: libreport
TagsNo tags attached.
abrt_hash003894a3f55b6e0d684b2d543402f7c32884e8f1438f6792bb14cf9b680c64f0
URL

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-03-24 12:51 gostal New Issue