View Issue Details

IDProjectCategoryView StatusLast Update
0018168CentOS-8kernelpublic2021-04-23 02:21
Reporterarhi Assigned To 
PrioritynormalSeverityblockReproducibilityalways
Status assignedResolutionopen 
Product Version8.3.2011 
Summary0018168: aacraid not recognising any pci-e cards
Descriptionaacraid driver is not recognising aacraid adapters

Steps To Reproducemodprobe aacraid
Additional Informationdmesg after loading the module show only that it is loaded, no cards found:

[ 303.035052] Adaptec aacraid driver 1.2.1[50877]-custom
[root@localhost OLD]#

lspci:
```
[root@localhost OLD]# lspci
00:00.0 Host bridge: Intel Corporation Device 9b73 (rev 03)
00:01.0 PCI bridge: Intel Corporation 6th-10th Gen Core Processor PCIe Controller (x16) (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Device 9ba8 (rev 03)
00:14.0 USB controller: Intel Corporation Comet Lake PCH-V USB Controller
00:16.0 Communication controller: Intel Corporation Device a3ba
00:17.0 SATA controller: Intel Corporation 400 Series Chipset Family SATA AHCI Controller
00:1b.0 PCI bridge: Intel Corporation Device a3e9 (rev f0)
00:1c.0 PCI bridge: Intel Corporation Device a397 (rev f0)
00:1d.0 PCI bridge: Intel Corporation Device a398 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device a3c8
00:1f.2 Memory controller: Intel Corporation Memory controller
00:1f.4 SMBus: Intel Corporation Comet Lake PCH-V SMBus Host Controller
01:00.0 PCI bridge: Intel Corporation 80333 Segment-A PCIe Express to PCI-X bridge
01:00.2 PCI bridge: Intel Corporation 80333 Segment-B PCIe Express to PCI-X bridge
02:0e.0 RAID bus controller: Adaptec AAC-RAID
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
[root@localhost OLD]#
```

lspci -knn
```
...
02:0e.0 RAID bus controller [0104]: Adaptec AAC-RAID [9005:0285]
        Subsystem: Adaptec 31605 [9005:02be]
...
```

nothing in /proc/scsi/scsi nor in /dev/a*
```
[root@localhost ~]# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA Model: KINGSTON SV300S3 Rev: BBF0
  Type: Direct-Access ANSI SCSI revision: 05
[root@localhost ~]# ls -la /dev/a*
crw-r--r--. 1 root root 10, 235 Apr 22 05:11 /dev/autofs
[root@localhost ~]#
```

Tagsaacraid

Activities

arhi

arhi

2021-04-22 05:40

reporter   ~0038407

I downloaded kernel source from https://github.com/torvalds/linux.git
extracted the drivers/scsi/aacraid/
and recompiled it with dkms this new module now see the card... it bugs, I guess 'cause I "force-compiled-it" (I had to add -Wno-incompatible-pointer-types and I had to comment out part of the source as

/var/lib/dkms/aacraid/1.2.2/build//linit.c:1480:14: error: initialization of ‘int (*)(struct scsi_device *, int, void *)’ from incompatible pointer type ‘int (*)(struct scsi_device *, unsigned int, void *)’ [-Werror=incompatible-pointer-types]
  .ioctl = aac_ioctl,
              ^~~~~~~~~
/var/lib/dkms/aacraid/1.2.2/build//linit.c:1480:14: note: (near initialization for ‘aac_driver_template.ioctl’)
/var/lib/dkms/aacraid/1.2.2/build//linit.c:1482:20: error: initialization of ‘int (*)(struct scsi_device *, int, void *)’ from incompatible pointer type ‘int (*)(struct scsi_device *, unsigned int, void *)’ [-Werror=incompatible-pointer-types]
  .compat_ioctl = aac_ioctl,
                    ^~~~~~~~~
/var/lib/dkms/aacraid/1.2.2/build//linit.c:1482:20: note: (near initialization for ‘aac_driver_template.compat_ioctl’)
/var/lib/dkms/aacraid/1.2.2/build//linit.c: In function ‘aac_probe_one’:
/var/lib/dkms/aacraid/1.2.2/build//linit.c:1730:8: error: ‘struct Scsi_Host’ has no member named ‘max_segment_size’
   shost->max_segment_size = shost->max_sectors << 9;
        ^~
/var/lib/dkms/aacraid/1.2.2/build//linit.c:1732:8: error: ‘struct Scsi_Host’ has no member named ‘max_segment_size’
   shost->max_segment_size = 65536;
        ^~


so I just got it to compile to see if it will see the card, and it does... so there is def. something wrong with the aacraid module that comes with centos 8 ( 4.18.0-301.1.el8.x86_64 is running attm)
toracat

toracat

2021-04-22 22:26

manager   ~0038409

You can test the latest in-kernel driver by installing kernel-ml from ELRepo. I see:

filename: /usr/lib/modules/5.11.16-1.el8.elrepo.x86_64/kernel/drivers/scsi/aacraid/aacraid.ko.xz
version: 1.2.1[50983]-custom
license: GPL
description: Dell PERC2, 2/Si, 3/Si, 3/Di, Adaptec Advanced Raid Products, HP NetRAID-4M, IBM ServeRAID & ICP SCSI driver
arhi

arhi

2021-04-23 01:30

reporter   ~0038411

@toracat don't I need kernel 5.11 to load them ?
never used this kernel-ml package, how to load the driver from /usr/lib/modules/5.11.16-1.el8.elrepo.x86_64/kernel/drivers/scsi/aacraid/aacraid.ko.xz instead a default location /lib/modules/4.18.0-301.1.el8.x86_64/kernel/drivers/scsi/aacraid/aacraid.ko.xz ?

thanks
arhi

arhi

2021-04-23 02:21

reporter   ~0038412

installed kernel-ml from elrepo
new driver works (shows the same version but "modinfo aacraid" shows it's loading it from the 5.11.16-1 tree)

no clue how kernel/modprobe now decides what driver to load, will have to check that out (will appreciate link to some doc if you have one to share) but this works :) thanks

Issue History

Date Modified Username Field Change
2021-04-22 04:07 arhi New Issue
2021-04-22 04:07 arhi Tag Attached: aacraid
2021-04-22 05:40 arhi Note Added: 0038407
2021-04-22 22:26 toracat Note Added: 0038409
2021-04-22 22:26 toracat Status new => assigned
2021-04-23 01:30 arhi Note Added: 0038411
2021-04-23 02:21 arhi Note Added: 0038412