View Issue Details

IDProjectCategoryView StatusLast Update
0018188CentOS-8anacondapublic2021-05-13 14:42
Reporterdgalloway Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status newResolutionopen 
Platformx86_64OSCentOS 8OS VersionStream
Summary0018188: initrd and vmlinuz in CentOS 8 Stream are incompatible. Can't PXE.
DescriptionI've imported CentOS-Stream-8-x86_64-20210506-dvd1.iso into Cobbler 2.6 and I can't get an automated install to run. It hangs then times out at:

anaconda 33.16.3.26-2.el8.centos for CentOS Linux 8 started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2
 * if the graphical installation interface fails to start, try again with the
   inst.text bootoption to start text installation
 * when reporting a bug add logs from /tmp as separate text/plain attachments
[14:27:54 Service org.fedoraproject.Anaconda.Modules.Storage has failed to start: Failed to activate service 'org.fedoraproject.Anaconda.Modules.Storage': timed out (service_start_timeout=600000ms)

[anaconda root@smithi134 tmp]# tail syslog
14:17:55,954 WARNING org.fedoraproject.Anaconda.Modules.Storage: return m(*args, **kwargs)
14:17:55,954 WARNING org.fedoraproject.Anaconda.Modules.Storage: File "/usr/lib/python3.6/site-packages/blivet/blivet.py", line 1053, in set_default_fstype
14:17:55,954 WARNING org.fedoraproject.Anaconda.Modules.Storage: self._check_valid_fstype(newtype)
14:17:55,954 WARNING org.fedoraproject.Anaconda.Modules.Storage: File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
14:17:55,954 WARNING org.fedoraproject.Anaconda.Modules.Storage: return m(*args, **kwargs)
14:17:55,954 WARNING org.fedoraproject.Anaconda.Modules.Storage: File "/usr/lib/python3.6/site-packages/blivet/blivet.py", line 1038, in _check_valid_fstype
14:17:55,954 WARNING org.fedoraproject.Anaconda.Modules.Storage: raise ValueError("new value %s is not valid as a default fs type" % newtype)
14:17:55,954 WARNING org.fedoraproject.Anaconda.Modules.Storage:ValueError: new
value xfs is not valid as a default fs type


If I use the vmlinuz and initrd from the CentOS 8.3 iso, install proceeds as expected.
Steps To Reproduce1) Import http://packages.oit.ncsu.edu/centos/8-stream/isos/x86_64/CentOS-Stream-8-x86_64-20210506-dvd1.iso to Cobbler
2) Try to PXE boot it
Additional InformationSeems like https://bugs.centos.org/view.php?id=16640
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-05-13 14:42 dgalloway New Issue