View Issue Details

IDProjectCategoryView StatusLast Update
0018211CentOS-8hostnamepublic2021-06-11 04:26
Reporterstevenbain Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformCentOSOSCentOS Stream 8OS VersionCentOS Stream 8
Summary0018211: Package: hostname - SystemD Service File Problem Causing NetworkManager to Fail on Boot
DescriptionDuring boot the following messages appear and cause several services to fail to start.

# dmesg | egrep 'break|Found'
[ 5.637161] systemd[1]: NetworkManager-wait-online.service: Found ordering cycle on sysinit.target/start
[ 5.638902] systemd[1]: NetworkManager-wait-online.service: Found dependency on nis-domainname.service/start
[ 5.640665] systemd[1]: NetworkManager-wait-online.service: Found dependency on network-online.target/start
[ 5.642436] systemd[1]: NetworkManager-wait-online.service: Found dependency on cloud-init.service/start
[ 5.644101] systemd[1]: NetworkManager-wait-online.service: Found dependency on NetworkManager-wait-online.service/start
[ 5.645988] systemd[1]: NetworkManager-wait-online.service: Job nis-domainname.service/start deleted to break ordering cycle starting with NetworkManager-wait-online.service/start
Steps To ReproduceResolved by removing 'After=network-online.target' from /usr/lib/systemd/system/nis-domainname.service.
TagsNo tags attached.

Activities

cesarb

cesarb

2021-06-07 22:49

reporter   ~0038478

The upstream bug seems to be https://bugzilla.redhat.com/show_bug.cgi?id=1959720 and another workaround is "dnf downgrade hostname" to go back to hostname-3.20-6.el8 which works correctly.
carlwgeorge

carlwgeorge

2021-06-11 04:26

developer   ~0038494

CentOS Stream 8 bugs are tracked in bugzilla, not this bug tracker.

https://wiki.centos.org/ReportBugs
https://bugzilla.redhat.com/show_bug.cgi?id=1959720

Issue History

Date Modified Username Field Change
2021-06-02 07:57 stevenbain New Issue
2021-06-07 22:49 cesarb Note Added: 0038478
2021-06-11 04:26 carlwgeorge Status new => closed
2021-06-11 04:26 carlwgeorge Resolution open => fixed
2021-06-11 04:26 carlwgeorge Note Added: 0038494