View Issue Details

IDProjectCategoryView StatusLast Update
0018291CentOS-7kernelpublic2021-09-10 23:06
Reporterg3plan Assigned To 
PriorityhighSeverityblockReproducibilityrandom
Status resolvedResolutionfixed 
Platform x86_64OSCentosOS Version7.4
Product Version7.4.1708 
Summary0018291: Kernel panic: kernel BUG at fs/ceph/mds_client.c:1325!
DescriptionHello, I upgraded to kernel 3.10.0-1160 version on Centos7.4, and encountered a kernel crash when using the cephfs client.

I think this ”https://github.com/torvalds/linux/commit/87bc5b895d94a0f40fe170d4cf5771c8e8f85d15“ commit may solve my problem. When will centos7 update this commit?

System: CentOS Linux release 7.4.1780 (Core)
Kernel : 3.10.0-1127.el7.x86_64
Ceph: ceph-14.2.8-0
libcephfs2-14.2.8-0
Additional InformationUnless I'm mistaken, the patch is in the CentOS 8.4 GA kernel. Closing as 'resolved'.
TagsNo tags attached.
abrt_hash
URL

Relationships

duplicate of 0018290 closed Update "ceph: use ceph_evict_inode to cleanup inode's resource" commit! 

Activities

g3plan

g3plan

2021-08-31 11:05

reporter  

toracat

toracat

2021-08-31 21:25

manager   ~0038603

CentOS 7.4 is no longer supported. Please update your system to the latest. Chances are that the referenced fix is in the current kernel.
ManuelWolfshant

ManuelWolfshant

2021-08-31 22:23

manager   ~0038604

Please update your whole system using the latest packages offered by the distribution. First of all we do not support cherry picking and second even 3.10.0-1160 is not the latest.
TrevorH

TrevorH

2021-08-31 22:38

manager   ~0038605

Also, I checked and that patch is already part of kernel-3.10.0-1160.41.1.el7 and possibly earlier ones too (I only checked the latest).

Issue History

Date Modified Username Field Change
2021-08-31 11:05 g3plan New Issue
2021-08-31 11:05 g3plan File Added: 2bf2d3653b2a5105a927b1c897b7a0d6.jpg
2021-08-31 11:05 g3plan File Added: 3e8d99818b7d01f83d46e8f59f032640.jpg
2021-08-31 21:25 toracat Note Added: 0038603
2021-08-31 21:25 toracat Status new => assigned
2021-08-31 21:25 toracat Description Updated
2021-08-31 21:29 toracat Relationship added duplicate of 0018290
2021-08-31 22:23 ManuelWolfshant Note Added: 0038604
2021-08-31 22:38 TrevorH Note Added: 0038605
2021-09-10 23:06 toracat Status assigned => resolved
2021-09-10 23:06 toracat Resolution open => fixed
2021-09-10 23:06 toracat Additional Information Updated