View Issue Details

IDProjectCategoryView StatusLast Update
0018332CentOS-7httpdpublic2021-10-21 00:13
Reporterjpuhlman Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
OSCentos 7 
Product Version7.9.2009 
Summary0018332: httpd update as of 10-20-2021 is incomplete and if httpd-manual is installed blocks updates.
Descriptiondocker run -it centos:7.9.2009 yum install mod_ssl httpd-manual

results in:

Error: Package: httpd-manual-2.4.6-97.el7.centos.noarch (updates)
           Requires: httpd = 2.4.6-97.el7.centos
           Available: httpd-2.4.6-95.el7.centos.x86_64 (base)
               httpd = 2.4.6-95.el7.centos
           Available: httpd-2.4.6-97.el7.centos.x86_64 (updates)
               httpd = 2.4.6-97.el7.centos
           Installing: httpd-2.4.6-97.el7.centos.1.x86_64 (updates)
               httpd = 2.4.6-97.el7.centos.1


This is due to mod_ssl requiring a specific version of httpd to be installed.
[cluge@black centos-updates-7.9]$ docker run -it centos:7.9.2009 rpm -qp --requires http://mirror.centos.org/centos/7.9.2009/updates/x86_64/Packages/mod_ssl-2.4.6-97.el7.centos.1.x86_64.rpm | grep "httpd ="
httpd = 0:2.4.6-97.el7.centos.1

and httpd-manual as well.

[cluge@black centos-updates-7.9]$ docker run -it centos:7.9.2009 rpm -qp --requires http://mirror.centos.org/centos/7.9.2009/updates/x86_64/Packages/httpd-manual-2.4.6-97.el7.centos.noarch.rpm | grep "httpd ="
httpd = 2.4.6-97.el7.centos

While mod_ssl was updated with the rest of the httpd packages, httpd-manual was not.

[ ] mod_ssl-2.4.6-97.el7.centos.1.x86_64.rpm 2021-10-20 12:10 115K
[ ] mod_session-2.4.6-97.el7.centos.1.x86_64.rpm 2021-10-20 12:10 63K
[ ] mod_proxy_html-2.4.6-97.el7.centos.1.x86_64.rpm 2021-10-20 12:10 53K
[ ] mod_ldap-2.4.6-97.el7.centos.1.x86_64.rpm 2021-10-20 12:10 74K
[ ] httpd-tools-2.4.6-97.el7.centos.1.x86_64.rpm 2021-10-20 12:10 93K
[ ] httpd-devel-2.4.6-97.el7.centos.1.x86_64.rpm 2021-10-20 12:10 200K
[ ] httpd-2.4.6-97.el7.centos.1.x86_64.rpm 2021-10-20 12:10 2.7M

[ ] httpd-manual-2.4.6-97.el7.centos.noarch.rpm 2020-11-18 14:24 1.3M

Since older updates are removed from the updates repository on mirrors, this causes an unresolvable dependency set if you have http-manual and mod_ssl installed at the same time.



Steps To Reproducedocker run -it centos:7.9.2009 yum install mod_ssl httpd-manual
TagsNo tags attached.
abrt_hash
URL

Activities

TrevorH

TrevorH

2021-10-20 21:12

manager   ~0038671

> Since older updates are removed from the updates repository on mirror

They are not removed, they are still present and can be used by explicit version number or using e.g. yum downgrade.
jpuhlman

jpuhlman

2021-10-20 21:59

reporter   ~0038672

Fair enough. Then the rest of the update for httpd needs to be pushed to the repository to resolve the unresolvable dependency network.
jpuhlman

jpuhlman

2021-10-21 00:12

reporter   ~0038673

As of 5:11 PM PDT, the package is available, the repo data is updated and I was able to get past this issue.

Issue History

Date Modified Username Field Change
2021-10-20 21:03 jpuhlman New Issue
2021-10-20 21:12 TrevorH Note Added: 0038671
2021-10-20 21:59 jpuhlman Note Added: 0038672
2021-10-20 22:48 toracat Status new => assigned
2021-10-21 00:12 jpuhlman Note Added: 0038673
2021-10-21 00:13 ManuelWolfshant Status assigned => closed
2021-10-21 00:13 ManuelWolfshant Resolution open => fixed