View Issue Details

IDProjectCategoryView StatusLast Update
0018366CentOS-8generalpublic2022-01-08 18:57
Reporterklaatu Assigned To 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionwon't fix 
Product Version8.4.2105 
Summary0018366: Several flatpaks seem to have audio and rendering issues
DescriptionApologies for a very general bug report, but I'm not able to pinpoint the root of the problem.

Several flatpaks fail to launch correctly on my CentOS Stream 8 system. I've filed bugs with the Flathub, but few maintainers have been able to determine the problem.

Problematic Flatpaks include:

App: com.giadamusic.Giada
Error: "Your sound card is misconfigured."
Note: My sound works as expected with Ardour, Audacity, Kdenlive, and many other Flatpak applications.
External bug: https://github.com/flathub/com.giadamusic.Giada/issues/11

App: org.hydrogenmusic.Hydrogen
Error: Fails to launch entirely. No window appears. It throws an error about Qt authentication, but I've been told this is not the cause of the problem (and other Flatpaks using Qt work as expected, such as Krita)
External bug: https://github.com/flathub/org.hydrogenmusic.Hydrogen/issues/16

App: com.obsproject.Studio
Error: Window launches, but without text and at quadruple the size of my screen (window edges are off screen)
External bug: https://github.com/flathub/com.obsproject.Studio/issues/143

App: info.mumble.Mumble
Error: Window launches, but without text or widgets
External bug: none filed yet, I've decided to file here for now
Steps To Reproduce1. Install CentOS 8 -> upgrade to CentOS Stream
2. Install Giada, Hydrogen, Mumble, or OBS Studio as a flatpak from gnome-software or using the flatpak command. It makes no difference whether the flatpak is installed as a systemwide app or as a user app.
3. Launch the app
Additional InformationThis is a CentOS Stream 8 system that's started out as a CentOS 8 system. I upgraded and did a distro-sync.

```
$ cat /etc/os-release
NAME="CentOS Stream"
VERSION="8"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="8"
PLATFORM_ID="platform:el8"
PRETTY_NAME="CentOS Stream 8"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:8"
HOME_URL="https://centos.org/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux 8"
REDHAT_SUPPORT_PRODUCT_VERSION="CentOS Stream"
```

Flatpak version 1.8.5
TagsNo tags attached.

Activities

toracat

toracat

2022-01-08 18:57

manager   ~0038784

CentOS Stream-related issues must be reported upstream. Please see:

https://wiki.centos.org/ReportBugs

Issue History

Date Modified Username Field Change
2021-12-01 23:55 klaatu New Issue
2022-01-08 18:57 toracat Status new => closed
2022-01-08 18:57 toracat Resolution open => won't fix
2022-01-08 18:57 toracat Note Added: 0038784