View Issue Details

IDProjectCategoryView StatusLast Update
0018412CentOS-8generalpublic2022-03-27 15:54
Reporterbilias Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0018412: vault access forbidden
Descriptioncloudfront seems to reject access to vault.centos.org

I can access https://vault.centos.org/8.5.2111/opstools/x86_64/collectd-5/repodata/repomd.xml from browser. However not from yum/wget/curl

# wget https://vault.centos.org/8.5.2111/opstools/x86_64/collectd-5/repodata/repomd.xml
--2022-03-08 12:01:07-- https://vault.centos.org/8.5.2111/opstools/x86_64/collectd-5/repodata/repomd.xml
Resolving vault.centos.org (vault.centos.org)... 52.85.158.46, 52.85.158.33, 52.85.158.15, ...
Connecting to vault.centos.org (vault.centos.org)|52.85.158.46|:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2022-03-08 12:01:07 ERROR 403: Forbidden.

# curl https://vault.centos.org/8.5.2111/opstools/x86_64/collectd-5/repodata/repomd.xml
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<HTML><HEAD><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
<TITLE>ERROR: The request could not be satisfied</TITLE>
</HEAD><BODY>
<H1>403 ERROR</H1>
<H2>The request could not be satisfied.</H2>
<HR noshade size="1px">
Request blocked.
We can't connect to the server for this app or website at this time. There might be too much traffic or a configuration error. Try again later, or contact the app or website owner.
<BR clear="all">
If you provide content to customers through CloudFront, you can find steps to troubleshoot and help prevent this error by reviewing the CloudFront documentation.
<BR clear="all">
<HR noshade size="1px">
Generated by cloudfront (CloudFront)
Request ID: MrFTWq92JWDPJ1SRaJe-XR0vUotsw3WFwydHfjyL6Rft1vA0B-7-kA==

<ADDRESS>
</ADDRESS>
</BODY></HTML>

# yum update
CentOS-8 - OpsTools - collectd - vault 5.7 kB/s | 919 B 00:00
Errors during downloading metadata for repository 'ovirt-4.4-centos-opstools-vault':
  - Status code: 403 for https://vault.centos.org/8.5.2111/opstools/x86_64/collectd-5/repodata/repomd.xml (IP: 52.85.158.46)
Error: Failed to download metadata for repo 'ovirt-4.4-centos-opstools-vault': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
Steps To Reproducewget https://vault.centos.org/8.5.2111/opstools/x86_64/collectd-5/repodata/repomd.xml

curl https://vault.centos.org/8.5.2111/opstools/x86_64/collectd-5/repodata/repomd.xml

TagsNo tags attached.

Activities

toracat

toracat

2022-03-27 15:54

manager   ~0038885

It seems to be working now. Closing.

Issue History

Date Modified Username Field Change
2022-03-08 10:02 bilias New Issue
2022-03-27 15:54 toracat Status new => resolved
2022-03-27 15:54 toracat Resolution open => fixed
2022-03-27 15:54 toracat Note Added: 0038885