View Issue Details

IDProjectCategoryView StatusLast Update
0018431CentOS-8dnfpublic2022-04-14 21:15
Reportersven.haardiek Assigned To 
PriorityhighSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version8.4.2105 
Summary0018431: Broken Dependencies 'Development Tools'
DescriptionI tried to install 'Development Tools', but it seems like the repository is broken:

❯ docker run -it quay.io/centos/centos:stream8 dnf groupinstall -y 'Development Tools'
CentOS Stream 8 - AppStream 14 MB/s | 21 MB 00:01
CentOS Stream 8 - BaseOS 8.6 MB/s | 21 MB 00:02
CentOS Stream 8 - Extras 49 kB/s | 18 kB 00:00
Last metadata expiration check: 0:00:01 ago on Wed Apr 13 13:51:59 2022.
Error:
 Problem 1: package rpm-build-4.14.3-22.el8.x86_64 requires rpm = 4.14.3-22.el8, but none of the providers can be installed
  - cannot install both rpm-4.14.3-23.el8.x86_64 and rpm-4.14.3-22.el8.x86_64
  - package rpm-libs-4.14.3-23.el8.x86_64 requires rpm = 4.14.3-23.el8, but none of the providers can be installed
  - package rpm-build-libs-4.14.3-23.el8.x86_64 requires rpm-libs(x86-64) = 4.14.3-23.el8, but none of the providers can be installed
  - package rpm-sign-4.14.3-23.el8.x86_64 requires rpm-build-libs(x86-64) = 4.14.3-23.el8, but none of the providers can be installed
  - cannot install the best candidate for the job
 Problem 2: package redhat-rpm-config-127-1.el8.noarch requires glibc-gconv-extra, but none of the providers can be installed
  - glibc-gconv-extra-2.28-189.el8.i686 has inferior architecture
  - glibc-gconv-extra-2.28-167.el8.i686 has inferior architecture
  - glibc-gconv-extra-2.28-170.el8.i686 has inferior architecture
  - glibc-gconv-extra-2.28-174.el8.i686 has inferior architecture
  - glibc-gconv-extra-2.28-180.el8.i686 has inferior architecture
  - glibc-gconv-extra-2.28-181.el8.i686 has inferior architecture
  - glibc-gconv-extra-2.28-184.el8.i686 has inferior architecture
  - glibc-gconv-extra-2.28-196.el8.i686 has inferior architecture
  - package glibc-gconv-extra-2.28-189.el8.x86_64 requires glibc(x86-64) = 2.28-189.el8, but none of the providers can be installed
  - package glibc-gconv-extra-2.28-167.el8.x86_64 requires glibc(x86-64) = 2.28-167.el8, but none of the providers can be installed
  - package glibc-gconv-extra-2.28-170.el8.x86_64 requires glibc(x86-64) = 2.28-170.el8, but none of the providers can be installed
  - package glibc-gconv-extra-2.28-174.el8.x86_64 requires glibc(x86-64) = 2.28-174.el8, but none of the providers can be installed
  - package glibc-gconv-extra-2.28-180.el8.x86_64 requires glibc(x86-64) = 2.28-180.el8, but none of the providers can be installed
  - package glibc-gconv-extra-2.28-181.el8.x86_64 requires glibc(x86-64) = 2.28-181.el8, but none of the providers can be installed
  - package glibc-gconv-extra-2.28-184.el8.x86_64 requires glibc(x86-64) = 2.28-184.el8, but none of the providers can be installed
  - package glibc-gconv-extra-2.28-196.el8.x86_64 requires glibc(x86-64) = 2.28-196.el8, but none of the providers can be installed
  - cannot install both glibc-2.28-197.el8.x86_64 and glibc-2.28-189.el8.x86_64
  - cannot install both glibc-2.28-197.el8.x86_64 and glibc-2.28-167.el8.x86_64
  - cannot install both glibc-2.28-197.el8.x86_64 and glibc-2.28-170.el8.x86_64
  - cannot install both glibc-2.28-197.el8.x86_64 and glibc-2.28-174.el8.x86_64
  - cannot install both glibc-2.28-197.el8.x86_64 and glibc-2.28-180.el8.x86_64
  - cannot install both glibc-2.28-197.el8.x86_64 and glibc-2.28-181.el8.x86_64
  - cannot install both glibc-2.28-197.el8.x86_64 and glibc-2.28-184.el8.x86_64
  - cannot install both glibc-2.28-197.el8.x86_64 and glibc-2.28-196.el8.x86_64
  - glibc-2.28-197.el8.i686 has inferior architecture
  - package glibc-devel-2.28-197.el8.x86_64 requires glibc = 2.28-197.el8, but none of the providers can be installed
  - cannot install the best candidate for the job
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
Steps To ReproduceTry to install 'Development Tools' in the latest centos 8 stream
TagsNo tags attached.

Activities

toracat

toracat

2022-04-14 21:15

manager   ~0038902

CentOS Stream-related bugs must be reported to Red Hat. For details, please see:

https://wiki.centos.org/ReportBugs

Issue History

Date Modified Username Field Change
2022-04-13 14:44 sven.haardiek New Issue
2022-04-14 21:15 toracat Note Added: 0038902