2017-09-24 03:18 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002075CentOS-4centos-releasepublic2007-06-03 08:20
ReporterNeoGenesis 
PrioritynormalSeveritymajorReproducibilityalways
StatusassignedResolutionopen 
Product Version4.5 - i386 
Target VersionFixed in Version 
Summary0002075: file conflict between centos-release and apt - both provide the same file
DescriptionWhen trying to upgrade from 4.4 -> 4.5 we get this error:

file /etc/apt/sources.list.d/centos.list from install of centos-release-4-4.3 conflicts with file from package apt-0.5.15cnc6-4.centos4

As apt is installed with --nodeps during the install it is no problem, but when we try to upgrade - it fails.
Additional InformationThe resolution would be to remove the list file from apt/centos-release file or to rename it in one of them
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0005253

NeoGenesis (reporter)

One way of fixing it http://alfa2linux.blogspot.com/2007/05/centos-44-and-45-apt-problems.html

~0005281

pdf (reporter)

Last edited: 2007-06-03 08:22

I have the same question.
I have installed RH AS4.0 release, then I install apt-0.5.15cnc6-4.centos4.i386.rpm. Then I try to install yum with "apt-get install yum", but my system report that "file /etc/apt/sources.list.d/centos.list from install of centos-release-4-4.3 conflicts with file from package apt-0.5.15cnc6-4.centos4 E: Error while running transaction".
I am still have no idea to resove this problem after I reading the articles in the blog of Vahur.
Does any one has an detailed solutions? THKs very much!

+Notes

-Issue History
Date Modified Username Field Change
2007-05-23 09:44 NeoGenesis New Issue
2007-05-23 09:44 NeoGenesis Status new => assigned
2007-05-29 18:48 NeoGenesis Note Added: 0005253
2007-06-03 08:20 pdf Note Added: 0005281
2007-06-03 08:21 pdf Note Edited: 0005281
2007-06-03 08:22 pdf Note Edited: 0005281
+Issue History