View Issue Details

IDProjectCategoryView StatusLast Update
0002141CentOS-5udevpublic2011-09-21 10:38
Status assignedResolutionopen 
Product Version5.0 - x86_64 
Target VersionFixed in Version 
Summary0002141: Udev hangs on startup
DescriptionUdev always hangs on startup.
I tried to boot with acpi=off, but without any success.

My hardware configuration is here$wwwPartNumLookup/_8840EDG?OpenDocument&sourcesite=esgie
TagsNo tags attached.




2007-06-16 15:55

reporter   ~0005390

I forgot to mention that this only happens when using XEN.
Sorry for the incomplete information


2007-06-17 09:33

reporter   ~0005394

Try with "acpi=off noapic" - works wonders on 336/346 with CentOS 4.0.
Tho I have not tried with 5.0...


2007-06-18 19:19

reporter   ~0005426

Same problem here. CentOS 5 final with latest xen kernel (I don't remember which, not on my computer now.) The acpi=off dosn't change anything. I suspect that this bug also makes domU crash at install. (something about the USB hub, "hub_port_status failed : err -110").

Do you have any other suggestion ?


2007-06-18 22:30

reporter   ~0005431

Can't think of anything useful except to boot with "nousb" and see if it makes the system more or less usable. Also disabling usb in the bios could be a step closer to find the problem source.

As I'm guessing You use xen for hos operating system, so is the usb support a must?


2007-06-21 10:58

reporter   ~0005443

Last edited: 2007-06-21 14:02

I have almost the same problem. Boots Hangs when starting udev. Though, it doesn't always do it, it hangs most of the time (let's say, 9 boots out of 10) so it has become unusable. More precisely, it hangs when launching /sbin/udevsettle.

I have tested two completly different hardware (one R440 Novascale with Core Duo), and home made 3Ghz Xeon, both 64bits with 1Go of RAM.
I can't disable USB as the R440 use USB keyboards only.

Kernel is for hardware and NFS_ROOT support.
Diskless system (never had any problems with the disk one)



2007-06-21 14:00

reporter   ~0005446

2.4 kernels are not meant to use udev AFAIK. They use devfs instead sysfs. I have not used a 2.4 kernel for ages, so I'm not competent to answer if udev support is back ported from 2.5/2.6 to 2.4. Ether upgrading the kernel to a standard kernel (or at least to a 2.6 kernel) or disabling/removing the udev may solve your problem.


2007-06-21 14:03

reporter   ~0005447

My mistake, I corrected my note, I meant (almost latest 2.6 kernel)


2007-08-02 21:20

reporter   ~0005803

I have had much the same problem on my HP Omnibook XE3 notebook. This old 256 Mb machine worked fine with CentOS4 i386, but after upgrading to CentOS5 udev often freezes on startup.

After setting udev_log="info" in /etc/udev/udev.conf, the messages seemed to indicate a timing issue with the floppy. After disabling the floppy controller in the BIOS, no more crashes thus far (the messages were not saved to the log files because of the crash, so I can't say exactly what they were).

Hope this helps.


2008-07-30 13:49

reporter   ~0007775

I had this problem also, of udev hanging on system bootup with CentOS 5.2 i386 under Xen HVM virtualization.

I disabled udev by commenting out this line in /etc/rc.sysinit:



2008-08-02 13:19

reporter   ~0007794

I some cases similar to the one reported a possible work-around is to add
 udevtimeout=XX (where XX is number of seconds,ie 30)
in the kernel command line (ie grub.conf)

This should cause udev_settle to timeout after XX seconds and let the system boot.


2008-08-04 21:29

reporter   ~0007800

Using VMware Server with CentOS 5.2 -
adding udevtimeout=XX to the boot options did not help,
boot still hung on udev.
Changing the processor count from 2 to 1 did work.
Looks like a processor "affinity" problem.


2008-08-29 11:57

reporter   ~0007884

I found a solution for my case:

I have modified the /etc/rc.sysinit to mount a tmpfs fs in /dev
if [ ! -e /proc/mounts ]; then
        mount -n -t proc /proc /proc
        mount -n -t sysfs /sys /sys >/dev/null 2>&1
        mount -n -t tmpfs /dev /dev <- There

And it works. I guess this is done in the initrd which I do not use since I have a home made kernel.
I don't see any side effect so far.


2009-07-09 13:47

reporter   ~0009589

Had the same problem on ESXi Free 4.0 using CentOS 5.2 (2.6.18-92.el5 i686). Changed the number of CPUs from 2 down to 1 and it booted just fine.


2009-11-18 20:12

reporter   ~0010383

It's apparently an issue with the clock that only occurs when you give the guest more than one cpu. Appending the following to the boot options does the trick here:



2010-09-23 18:45

reporter   ~0011881

Had the same problem on a Dell Dimension C521, with Centos 5.5, Kernel 2.6.8-194.11.1.el5.
Successfully passed udev start with "acpi=off noacpi clocksource=acpi_pm" boot options.


2010-10-09 17:04

reporter   ~0011921

I believe this is not really about XEN. I use non-xen kernels here, I have been having this udev issues since CentOS 5.4(3?) introduced the 2.6.18-194* kernels. I have done a fresh 5.5 install with ext3 fs for every disk array ( used to be XFS with CentOS 5.4 ).

About "processor affinity" reported by ngbranitsky, I don't have an opinion at all... I can tell that I had a Phenom II 920 CPU and I downgraded to an Athlon 64X2 4400+ to be sure that the CPU is NOT the problem. ( M2N32-SLI Deluxe is told to have "issues" with AM2+ ). The Chipset is MCP55.

All I can say ATM is that 2.6.18-164* WORKS and 2.6.18-194* HANGS.

I haven't tried the "tricks" from the notes above thought. I will try these and come with and update later; just wanted to help filtering the points of possible cause for this problem.


2010-10-11 12:05

reporter   ~0011923

Im running a compaq presario v6301au , thunderbird 64 x2 thats been running with a 35c palmrest for 2 years due to faulty compaq bios (fixed). At first i thought this was processor/memory failure however memory has been ruled out and processor seems to be fine given Ubuntu 10.04 is completely stable.

My system freezes at udev, and at random places after udev is started.

Memory scan for 3 hours comes up clean.

acpi=off causes a halt at start however,
noacpi and clocksource=acpi_pm allow boot so far 5 times in a row without freeze.

all the other mentioned work arounds did not work.

this of course, could still be processor failure.


2010-10-11 13:55

reporter   ~0011924

Firstly, id like to chime in im not using XEN kernels here otherwise and this problem persists on 5.4 and 5.5 (with all updates)

5 in a row was luck it seemed.

After enabling services problem remained, reversing this did not remedy.

I tried maxcpus=1 which worked until it freezed in shutdown.

I'm now trying an i386 install.


2010-10-14 19:48

reporter   ~0011937

Adding noacpi boot option and disabling audio in the BIOS worked for me. None of the other command line options seemed to help.

OS: CentOS 5.4
Kernel: 2.6.18-194
CPU: AMD Athlon 64 4200+ (dual core)
Graphics: nVidia GeForce 6150


2010-10-24 02:36

reporter   ~0011954

Same problem here with 194. None of the kernel options above made a difference (although I got a new message "disabling IRQ #129).


2010-12-01 08:10

reporter   ~0012125

Similar problem using openSuse: When I disable the onboard network card it boots smoothly.

<6>[ 17.836934] ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[19] MMIO=[f7800000-f78007ff] Max Packet=[2048] IR/IT contexts=[8/8]
<6>[ 17.873923] parport_pc 00:0f: reported by Plug and Play ACPI
<6>[ 17.874022] parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
<6>[ 17.890579] hda_codec: ALC663: BIOS auto-probing.
<7>[ 17.890585] ALSA hda_codec.c:4385: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0)
<7>[ 17.890588] ALSA hda_codec.c:4389: speaker_outs=1 (0x17/0x0/0x0/0x0/0x0)
<7>[ 17.890591] ALSA hda_codec.c:4393: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
<7>[ 17.890594] ALSA hda_codec.c:4394: mono: mono_out=0x0
<7>[ 17.890596] ALSA hda_codec.c:4397: dig-out=0x11/0x1e
<7>[ 17.890598] ALSA hda_codec.c:4405: inputs: mic=0x18, fmic=0x19, line=0x1a, fline=0x0, cd=0x0, aux=0x0
<7>[ 17.892134] ALSA patch_realtek.c:1287: realtek: No valid SSID, checking pincfg 0x4005c603 for NID 0x1d
<7>[ 17.892137] ALSA patch_realtek.c:1303: realtek: Enabling init ASM_ID=0xc603 CODEC_ID=10ec0663
<6>[ 18.003009] ppdev: user-space parallel port driver
<7>[ 19.098759] ieee1394: Host added: ID:BUS[0-00:1023] GUID[003005b3500b9c1b]
<6>[ 117.555397] ipmi_si: There appears to be no BMC at this location
<6>[ 117.559395] ipmi_si 0000:05:00.3: PCI INT D disabled
<4>[ 117.567306] ipmi_si: Unable to find any System Interface(s)
<6>[ 118.065659] Adding 4200444k swap on /dev/sda1. Priority:-1 extents:1 across:4200444k
<6>[ 118.907767] device-mapper: uevent: version 1.0.3
<6>[ 118.907878] device-mapper: ioctl: 4.17.0-ioctl (2010-03-05) initialised:
<6>[ 119.083769] loop: module loaded
<6>[ 120.229552] EXT4-fs (sda3): mounted filesystem with ordered data mode



2011-02-04 14:35

reporter   ~0012404

A quick update here:
I'll try some of the tricks above and I'll post any news. The CentOS 5 kernel is old enough to use an old version without fixes at least. And I want to upgrade my array to 6Tb. Too much data to mess with, I NEED and up2date system.

Just FYI, I use fedora for desktop, The system is an Intel Q9550 ( my server, the one with CentOS 5 is AMD ), and after an update to kernel to, the same thing happened: udev hangs.

More news later.


2011-02-05 01:23

reporter   ~0012407

NEWS: In my it case was really the sound card. Simply blacklisting the snd-hda-intel module was enough...

OK, i don't really need sound here... but let's just say that I'd need it.
I wonder if this bug report is going anywhere...

Should we fill an upstream bug report for this? I didn't find anything at google with many different keywords.

Not being able to boot with onboard NIC like in tombert's case is a serious issue.

The issue is serious since everything worked fine with the 2.6.18-164 kernel series and doesn't work with any 2.6.18-194 version ( in my case at least ).

What changed so much from 164 to 194? Is it some (broken) code backporting issue?

Now I can move to ext4.


2011-02-09 02:04

reporter   ~0012417


Just compiled 2.6.18-238.1 from upstream. The sound card works fine now, removed the blacklist entry.


2011-02-09 23:29

reporter   ~0012421

I have encountered the same problem. Both disabling the Audio via the bios or blacklisting the snd-hda-intel module solves this problem for me.

Note: I believe this might be some sort of timing issue related to access speed of the hard drives.
This problem started for me when I decided to swap hard drives for newer ones.

Replaced hard drive: Seagate Barracuda 7200.10 Model: ST3500630AS
New hard drives: Western Digital Caviar Black Model: WD2001FASS.
MB: Asus m2npv-vm
CPU: Model AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
Kernel: Kernel Version 2.6.18-194.8.1.v5PAE (SMP)


2011-04-12 08:13

reporter   ~0012599

Same problem for me with CentOS 5.6. I have 16 identical hosts. No problem with 15 of them, but on hangs on starting udev. Most of the command line parameters from above don't seem to help. By setting udevtimeout, udevsettle terminates after the specified timeout, and the system boots up.


2011-05-07 04:29

reporter   ~0012721

This was a problem for me on vmware workstation when I selected the virtualization support package during install of CentOs 5.5 and attempted to reboot for the first time. I performed a fresh install without the virtualization package and it booted just fine.


2011-09-21 10:38

reporter   ~0013332

FWIW, I've added yesterday.

It describes a "Starting udev" hang, too (*no* XEN). According to my tests the /sbin/udevsettle hangs forever in usleep(). The udevsettle process does *not* time out after 180s (the default timeout).

This hang is rare and only happens in approx 1 percent of all reboots. I need to reboot 100 cluster nodes once or twice to run into the hang. But it *is* reproducible and occurs on many different machines which otherwise work fine.

Issue History

Date Modified Username Field Change
2007-06-13 10:22 antistes New Issue
2007-06-13 10:22 antistes Status new => assigned
2007-06-16 15:55 antistes Note Added: 0005390
2007-06-17 09:33 NeoGenesis Note Added: 0005394
2007-06-18 19:19 lucboudreau Note Added: 0005426
2007-06-18 22:30 NeoGenesis Note Added: 0005431
2007-06-21 10:58 dpi Note Added: 0005443
2007-06-21 14:00 NeoGenesis Note Added: 0005446
2007-06-21 14:02 dpi Note Edited: 0005443
2007-06-21 14:03 dpi Note Added: 0005447
2007-08-02 21:20 andfri Note Added: 0005803
2008-07-30 13:49 mark Note Added: 0007775
2008-08-02 13:19 Giulio Note Added: 0007794
2008-08-04 21:29 ngbranitsky Note Added: 0007800
2008-08-29 11:57 dpi Note Added: 0007884
2009-07-09 13:47 dragonmantank Note Added: 0009589
2009-11-18 20:12 fnaard Note Added: 0010383
2010-09-23 18:45 ggrussenmeyer Note Added: 0011881
2010-10-09 17:04 msilveirabr Note Added: 0011921
2010-10-11 12:05 hyperthinker1024 Note Added: 0011923
2010-10-11 13:55 hyperthinker1024 Note Added: 0011924
2010-10-14 19:48 swculy Note Added: 0011937
2010-10-24 02:36 Robin Note Added: 0011954
2010-12-01 08:10 tombert Note Added: 0012125
2011-02-04 14:35 msilveirabr Note Added: 0012404
2011-02-05 01:23 msilveirabr Note Added: 0012407
2011-02-09 02:04 msilveirabr Note Added: 0012417
2011-02-09 23:29 cognoquest Note Added: 0012421
2011-04-12 08:13 bgufler Note Added: 0012599
2011-05-07 04:29 b Note Added: 0012721
2011-09-21 10:38 knweiss Note Added: 0013332