View Issue Details

IDProjectCategoryView StatusLast Update
0002244CentOS-5xenpublic2009-12-04 12:24
Reporterbtk 
PrioritynormalSeveritymajorReproducibilityalways
Status assignedResolutionopen 
Product Version5.0 - x86_64 
Target VersionFixed in Version 
Summary0002244: Only 3.2Gb of Ram instead of 8Gb
DescriptionWhen booting Xen Kernel, it only recognize 3.2 Gb of memory. But we got 8Gb.
With standard Kernel evreything it's fine, we got 8Gb of memory.

Additional InformationMotherborad MSI k9n sli platinum
AMD X2 64 6000+
8Gb OCZ memory
Tried with 2.6.18-8.1.8.el5.centos.plusxen kernel and 2.6.18-8.1.8.el5.
TagsNo tags attached.

Relationships

related to 0001905 closedkbsingh@karan.org 4GB only recognized as 3GB 

Activities

mattdm

mattdm

2007-08-02 13:17

updater   ~0005793

Are you using the 64-bit kernel or the 32-bit one?
btk

btk

2007-08-02 13:39

reporter   ~0005795

I'm using 64-bit kernel.
smooge

smooge

2007-08-02 17:24

reporter   ~0005799

The problem is probably with the hardware and the various ways that memory can be seen on the AMD systems. AMD itself has found that board manufacturers do whacky new things to try and save a buck or two...

First, does the memory show up if you use a regular kernel versus xen?

Second update BIOS to the latest version, and open a ticket with the board manufacturer asking why the memory isnt being seen.

Third, on x86_32, I know you can try various remapping commands to get the kernel to ignore ACPI BIOS crap or have it tell it to look at other parts of the BUS for its memory (usually with a PCI command).

"pci=conf1" or "pci=nommconf"
btk

btk

2007-08-02 21:56

reporter   ~0005805

I can have my 8Gb of memory using x86_64 non-xen kernel.
I tried remapping memory hole in the Bios option too. And after googling, I also tried "pci=conf1" or "pci=nommconf".
I'm using the latest Bios version.
Under Centos 4.5 I got also my 8Gb. The problem occur only with x86_64 xen kernel.
Thanks for your help
lauchlin

lauchlin

2007-11-09 20:03

reporter   ~0006261

I'm seeing a similar problem. MSI PS5Neo2 main board. Under Centos 5 2.6.22-14 I have no problems seeing 4GB+ memmory. If I use 2.6.22-14xen then I can only see 3.2GB ram.

FYI:

Linux sal9000 2.6.22-14-xen #1 SMP Sun Oct 14 23:20:20 GMT 2007 x86_64 GNU/Linux

cat /proc/mtrr
reg00: base=0x00000000 ( 0MB), size=65536MB: write-back, count=0
reg01: base=0xcff00000 (3327MB), size= 1MB: uncachable, count=0
reg02: base=0xd0000000 (3328MB), size= 256MB: uncachable, count=0
reg03: base=0xe0000000 (3584MB), size= 512MB: uncachable, count=0
ripienaar

ripienaar

2007-12-03 23:26

reporter   ~0006451

I had the same problem on CentOS 5 and 5.1, some bug fixes are doing the rounds at:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=419994

this worked for me, my machine now see all the momory, I applied the fix to the CentOS 5.1 src rpm
yerenkow

yerenkow

2009-12-03 23:54

reporter   ~0010452

Have the same here,
System Information
        Manufacturer: Supermicro
        Product Name: X7DBR-3
Only 4gb from 8gb seen.
toracat

toracat

2009-12-04 12:24

manager   ~0010458

The CentOS version of grub with the patch referenced in the debian bug report in comment 6451 has been available at:

http://centos.toracat.org/grub-0.97/CentOS-5/

It is currently grub-0.97-13.5.bz250299. Please see bug #1905 for details.

Issue History

Date Modified Username Field Change
2007-08-02 08:42 btk New Issue
2007-08-02 08:42 btk Status new => assigned
2007-08-02 13:17 mattdm Note Added: 0005793
2007-08-02 13:39 btk Note Added: 0005795
2007-08-02 17:24 smooge Note Added: 0005799
2007-08-02 21:56 btk Note Added: 0005805
2007-11-09 20:03 lauchlin Note Added: 0006261
2007-12-03 23:26 ripienaar Note Added: 0006451
2009-12-03 23:54 yerenkow Note Added: 0010452
2009-12-04 01:59 toracat Relationship added related to 0001905
2009-12-04 12:24 toracat Note Added: 0010458