View Issue Details

IDProjectCategoryView StatusLast Update
0002363CentOS-5initscriptspublic2007-10-09 09:02
ReporterLeroyvl 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version5.0 - x86_64 
Target VersionFixed in Version 
Summary0002363: service network start ignores ONBOOT=NO for aliased interfaces
DescriptionWhen adding a ifcfg-eth0:1 with the line ONBOOT=NO it is started at boot or 'service network restart'. The fix has been attached.
Additional Information--- /etc/sysconfig/network-scripts/ifup-aliases.bug 2007-09-27 11:29:40.000000000 +0200
+++ /etc/sysconfig/network-scripts/ifup-aliases 2007-09-27 11:30:23.000000000 +0200
@@ -321,6 +321,7 @@ for FILE in ifcfg-${parent_device}:* ; d
        is_ignored_file "$FILE" && continue
        ini_env;
        . $FILE;
+ [ "${ONBOOT}" = "no" -o "${ONBOOT}" = "NO" ] && continue
        [ -z "$DEVICE" ] && DEVICE=${FILE##ifcfg-}
        [ "$ONPARENT" != "no" -a "$ONPARENT" != "NO" ] && new_interface;
        unset DEVICE
TagsNo tags attached.

Activities

2007-09-27 09:36

 

ifup-aliases.do_not_ignore_onboot.patch (521 bytes)
--- /etc/sysconfig/network-scripts/ifup-aliases.bug	2007-09-27 11:29:40.000000000 +0200
+++ /etc/sysconfig/network-scripts/ifup-aliases	2007-09-27 11:30:23.000000000 +0200
@@ -321,6 +321,7 @@ for FILE in ifcfg-${parent_device}:* ; d
        is_ignored_file "$FILE" && continue
        ini_env;
        . $FILE;
+       [ "${ONBOOT}" = "no" -o "${ONBOOT}" = "NO" ] && continue
        [ -z "$DEVICE" ] && DEVICE=${FILE##ifcfg-}
        [ "$ONPARENT" != "no" -a "$ONPARENT" != "NO" ] && new_interface;
        unset DEVICE
range

range

2007-09-27 11:28

administrator   ~0006065

Bleh. That should have been patched in 8.11-1;

- fix mis-bringup of interfaces due to accidentally matched HWADDR
  (a.k.a. ONBOOT=no not working) (#153669, #157252)

See https://bugzilla.redhat.com/show_bug.cgi?id=157252 (though that is for FC3).

Can you please report that at bugzilla.redhat.com and link back and forth to the bug here and there?

Cheers,

Ralph
range

range

2007-10-05 10:41

administrator   ~0006095

Errrm. What is the link to your bugzilla entry at upstream? :)
range

range

2007-10-05 10:43

administrator   ~0006096

I don't know if adding to a CLOSED bug for FC3 was smart - You should have opened a new one for RHEL 5 ...
Leroyvl

Leroyvl

2007-10-05 14:35

reporter   ~0006097

Upstream entry:

https://bugzilla.redhat.com/show_bug.cgi?id=320211
range

range

2007-10-05 14:40

administrator   ~0006098

Thanks
Leroyvl

Leroyvl

2007-10-08 22:42

reporter   ~0006106

Got word from RedHat, this is not a bug but one has to read the manual :).

Bill Nottingham explains:

See /usr/share/doc/initscripts-<version>/sysconfig.txt, specifically the notes
about ONBOOT and aliases, and the use of ONPARENT.

The important bits are:

--------------------------------------------------------------------------

  Alias specific items:
    ONPARENT=yes|no
      Whether to bring up the device when the parent device is brought
      up.
      Default: yes

--------------------------------------------------------------------------

-> CLOSE
range

range

2007-10-09 09:02

administrator   ~0006107

RTFineM -> closed on reporters request. Thank you.

Issue History

Date Modified Username Field Change
2007-09-27 09:36 Leroyvl New Issue
2007-09-27 09:36 Leroyvl Status new => assigned
2007-09-27 09:36 Leroyvl File Added: ifup-aliases.do_not_ignore_onboot.patch
2007-09-27 11:28 range Note Added: 0006065
2007-09-27 11:29 range Status assigned => acknowledged
2007-10-05 10:41 range Note Added: 0006095
2007-10-05 10:43 range Note Added: 0006096
2007-10-05 14:35 Leroyvl Note Added: 0006097
2007-10-05 14:40 range Note Added: 0006098
2007-10-08 22:42 Leroyvl Note Added: 0006106
2007-10-09 09:02 range Status acknowledged => closed
2007-10-09 09:02 range Note Added: 0006107
2007-10-09 09:02 range Resolution open => no change required