View Issue Details

IDProjectCategoryView StatusLast Update
0002381CentOS-5kernelpublic2007-10-17 07:16
Reporterberanger 
PrioritynormalSeveritymajorReproducibilityalways
Status assignedResolutionopen 
Product Version5.0 - i386 
Target VersionFixed in Version 
Summary0002381: Suspend-to-disk fails miserably (but works from the LiveCD!)
DescriptionSuspend-to-disk fails miserably on Acer TravelMate 5310, with swsusp being unable to save the memory image to the swap. The system frezes after a lot of errors of this kind:
  end_request: I/O error, dev sda, sector NNNNNNNN
  Buffer I/O error on device sda, logical block N

Obviously, it fails to resume, so it reloads the whole system. The behavior is the same, no matter how many times you try it.
Additional Information-- On the same hardware, CentOS 5.0 LiveCD suspends-to-disk successfully when a swap partition is available! (Of course it's not about waking up here...)
-- The same hibernation failure with: X/OS 5.0 x86_64 edition.
-- The same hibernation failure with: StartCom EL 5.0 i386 edition.
-- It doesn't matter if you use the kernel on the installation media or a full updated system.
-- Hibernation not only works with CentOS 5.0 LiveCD, but it also works with Fedora 7.
-- Have not tried with FC6.
-- Have not tried with Scientific Linux 5.0.
-- Have not tried with RHEL5.
-- Hardware details here:
http://beranger.org/bugz/acertm5310_centos5_dmesg.txt
http://beranger.org/bugz/acertm5310_centos5_lspci.txt
http://beranger.org/bugz/acertm5310_centos5_lspcivv.txt
TagsNo tags attached.

Activities

beranger

beranger

2007-10-17 07:16

reporter   ~0006144

I have found the fix.

In /etc/pm/config, add tg3 to the list:
SUSPEND_MODULES="button tg3"

People using Bluetooth would probably have it this way:
SUSPEND_MODULES="button uhci-hcd tg3"

Issue History

Date Modified Username Field Change
2007-10-10 10:16 beranger New Issue
2007-10-10 10:16 beranger Status new => assigned
2007-10-17 07:16 beranger Note Added: 0006144