View Issue Details

IDProjectCategoryView StatusLast Update
0002434CentOS-3perlpublic2009-01-29 21:01
Reportermla12 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
Product Version3.8 
Target VersionFixed in Version 
Summary0002434: Scalar::Util missing XS
DescriptionIt appears that the perl RPM does not include the XS version of Scalar::Util.

Various modules die when attempting to use dualvar() from the Scalar::Util module, which is only available in the XS-compiled version of the module.
Additional InformationBackground:

Last night my CentOS 3.9 was auto-updated by Yum:

Nov 06 06:06:15 Updated: perl-CPAN 2:1.61-97.EL3.i386
Nov 06 06:06:15 Updated: perl 2:5.8.0-97.EL3.i386
Nov 06 06:06:15 Updated: perl-CGI 2:2.89-97.EL3.i386
Nov 06 06:06:15 Updated: perl-suidperl 2:5.8.0-97.EL3.i386

Immediately after, the site starting failing in calls to Compress::Zlib due to a
missing dualvar function. Downgrading to previous perl did not help.

However, once I went into CPAN and manually rebuilt Scalar::Util with the compiled XS extensions, everything starting working normally.

TagsNo tags attached.

Activities

mla12

mla12

2007-11-07 23:56

reporter   ~0006252

More discussion of this issue:
http://rt.cpan.org/Public/Bug/Display.html?id=27598
JohnnyHughes

JohnnyHughes

2008-01-09 23:37

administrator   ~0006676

if you had done that in the past too (rebuild Scalar::Util) then that would have been upgraded with the new version of perl.

In the bug that you mention in your link, CentOS exhibits the same behavior as RHEL (which is our goal).

Only if we exhibit a different behavior would we change our build.
ajscam

ajscam

2008-07-28 14:53

reporter   ~0007767

My most recent yum update has caused this problem on CentOS 4.6...

Jul 25 16:18:22 Updated: perl.i386 3:5.8.5-36.el4_6.3
tru

tru

2009-01-29 21:01

administrator   ~0008652

won't fix as it's also there upstream

Issue History

Date Modified Username Field Change
2007-11-07 23:54 mla12 New Issue
2007-11-07 23:54 mla12 Status new => assigned
2007-11-07 23:56 mla12 Note Added: 0006252
2008-01-09 23:37 JohnnyHughes Note Added: 0006676
2008-07-28 14:53 ajscam Note Added: 0007767
2009-01-29 21:01 tru Status assigned => closed
2009-01-29 21:01 tru Note Added: 0008652
2009-01-29 21:01 tru Resolution open => won't fix