View Issue Details

IDProjectCategoryView StatusLast Update
0002499CentOS-5lm_sensorspublic2008-05-22 13:18
Reporterchlambert 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
Product Version5.1 
Target VersionFixed in Version 
Summary0002499: lm_sensors report "General parse error" on AMD K8 CPU
DescriptionThe command sensors reports "General parse error". My CentOS version is 5.1 for x86_64

'rpm -q lm_sensors' reports lm_sensors-2.10.0-3.1

See informations from www.lm-sensors.org on additional information pane
Additional InformationDecember 5th, 2006: Note to k8temp users. The Linux 2.6.19 kernel features a new hardware monitoring driver, k8temp, which supports all recent AMD K8 CPUs. The driver will load automatically on supported systems. Due to technical specificities of this driver, upgrade to lm_sensors 2.10.1 is mandatory. Older versions of libsensors will fail with a "General parse error" message. If you can't upgrade lm_sensors for any reason, you'll have to blacklist the k8temp driver to prevent it from being loaded. Thanks to Artem S. Tashkinov for notifying us.
TagsNo tags attached.

Activities

tupari

tupari

2008-05-15 18:05

reporter   ~0007272

Why is this still an issue with the current 5.1 rpms?
toracat

toracat

2008-05-16 22:41

manager   ~0007279

lm_sensors in CentOS 5 is currently lm_sensors-2.10.0-3.1. As noted in "Additional Information", AMD K8 requires at least 2.10.1.

Solution: Install lm_sensors from ATrpms which has a newer version that works with the AMD K8 chip. Refer to http://wiki.centos.org/Repositories for how to set up the Atrpms repository.
timverhoeven

timverhoeven

2008-05-22 13:18

developer   ~0007298

Workaround provided.

Issue History

Date Modified Username Field Change
2007-12-04 10:37 chlambert New Issue
2008-05-15 18:05 tupari Note Added: 0007272
2008-05-16 22:41 toracat Note Added: 0007279
2008-05-16 22:43 toracat Status new => confirmed
2008-05-22 13:18 timverhoeven Status confirmed => closed
2008-05-22 13:18 timverhoeven Note Added: 0007298
2008-05-22 13:18 timverhoeven Resolution open => won't fix