View Issue Details

IDProjectCategoryView StatusLast Update
0002552CentOS-5anacondapublic2011-09-05 21:30
Reportervivo Assigned To 
Status feedbackResolutionopen 
Product Version5.1 
Summary0002552: Install on AMD Geode LX800 fails with PackageSackError
DescriptionWhen trying to install Centos 5.1 on an LX800 mobo, an error is raised after package selection, that has "PackageSackError: No Package Matching Kernel" as bottom line and dozens of others on top.

cat /proc/cpuinfo:

processor : 0
vendor_id : AuthenticAMD
cpu family : 5
model : 10
model name : Geode(TM) integrated Processor by AMD PCS
stepping : 2
cpu MHz : 498.104
cache size : 128 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu de pse tsc msr cx8 pge cmov clflush mmx mmxext 3dnowext 3dnow up
bogomips : 997.11

Additional InformationI can install rhel just fine, the appropriate i686 kernel is used then. Other distros that support i686 only (archlinux) run fine as well.
TagsNo tags attached.


2007-12-18 23:53

reporter   ~0006582

can you attach the anaconda.log from a rhel install ?

2007-12-19 09:45


anaconda.log (9,941 bytes)


2007-12-19 09:46

reporter   ~0006586

I picked this log file from an ASTNOW install i had just finished, hope that helps.

2008-07-07 00:06

reporter   ~0007577

Can you re-test with the CentOS-5.2 Installer and let us know if this issue is resolved or not ?


2008-07-15 09:31

reporter   ~0007641

Same error when trying to install CentOS 5.2 on Geode hardware:

Traceback (most recent call first):
File "/usr/lib/python2.4/site-packages/yum/", line 750, in returnNewestByName raise PackageSackError, 'No Package Matching %s' % name
File "/usr/lib/python2.4/site-packages/yum/", line 345, in returnNewestByName return bestofeach.returnNewestByName(name)
File "/tmp/treedir.8196/instimage/usr/lib/anaconda/", line 1091, in getBestKernelByArch
pkgs = ayum.pkgSack.returnNewestByName(pkgname)
File "/tmp/treedir.8196/instimage/usr/lib/anaconda/", line 1100, in selectBestKernel
kpkg = getBestKernelByArch("kernel", self.ayum)

Is it possible to select the kernel manually, so we can work around this issue?


2008-07-15 09:49

reporter   ~0007642

A possible work-around using VMware:

2008-09-13 21:49

reporter   ~0007972

thats not an RHEL anaconda.log - its from some other random distro ( based on paths and the install mechanism. Also that kernel has never been shipped by redhat ).

2008-09-14 02:50

reporter   ~0007973

Can you test the install with the "rpmarch=i686" on the command line for the installer. eg: at the bootup screen for the installer type:

linux rpmarch=i686


2008-09-14 09:21

reporter   ~0007974

It seems like it should be possible to solve this by passing --targetarch i686 on the command line to anaconda, although it's not clear how to add extra command line options without rebuilding stage2.

2008-09-14 09:55

reporter   ~0007975

@rwmj: the rpmarch=i686 on the boot line will get passed to targetarch.


2008-09-14 10:39

reporter   ~0007976

So I did rpmarch=i686 on the kernel command line, and (with RHEL 5, not CentOS)
that does seem to work.

Interestingly, the option does _not_ get passed on the anaconda command line.
Anaconda must be accessing /proc/cmdline directly. I'll have to check the source
later to find out what it's doing.


2008-09-14 10:57

reporter   ~0007977

No, unfortunately that's no good - the install fails later on. I'll attach the new anaconda.log in a moment.

Since that install trashed the original filesystem on this machine, I no longer have any method of booting the machine, so I'll need to do the install by pulling out the hard drive and mounting it on another machine.

2008-09-14 10:58


anaconda-with-rpmarch.log (407,287 bytes)


2008-10-22 12:15

reporter   ~0008181

Hi There,
I found this from and am also trying to install CentOS 5.2 onto a vigen MPC-L, and can confirm the same issues as reported below; booting with the arguments "linux acpi=off rpmarch=i686 askmethod" allows anaconda to get as far as downloading/installing the packages but then crashes out with only "reboot" as the only option to choose.


2008-11-19 14:47

reporter   ~0008306

I have an "Flepo miniPC alpha" from and am
also trying to install CentOS 5.2. I can confirm the same issues as reported;
booting with the arguments "linux rpmarch=i686 ks=hd:hda3:/testbox-ks.cfg"
allows anaconda to get as far as to prepare installing the packages but
then crashes out with only "reboot" as the only option to choose.
The anaconda.log is like the uploaded anaconda-with-rpmarch.log
I read in "[CentOS-devel] geode anyone ?" about an updates.img to patch
anaconda. I am able to help testing if updates.img is available.


2008-12-30 17:19

reporter   ~0008516

I have the same problem with my appliance with AMD Geode CPU.
I tried many solutions, but I can only install a CentOS 4.6...
I tried to upgrade it to version 5.2, but i had no luck. The kernel updated without problems (using the patched kernel found here using

"rpm --ignorearch --force --nodeps <package>"

but when i tried to update the other packages I got an error with the RPM program itself...

In my opinion the CentOS 5.2 can run smoothly with Geode, but the installer must be patched so that it doesn't try to get the platform architecture.
Does anyone know how to make an installer patched in this way?

Thanks in advance


2009-02-26 08:13

reporter   ~0008848

I found a solution for my geode based netbook.
I have used CentOS-5.2-installer.iso livecd to boot and install the os.
After boot make a file /etc/rpm/platform and place i686-redhat-linux in it
$ cat /etc/rpm/platform

Then install from the icon on the desktop.



2009-07-09 20:49

reporter   ~0009591

I am running into this issue with CentOS 5.3 on a Soekris Net5501 (Geode LX 500 Mhz). This link:
implies that there is a problem with the kernel package from Red Hat.

Adding rpmarch=i686 helps, but then it crashes later on in the install process.

2009-07-10 12:30

reporter   ~0009594

I dont have a machine to test this or work with this one, so will leave it open and monitor it if anyone wants to go ahead and propose a fix or a process that might make it work


2009-07-10 15:52

reporter   ~0009598

As far as I investigated this IMHO CentOS 5.X can not be installed
on i586 architecture.

The output of /proc/cpuinfo is:

processor : 0
vendor_id : AuthenticAMD
cpu family : 5
model : 10
model name : Geode(TM) Integrated Processor by AMD PCS
stepping : 2
cpu MHz : 498.045
cache size : 128 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu de pse tsc msr cx8 pge cmov clflush mmx mmxext 3dnowext 3dnow up
bogomips : 996.09
clflush size : 32
power management:

Because of cpu family: 5 the yum depsolving is insisting in installing an
i586 kernel package. This package does not exist, only an i686 one.

Yum is ignoring all hints to install for an i686 architecture.


2010-05-08 15:22

reporter   ~0011237

In Fedora this:
is done to make it possible to install with the i686 kernel package.


2010-11-18 10:05

reporter   ~0012080

There is this: bug report.
Maybe the modifications described there can be considered for inclusion in
CentOS-5.6 release.

2011-01-24 14:21


geode-arch.patch (332 bytes)   
diff --git a/rpmUtils/ b/rpmUtils/
index b493b6a..27c6d53 100644
--- a/rpmUtils/
+++ b/rpmUtils/
@@ -15,7 +15,7 @@ arches = {
     # ia32
     "athlon": "i686",
     "i686": "i586",
-    "geode": "i586",
+    "geode": "i686",
     "i586": "i486",
     "i486": "i386",
     "i386": "noarch",

geode-arch.patch (332 bytes)   

2011-01-24 14:22


rpm-4.7.1-geode-i686.patch (343 bytes)   
diff --git a/ b/
index 4a6cca9..d62ddaf 100644
--- a/
+++ b/
@@ -281,7 +281,7 @@ arch_compat: alphaev5: alpha
 arch_compat: alpha: axp noarch
 arch_compat: athlon: i686
-arch_compat: geode: i586
+arch_compat: geode: i686
 arch_compat: pentium4: pentium3
 arch_compat: pentium3: i686
 arch_compat: i686: i586

rpm-4.7.1-geode-i686.patch (343 bytes)   


2011-01-24 14:23

reporter   ~0012370

Fedora is applying the geode-arch.patch since yum-3.2.24-3.fc12.src.rpm and the
rpm-4.7.1-geode-i686.patch since rpm-4.7.1-4.fc12.src.rpm to have geode install

2011-01-27 01:50

reporter   ~0012375

Could some of this changeset required be shipped as an updates.img instead of anaconda's payload being changed at build time ? If so, that would be my first preference; allowing us to ship the main distro as is, and do this for the specific required geode users via an 'alternative' install disk


2011-01-27 17:05

reporter   ~0012382

I did some experiments with updates.img which contain the two files with
the modifications applied. It does not work as expected.
Since I do not know the creation and functionality of updates.img very
well there may be some error in there.
Modifying the files after booting the install media neither works since
they reside in a read only location.
yum-3.2.25-12.el6.src.rpm and rpm-4.8.0-4.el6.src.rpm also apply the
patches and my hope was for CentOS 6 but since the RHEL6.0 Beta2 has
only a PAE-kernel this will also be a no go for geode out of the box.

2011-01-27 17:19


updates.img.tgz (8,292 bytes)


2011-01-27 17:44

reporter   ~0012383

If the updates.img-method is working, I guess it is still required to
have the modifications applied to the yum- and rpm-package to be able
to update and install new packages after the installation.
yum and rpm will still use the wrong arch without the modifications.


2011-09-05 21:26

reporter   ~0013198

the updates.img method was not working, so I rebuilt the anaconda installer images with the 2 patches. The initial (network PXE-)install chugged along nicely and completed sucessfully. I took a pristine i386 install tree from a mirror and compared it to my new tree. The files different are - not surprisingly:

[os]# diff -r i386/ geode/
Binary files i386/images/boot.iso and geode/images/boot.iso differ
Binary files i386/images/diskboot.img and geode/images/diskboot.img differ
Binary files i386/images/minstg2.img and geode/images/minstg2.img differ
Binary files i386/images/pxeboot/initrd.img and geode/images/pxeboot/initrd.img differ
Binary files i386/images/stage2.img and geode/images/stage2.img differ
Binary files i386/images/xen/initrd.img and geode/images/xen/initrd.img differ
Binary files i386/isolinux/initrd.img and geode/isolinux/initrd.img differ
Binary files i386/isolinux/isolinux.bin and geode/isolinux/isolinux.bin differ

NOTE HOWEVER i still had to add rpmarch=i686 on the pxelinux kernel boot line.
I'll try to get the installed image to use yum update without patches later on, by provinding the /etc/rpm/platform file and will keep you posted.


2011-09-05 21:30

reporter   ~0013199

N.B. i am not sure the initrd images need to be different at all, i just don't know the exact anaconda settings the original installer is build with. I think if someone were to spin a new installer with the canon centos build system, the actual files different would only be the Stage2 images.

Issue History

Date Modified Username Field Change
2007-12-18 19:23 vivo New Issue
2007-12-18 23:52 Severity crash => feature
2007-12-18 23:52 Category -OTHER => anaconda
2007-12-18 23:53 Note Added: 0006582
2007-12-18 23:53 Status new => feedback
2007-12-19 09:45 vivo File Added: anaconda.log
2007-12-19 09:46 vivo Note Added: 0006586
2008-07-07 00:06 Note Added: 0007577
2008-07-15 09:31 sander Note Added: 0007641
2008-07-15 09:49 sander Note Added: 0007642
2008-09-13 21:49 Note Added: 0007972
2008-09-13 21:52 Status feedback => acknowledged
2008-09-14 02:50 Note Added: 0007973
2008-09-14 02:51 Status acknowledged => feedback
2008-09-14 09:21 rwmj Note Added: 0007974
2008-09-14 09:55 Note Added: 0007975
2008-09-14 10:39 rwmj Note Added: 0007976
2008-09-14 10:57 rwmj Note Added: 0007977
2008-09-14 10:58 rwmj File Added: anaconda-with-rpmarch.log
2008-10-22 12:15 linickx Note Added: 0008181
2008-11-19 14:47 microplex Note Added: 0008306
2008-12-30 17:19 midasol Note Added: 0008516
2009-02-26 08:13 brampie66 Note Added: 0008848
2009-07-09 20:49 ingham Note Added: 0009591
2009-07-10 12:30 Note Added: 0009594
2009-07-10 15:52 microplex Note Added: 0009598
2010-05-08 15:22 microplex Note Added: 0011237
2010-11-18 10:05 microplex Note Added: 0012080
2011-01-24 14:21 microplex File Added: geode-arch.patch
2011-01-24 14:22 microplex File Added: rpm-4.7.1-geode-i686.patch
2011-01-24 14:23 microplex Note Added: 0012370
2011-01-27 01:50 Note Added: 0012375
2011-01-27 17:05 microplex Note Added: 0012382
2011-01-27 17:19 microplex File Added: updates.img.tgz
2011-01-27 17:44 microplex Note Added: 0012383
2011-09-05 21:26 GinNTonic Note Added: 0013198
2011-09-05 21:30 GinNTonic Note Added: 0013199