View Issue Details

IDProjectCategoryView StatusLast Update
0002554CentOS-4sambapublic2007-12-18 21:28
ReporterJohnnyHughes 
PrioritylowSeverityminorReproducibilityrandom
Status resolvedResolutionunable to reproduce 
Product Version4.6 
Target VersionFixed in Version 
Summary0002554: "msdfs proxy = no" in smb.conf causes shares to be unavailable.
DescriptionSome automated tools for generating samba's smb.conf file (as well as several examples on the internet) will add a line like this in smb.conf files:

msdfs proxy = no

This is not proper for the version of samba in centos-4.6 (or centos-5.x). See the information posted in "additional information" (below) for the proper use of the variable "msdfs proxy".

The fix is to remark out (or remove) msdfs proxy setting.

I did not find anything in centos-4.6 that actually adds this line to the smb.conf file, although SOME versions of samba-swat and kcontrol do add this value ... when I tested the 4.6 versions I could not get it to add that variable.
Additional Informationmsdfs proxy:

This parameter indicates that the share is a stand-in for another CIFS share whose location is specified by the value of the parameter. When clients attempt to connect to this share, they are redirected to the proxied share using the SMB-Dfs protocol.

Only Dfs roots can act as proxy shares. Take a look at the msdfs root and host msdfs options to find out how to set up a Dfs root share.

Example: msdfs proxy = \\otherserver\someshare
TagsNo tags attached.

Issue History

Date Modified Username Field Change
2007-12-18 21:25 JohnnyHughes New Issue
2007-12-18 21:28 JohnnyHughes Status new => resolved
2007-12-18 21:28 JohnnyHughes Resolution open => unable to reproduce
2007-12-18 21:28 JohnnyHughes Note Added: 0006578