View Issue Details

IDProjectCategoryView StatusLast Update
0002661CentOS-5centos-releasepublic2008-06-27 13:08
Reporterkeithel 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.1 
Target VersionFixed in Version5.2 
Summary0002661: yum install without network fails to install (and without warning or error message)
DescriptionWhen trying to install kernel-xen-devel (or any other package for that matter) with yum, I get the following:

-------------% snip --------------
yum --disablerepo=\* --enablerepo=c5-media install kernel-xen-devel
[...]
Installing:
 kernel-xen-devel x86_64 2.6.18-53.el5 c5-media 4.9 M

Transaction Summary
[...]
Total download size: 4.9 M
Is this ok [y/N] y
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID e8562897


Public key for kernel-xen-devel-2.6.18-53.el5.x86_64.rpm is not installed
-------------% snip --------------
(full dump in attachment)

If you note, this doesn't say anything about it not being installed, but alas, kernel devel tools are not present, and you are presented with the same thing when you execute the command again.
Additional InformationMachine setup:
Intel Core 2 Quad
4GB ram
CentOS 5.1 x86_64 installed from DVD media
Asus P5B-VM SE motherboard
Non-functioning RealTek RTL8111b network (built into motherboard)
TagsNo tags attached.

Relationships

has duplicate 0002696 closedkbsingh@karan.org c5-media repo points to wrong GPG key 

Activities

2008-02-08 15:35

 

yum-dvd-install-error.out (1,129 bytes)
keithel

keithel

2008-02-08 15:42

reporter   ~0006850

So, it seems from this, that the gpg keys for these packages are one of:
* yum is not configured properly to find the gpg keys on the DVD media (mounted at /mnt/cdrom)
* the GPG keys for these packages are not present on the DVD media.

When I force gpgcheck off, things install.
This still looks like a bug to me.
range

range

2008-02-08 16:06

administrator   ~0006851

You can install the keys from /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5, as *should* be referenced from the Centos-Media.repo file.

But true, this one references the Beta key.
range

range

2008-02-08 16:08

administrator   ~0006852

Changing to centos-release package. Severity is trivial. Should be changed in the next centos-release package.
keithel

keithel

2008-02-08 19:49

reporter   ~0006857

Thank you range -- that worked like a charm.

I just wish yum would fallback to non-network sources without having to specially-exclude repository specifiers -- if you have no network, on a default install with full DVD inserted, 'yum install foo' will fail looking for the network update repo.
range

range

2008-02-20 09:52

administrator   ~0006910

Upgraded to blocker. Needs to be fixed for next centos-release package
JohnnyHughes

JohnnyHughes

2008-02-23 13:00

administrator   ~0006926

the rub is, we purposely use the http:// key because we control that location.

some bad guy COULD put out a bad CD ... BUT they can't put their bad key on our mirror.
range

range

2008-02-23 17:35

administrator   ~0006927

But that defies the usage of the Media-Repo. Maybe better put a line of text in there to either disable gpg (bad idea) or get the key from somewhere before trying to install from the repo?
toracat

toracat

2008-06-19 20:03

manager   ~0007414

Fixed in 5.2.
keithel

keithel

2008-06-19 21:04

reporter   ~0007415

I'm curious -- what was the ultimate fix for this (if someone knows off the top of their head)?
toracat

toracat

2008-06-19 21:46

manager   ~0007416

The "fix" in note 7414 was with respect to the Centos-Media.repo file. It no longer refers to the Beta key.

About the location of the key (local versus remote), please see this thread in the mailing list:

http://lists.centos.org/pipermail/centos-devel/2008-February/004248.html

Issue History

Date Modified Username Field Change
2008-02-08 15:35 keithel New Issue
2008-02-08 15:35 keithel File Added: yum-dvd-install-error.out
2008-02-08 15:42 keithel Note Added: 0006850
2008-02-08 16:06 range Note Added: 0006851
2008-02-08 16:07 range Status new => acknowledged
2008-02-08 16:08 range Note Added: 0006852
2008-02-08 16:08 range Severity major => trivial
2008-02-08 16:08 range Category yum => centos-release
2008-02-08 19:49 keithel Note Added: 0006857
2008-02-20 09:50 range Relationship added has duplicate 0002696
2008-02-20 09:52 range Note Added: 0006910
2008-02-20 09:52 range Severity trivial => block
2008-02-23 13:00 JohnnyHughes Note Added: 0006926
2008-02-23 17:35 range Note Added: 0006927
2008-06-19 20:03 toracat Note Added: 0007414
2008-06-19 21:04 keithel Note Added: 0007415
2008-06-19 21:46 toracat Note Added: 0007416
2008-06-27 13:08 timverhoeven Status acknowledged => resolved
2008-06-27 13:08 timverhoeven Fixed in Version => 5.2
2008-06-27 13:08 timverhoeven Resolution open => fixed