View Issue Details

IDProjectCategoryView StatusLast Update
0002700CentOS-5net-snmppublic2013-03-22 17:35
Reportermichael_hobbs 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version5.1 
Target VersionFixed in Version5.1 
Summary0002700: snmpd in 5.3.1-19.el5_1.4 throws undefined symbol with default config
Description[root@yoshimitsu ~]# snmpd -f
snmpd: symbol lookup error: snmpd: undefined symbol: smux_snmp_select_list_get_length


5.3.1-19.el5_1.3 works just fine. I'm glad to provide any more info if needed.
TagsNo tags attached.

Activities

benjav

benjav

2008-03-12 14:33

reporter   ~0007021

Seems to be a dependency problem - just updating net-snmp doesn't update net-snmp-libs. The combination of net-snmp 5.3.1-19.el5_1.4 and net-snmp-libs 5.3.1-19.el5_1.3 leads to the described error, updating net-snmp-libs solves it.
YonatanE

YonatanE

2008-07-22 11:54

reporter   ~0007737

We had the same problem using Centos 4.5 :\

 /usr/sbin/snmpd -f -Lf /dev/null -p /var/run/snmpd.pid -a
/usr/sbin/snmpd: symbol lookup error: /usr/sbin/snmpd: undefined symbol: smux_snmp_select_list_get_length


we've fix this problem using:

yum upgrade net-snmp-libs
jm77

jm77

2009-01-22 22:15

reporter   ~0008616

I was able to reproduce the issue. Upgrading net-snmp-libs as suggested resolved the problem.
tigalch

tigalch

2013-03-22 17:35

manager   ~0016812

marking as solved per reporters feedback

Issue History

Date Modified Username Field Change
2008-02-20 22:16 michael_hobbs New Issue
2008-03-12 14:33 benjav Note Added: 0007021
2008-07-22 11:54 YonatanE Note Added: 0007737
2009-01-22 22:15 jm77 Note Added: 0008616
2013-03-22 17:35 tigalch Note Added: 0016812
2013-03-22 17:35 tigalch Status new => resolved
2013-03-22 17:35 tigalch Fixed in Version => 5.1
2013-03-22 17:35 tigalch Resolution open => fixed