View Issue Details

IDProjectCategoryView StatusLast Update
0002934CentOS-5httpdpublic2011-10-14 20:25
Reporterasautins 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version5.2 
Target VersionFixed in Version 
Summary0002934: /usr/sbin/apxs cannot open config_vars.mk
Description  After installing apxs ( yum install httpd-devel ), the following error is reported when executing /usr/sbin/apxs:

cannot open /httpd/build/config_vars.mk: No such file or directory at /usr/sbin/apxs line 201.

  It appears the problem is that `pkg-config --variable=libdir apr-1` does not return anything ( returns /usr/lib64 on Centos 5.1 installation ) so the path is not built correctly.
Additional Information  The following is the transcript of installing and executing /usr/sbin/apxs:

[root@localhost ~]# yum install httpd-devel
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * base: mirror.chpc.utah.edu
 * updates: mirrors.easynews.com
 * addons: mirrors.easynews.com
 * extras: styx.biochem.wfubmc.edu
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package httpd-devel.i386 0:2.2.3-11.el5_1.centos.3 set to be updated
---> Package httpd-devel.x86_64 0:2.2.3-11.el5_1.centos.3 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package Arch Version Repository Size
=============================================================================
Installing:
 httpd-devel i386 2.2.3-11.el5_1.centos.3 base 146 k
 httpd-devel x86_64 2.2.3-11.el5_1.centos.3 base 147 k

Transaction Summary
=============================================================================
Install 2 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 293 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): httpd-devel-2.2.3- 100% |=========================| 147 kB 00:02
(2/2): httpd-devel-2.2.3- 100% |=========================| 146 kB 00:02
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: httpd-devel ######################### [1/2]
  Installing: httpd-devel ######################### [2/2]

Installed: httpd-devel.i386 0:2.2.3-11.el5_1.centos.3 httpd-devel.x86_64 0:2.2.3-11.el5_1.centos.3
Complete!
[root@localhost ~]# apxs
cannot open /httpd/build/config_vars.mk: No such file or directory at /usr/sbin/apxs line 201.
TagsNo tags attached.

Relationships

related to 0003084 feedbackkbsingh@karan.org yum Testing tracking bug: Report all problems here. 

Activities

range

range

2008-06-29 21:41

administrator   ~0007520

Acknowledged - apr-devel is missing the .pc files.
range

range

2008-06-29 21:49

administrator   ~0007521

Looks like httpd-devel only requires apr-devel, which seems to install the i386 versions of apr-devel and not the x86_64 version. If that one is installed apxs works fine.
asautins

asautins

2008-06-30 16:21

reporter   ~0007525

I believe apr-util-devel and expat-devel for x64 is not included properly as a dependency for httpd-devel. Note the following:

[root@localhost ~]# yum install httpd-devel
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * base: mirror.raystedman.net
 * updates: mirror.sanctuaryhost.com
 * addons: mirror.newnanutilities.org
 * extras: mirrors.tummy.com
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package httpd-devel.i386 0:2.2.3-11.el5_1.centos.3 set to be updated
--> Processing Dependency: apr-util-devel for package: httpd-devel
---> Package httpd-devel.x86_64 0:2.2.3-11.el5_1.centos.3 set to be updated
--> Running transaction check
---> Package apr-util-devel.i386 0:1.2.7-7.el5 set to be updated
--> Processing Dependency: expat-devel for package: apr-util-devel
--> Running transaction check
---> Package expat-devel.i386 0:1.95.8-8.2.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package Arch Version Repository Size
=============================================================================
Installing:
 httpd-devel i386 2.2.3-11.el5_1.centos.3 base 146 k
 httpd-devel x86_64 2.2.3-11.el5_1.centos.3 base 147 k
Installing for dependencies:
 apr-util-devel i386 1.2.7-7.el5 base 54 k
 expat-devel i386 1.95.8-8.2.1 base 130 k

Transaction Summary
=============================================================================
Install 4 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 477 k
Is this ok [y/N]: y
Downloading Packages:
(1/4): httpd-devel-2.2.3- 100% |=========================| 147 kB 00:00
(2/4): apr-util-devel-1.2 100% |=========================| 54 kB 00:00
(3/4): httpd-devel-2.2.3- 100% |=========================| 146 kB 00:00
(4/4): expat-devel-1.95.8 100% |=========================| 130 kB 00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: expat-devel ######################### [1/4]
  Installing: apr-util-devel ######################### [2/4]
  Installing: httpd-devel ######################### [3/4]
  Installing: httpd-devel ######################### [4/4]

Installed: httpd-devel.i386 0:2.2.3-11.el5_1.centos.3 httpd-devel.x86_64 0:2.2.3-11.el5_1.centos.3
Dependency Installed: apr-util-devel.i386 0:1.2.7-7.el5 expat-devel.i386 0:1.95.8-8.2.1
Complete!
[root@localhost ~]# pkg-config --variable=libdir apr-util-1 [root@localhost ~]# yum install apr-util-devel
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * base: mirror.raystedman.net
 * updates: mirror.sanctuaryhost.com
 * addons: mirror.newnanutilities.org
 * extras: mirrors.tummy.com
Setting up Install Process
Parsing package install arguments
Package apr-util-devel - 1.2.7-7.el5.i386 is already installed.
Resolving Dependencies
--> Running transaction check
---> Package apr-util-devel.x86_64 0:1.2.7-7.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package Arch Version Repository Size
=============================================================================
Installing:
 apr-util-devel x86_64 1.2.7-7.el5 base 54 k

Transaction Summary
=============================================================================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 54 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): apr-util-devel-1.2 100% |=========================| 54 kB 00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: apr-util-devel ######################### [1/1]

Installed: apr-util-devel.x86_64 0:1.2.7-7.el5
Complete!
[root@localhost ~]# yum install expat-devel
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * base: mirror.raystedman.net
 * updates: centos.mirrors.redwire.net
 * addons: mirror.newnanutilities.org
 * extras: mirrors.tummy.com
Setting up Install Process
Parsing package install arguments
Package expat-devel - 1.95.8-8.2.1.i386 is already installed.
Resolving Dependencies
--> Running transaction check
---> Package expat-devel.x86_64 0:1.95.8-8.2.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package Arch Version Repository Size
=============================================================================
Installing:
 expat-devel x86_64 1.95.8-8.2.1 base 127 k

Transaction Summary
=============================================================================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 127 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): expat-devel-1.95.8 100% |=========================| 127 kB 00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: expat-devel ######################### [1/1]

Installed: expat-devel.x86_64 0:1.95.8-8.2.1
Complete!
[root@localhost ~]# pkg-config --variable=libdir apr-util-1
/usr/lib64
range

range

2008-07-01 16:02

administrator   ~0007540

Seems to be a bug in yum. Forget my earlier remarks.

See http://lists.centos.org/pipermail/centos-devel/2008-June/004808.html
timverhoeven

timverhoeven

2008-07-01 17:19

developer   ~0007541

Closing bug. This is not a bug but a change in the behaviour of yum itself.
toracat

toracat

2008-07-03 17:58

manager   ~0007563

I think this report should be left open. Bad misbehavior like this may qualify as a "bug". It's been fixed upstream and the patched version will be made available[1]. When that eventually happens, this report may be marked "resolved".

[1] http://lists.centos.org/pipermail/centos-devel/2008-June/004808.html
yallaone

yallaone

2008-08-26 20:46

reporter   ~0007863

I see same problem as described. Even after installing apr-devel I get the same error with /usr/lib64 not being prepended.
Output of
# rpm -q --qf '%{name}-%{version}-%{release}.%{arch}\n"
httpd-devel-2.2.3-11.el5_1.centos.3.i386
httpd-devel-2.2.3-11.el5_1.centos.3.x86_64
apr-devel-1.2.7-11.i386

#
Thanks!
toracat

toracat

2008-08-27 00:35

manager   ~0007865

(1) yallaone,

Until the problem is solved, you need to specify the arch like so:

yum install apr-devel.x86_64

(2) The version of yum that fixes the bug reported in here is now in the testing repository. See:

http://lists.centos.org/pipermail/centos-devel/2008-August/003107.html
http://bugs.centos.org/view.php?id=3084

(3) Due to a recent renumbering of the entries in the CentOS mailing lists, the URL in Note 7563 above is no longer valid. The new URL is:

http://lists.centos.org/pipermail/centos-devel/2008-June/002955.html
range

range

2008-09-02 17:00

administrator   ~0007909

Can the reporter please check if the yum in testing (see note above) fixes that issue, so we can close this bug report?
mickh

mickh

2008-10-11 09:29

reporter   ~0008115

I too have this problem while attempting to build PHP 5.2.5 from Fedora SRPM. All dependencies satisfied and build goes well until configuring DSO module.

Started with exact problem described above. This didn't fix it:

yum install apr-devel.x86_64

but it did change the error message a bit:

The output of /usr/sbin/apxs follows:
-02 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic
apxs:Error: /usr/bin/apu-1-config not found!.
configure: error: Aborting
range

range

2008-10-11 12:07

administrator   ~0008116

mickh: No, you don't, you are just missing the package which contains apu-1-config. But this is not a support venue, it is a bug tracker.

So please take this issue to either the mailing lists or the forums, if you cannot figure it out yourself.
mickh

mickh

2008-10-11 12:35

reporter   ~0008117

OK, well not sure if this should go here or on the mailing list, but installing the latest yum package in testing (yum 3.2.19-9.el5.centos.noarch.rpm) fixed this issue for me and allowed packages to build.
toracat

toracat

2011-10-14 20:25

manager   ~0013544

Closing this very old bug report as 'resolved'.

Issue History

Date Modified Username Field Change
2008-06-29 04:46 asautins New Issue
2008-06-29 21:41 range Note Added: 0007520
2008-06-29 21:41 range Status new => acknowledged
2008-06-29 21:49 range Note Added: 0007521
2008-06-30 16:21 asautins Note Added: 0007525
2008-07-01 16:02 range Note Added: 0007540
2008-07-01 17:19 timverhoeven Status acknowledged => closed
2008-07-01 17:19 timverhoeven Note Added: 0007541
2008-07-01 17:19 timverhoeven Resolution open => not fixable
2008-07-03 17:58 toracat Status closed => feedback
2008-07-03 17:58 toracat Resolution not fixable => reopened
2008-07-03 17:58 toracat Note Added: 0007563
2008-08-26 20:46 yallaone Note Added: 0007863
2008-08-27 00:35 toracat Note Added: 0007865
2008-09-02 17:00 range Note Added: 0007909
2008-09-05 15:53 toracat Relationship added related to 0003084
2008-10-11 09:29 mickh Note Added: 0008115
2008-10-11 12:07 range Note Added: 0008116
2008-10-11 12:35 mickh Note Added: 0008117
2011-10-14 20:25 toracat Note Added: 0013544
2011-10-14 20:25 toracat Status feedback => resolved
2011-10-14 20:25 toracat Resolution reopened => fixed
2011-10-14 20:25 toracat Description Updated View Revisions
2011-10-14 20:25 toracat Additional Information Updated View Revisions