View Issue Details

IDProjectCategoryView StatusLast Update
0002937CentOS-5-OTHERpublic2008-07-21 11:33
Reporterdrak 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Platformi386OSCentOSOS Version5.2
Product Version5.2 
Target VersionFixed in Version 
Summary0002937: incompatible image for kickstart installation
DescriptionSince the update to 5.2 the images stored in os/i386/images are incompatible for kickstart installation pointing to url http://mirror.centos.org/centos/5/os/i386. When you try to install a kickstart installation with these it complains about compatibility. If I change the URL to the 5.1 tree http://mirror.centos.org/centos/5.1/os/i386 it works fine. I suspect they were left out of the update.
Steps To ReproduceCreate ks file:

install
url --url http://mirror.centos.org/centos/5/os/i386
lang en_US.UTF-8
network --device eth0 --bootproto static --ip 38.66.12.204 --netmask 255.255.255.128 --gateway 38.66.12.129 --nameserver 4.2.2.1
rootpw hidden
firstboot --disabled
firewall --disabled
authconfig --enableshadow --enablemd5
selinux --disabled
timezone US/Pacific
bootloader --location=mbr --driveorder=xvda --append="console=xvc0"
reboot

# Partitioning
#clearpart --all --initlabel --drives=xvda
part /boot --fstype ext3 --size=100 --grow --ondisk=xvda1
part swap --grow --size=512 --ondisk=xvda2
part / --fstype ext3 --grow --size=1200 --ondisk=xvda3

%packages --nobase
@ Core
TagsNo tags attached.

Activities

tru

tru

2008-07-09 15:50

administrator   ~0007606

no longer an issue (was caused by not yet updated mirrors during 5.1->5.2 transition)
drak

drak

2008-07-14 01:58

reporter   ~0007631

Doesnt appear to have been resolve - I still get errors:

              +-----------------+ HTTP Setup +------------------+
              | |
              | Please enter the following information: |
              | |
              | o the name or IP number of your Web server |
              | o the directory on that server containing |
              | CentOS for your architecture |
              | |
              | Web site name: mirror.centos.org_______ |
              | CentOS directory: /centos/5.2/os/i386_____ |
              | |
              | +----+ +------+ |
              | | OK | | Back | |
              | +----+ +------+ |
              | |
              | |
              +-------------------------------------------------+

    +----------------------------+ Retrieving +----------------------------+
    | |
    | Retrieving images/minstg2.img... |
    | |
    +----------------------------------------------------------------------+
 
                     +-------------+ Error +-------------+
                     | |
                     | The CentOS installation tree in |
                     | that directory does not seem to |
                     | match your boot media. |
                     | |
                     | +----+ |
                     | | OK | |
                     | +----+ |
                     | |
                     | |
                     +-----------------------------------+

But changing

CentOS directory: /centos/5.2/os/i386_____

to:

CentOS directory: /centos/5.1/os/i386_____

Works. Using /centos/5/os/i386 also fails.

Drak
tru

tru

2008-07-17 09:36

administrator   ~0007664

could you md5sum your vmlinuz/initrd,img files ?

They should be like:
[tru@sillage pxeboot]$ ll initrd.img vmlinuz
total 7328
-rw-rw-r-- 1 pvm centos_gid 5669675 Jun 19 17:05 initrd.img
-rw-rw-r-- 1 pvm centos_gid 1806388 Jun 19 17:05 vmlinuz
[tru@sillage pxeboot]$ md5sum vmlinuz initrd.img
ce39b88a01d40745677be9ac7fb06da5 vmlinuz
e4197b05b0fca8020bda204f8da19bf3 initrd.img

if they don't match you are not using the right files
drak

drak

2008-07-17 10:56

reporter   ~0007672

They match.

[root@dan pxeboot]# md5sum vmlinuz
ce39b88a01d40745677be9ac7fb06da5 vmlinuz
[root@dan pxeboot]# md5sum initrd.img
e4197b05b0fca8020bda204f8da19bf3 initrd.img

I wasnt aware the system was these pxeboot images, can you tell me the md5sum on images/minstg2.img that is shown to be loaded? Here are my values from the 5.2 directory:

[root@dan images]# md5sum minstg2.img
00ae357cd9a6a6d939d7eb8c283412d0 minstg2.img
[root@dan images]# md5sum stage2.img
74c12464f9690234fbcaf703b39ebe2f stage2.img

And from the 5.1 tree you can see just stage2.img is different

[root@dan images]# md5sum minstg2.img
ma9bf65528d4542e47fba2eb065e342d0 minstg2.img
[root@dan images]# md5sum stage2.img
65e0bdec44e804b378f9b5f4809ce0fa stage2.img
tru

tru

2008-07-17 12:36

administrator   ~0007677

[tru@sillage images]$ pwd
/var/ftp/pub/linux/centos/5.2/os/i386/images

[tru@sillage images]$ md5sum minstg2.img stage2.img
00ae357cd9a6a6d939d7eb8c283412d0 minstg2.img
74c12464f9690234fbcaf703b39ebe2f stage2.img

Your files look fine to me. Do you mind sharing your ks.cfg file?

I just re-installed a test machine here without any problem from
my local centos tree.

pxelinux.cfg entry:

LABEL c5/serial
 MENU LABEL ^b) centos 5 i386 ks minimal/serial console @38400
 KERNEL centos5.x86/vmlinuz
 APPEND initrd=centos5.x86/initrd.img noipv6 lang=en ip=dhcp syslog=10.0.0.4 ks=http://10.0.0.4/ks/c5-min-serial_jones.cfg console=ttyS0,38400n

c5-min-serial_jones.cfg:
install
text
cmdline
reboot
url --url ftp://10.0.0.4//pub/linux/centos/5/os/i386
repo --name=TOTO --baseurl=ftp://10.0.0.4/pub/linux/centos/5/updates/i386

lang en_US.UTF-8
keyboard us
xconfig --driver "nv" --resolution 800x600 --depth 24
# -> useless minimal install does not come with X
network --device eth0 --bootproto dhcp
rootpw --iscrypted xxxxxxxxxxxxxxxxxxxxx
firewall --enabled --port=22:tcp
authconfig --enableshadow --enablemd5
selinux --enforcing
timezone --utc Europe/Paris
bootloader --location=mbr --driveorder=hda
clearpart --all --drives=hda
part /boot --size=256 --asprimary --ondisk=hda --fstype ext3
part / --size=16384 --asprimary --ondisk=hda --fstype ext3
part swap --size=1024 --asprimary --ondisk=hda --fstype swap
part /work --size 1 --ondisk=hda --grow --fstype ext3

%packages
-Deployment_Guide-en-US
-gnu-efi



minicom log:
Loading centos5.x86/vmlinuz................................
Loading centos5.x86/initrd.img..................................................
Linux version 2.6.18-92.el5 (mockbuild@builder16.centos.org) (gcc version 4.1.28
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
...
Running anaconda, the CentOS system installer - please wait...
Probing for video card: nVidia Corporation NV11DDR [GeForce2 MX200]
Running pre-install scripts
Retrieving installation information...
In progress... Completed Completed
Retrieving installation information for TOTO...
In progress... Completed Completed
Checking dependencies in packages selected for installation...
In progress...
Formatting / file system...
In progress...
Formatting /work file system...
In progress...
Formatting /boot file system...
In progress...
Starting install process. This may take several minutes...
Preparing transaction from installation source...
In progress...
Installing libgcc-4.1.2-42.el5... Done [1/345]
....
Installing yum-updatesd-0.9-2.el5... Done [343/345]
Installing coolkey-1.1.0-6.el5... Done [344/345]
Installing NetworkManager-0.6.4-8.el5... Done [345/345]
Performing post install configuration...
Installing bootloader...
Running post-install scripts
sending termination signals...done

vsftpd.log:
Thu Jul 17 14:11:01 2008 8 10.0.0.201 93143040 //pub/linux/centos/5/os/i386/images/stage2.img b _ o a rhinstall@ ftp 0 * c
Thu Jul 17 14:11:28 2008 1 10.0.0.201 1140 /pub/linux/centos/5.2/os/i386/repodata/repomd.xml b _ o a anonymous@ ftp 0 * c
Thu Jul 17 14:11:28 2008 1 10.0.0.201 876639 /pub/linux/centos/5.2/os/i386/repodata/primary.xml.gz b _ o a anonymous@ ftp 0 * c
Thu Jul 17 14:11:33 2008 1 10.0.0.201 951 /pub/linux/centos/5.2/updates/i386/repodata/repomd.xml b _ o a anonymous@ ftp 0 * c
Thu Jul 17 14:11:33 2008 1 10.0.0.201 141848 /pub/linux/centos/5.2/updates/i386/repodata/primary.xml.gz b _ o a anonymous@ ftp 0 * c
....
Thu Jul 17 14:18:12 2008 1 10.0.0.201 409650 /pub/linux/centos/5.2/os/i386/CentOS/NetworkManager-0.6.4-8.el5.i386.rpm b _ o a anonymous@ ftp 0 * c
drak

drak

2008-07-17 13:04

reporter   ~0007679

install
url --url http://mirror.centos.org/centos/5/os/i386
lang en_US.UTF-8
network --device eth0 --bootproto static --ip 38.99.6.204 --netmask 255.255.255.128 --gateway 38.99.6.129 --nameserver 4.2.2.1
rootpw XLkmh9231DaV
firstboot --disabled
firewall --disabled
authconfig --enableshadow --enablemd5
selinux --disabled
timezone US/Pacific
bootloader --location=mbr --driveorder=xvda --append="console=xvc0"
reboot

# Partitioning
clearpart --all --initlabel --drives=xvda,xvdb,xvdc
part /boot --fstype ext3 --size=200 --grow --ondisk=xvda
part swap --grow --size=1024 --ondisk=xvdb
part / --fstype ext3 --grow --size=2000 --ondisk=xvdc

%packages --nobase
@ Core
tru

tru

2008-07-17 13:21

administrator   ~0007682

you are using a xen virtual machine?
<quote>
bootloader --location=mbr --driveorder=xvda --append="console=xvc0"
</quote>

What about starting with the obvious?
The xen kernel/initrd are in 5.2/os/i386/images/xen
drak

drak

2008-07-18 04:38

reporter   ~0007704

Yes it's Xen guess install. It works fine installing on the 5.1 tree. I even copied the images from where you suggested and boot the guest on those images still a problem looks for images/minstg2.img then gives the error. I had originally experienced this problem on a local mirror but then changed to using the central centos mirror in case my mirror wasnt in sync correctly. I feel everything is correct my side because everything installs fine specifying 5.1 in the install path rather than 5 or 5.2 - so surely it can only be something with the centos tree? seems like a bug but maybe I am missing something?

I get the same result using the ISO as a source.
kai

kai

2008-07-20 18:02

reporter   ~0007716

Just hit the same problem. You have to replace all your files in tftpboot with the latest ones from the CentOS 5.2 repo/DVD, plus copy /usr/lib/syslinux/pxelinux.0 on your system to your tftpboot directory. I had not done the latter.
tru

tru

2008-07-21 11:33

administrator   ~0007724

operator error wrong (version 5.1) xen kernel/initrd used to bootstrap a 5.2 installation

Issue History

Date Modified Username Field Change
2008-06-30 08:23 drak New Issue
2008-07-09 15:50 tru Status new => closed
2008-07-09 15:50 tru Note Added: 0007606
2008-07-09 15:50 tru Resolution open => fixed
2008-07-14 01:58 drak Status closed => feedback
2008-07-14 01:58 drak Resolution fixed => reopened
2008-07-14 01:58 drak Note Added: 0007631
2008-07-17 09:36 tru Note Added: 0007664
2008-07-17 10:56 drak Note Added: 0007672
2008-07-17 12:36 tru Note Added: 0007677
2008-07-17 13:04 drak Note Added: 0007679
2008-07-17 13:21 tru Note Added: 0007682
2008-07-18 04:38 drak Note Added: 0007704
2008-07-20 18:02 kai Note Added: 0007716
2008-07-21 11:33 tru Status feedback => closed
2008-07-21 11:33 tru Note Added: 0007724
2008-07-21 11:33 tru Resolution reopened => fixed