View Issue Details

IDProjectCategoryView StatusLast Update
0002956CentOS-5squidpublic2009-02-18 16:30
ReporterClement VERET 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.2 
Target VersionFixed in Version5.3 
Summary0002956: squid_unix_group makes squid crashes when trying to authenticate
DescriptionDescription of problem:

Squid totally crashes when trying to filter access with squid_unix_group
components with messages :
/var/log/messages :
Jul 7 11:21:11 test-01 squid[5207]: Squid Parent: child process 5396 started
Jul 7 11:21:19 test-01 kernel: squid_unix_grou[5407]: segfault at
00000000000000bf rip 00002b7d586c04a5 rsp 00007fff5321bd60 error 4
Jul 7 11:21:19 test-01 kernel: squid_unix_grou[5408]: segfault at
00000000000000bf rip 00002afb757fe4a5 rsp 00007fff360dbc20 error 4
Jul 7 11:21:20 test-01 kernel: squid_unix_grou[5409]: segfault at
00000000000000bf rip 00002b0781eb74a5 rsp 00007fff29a25570 error 4
Jul 7 11:21:20 test-01 squid[5207]: Squid Parent: child process 5396 exited due
to signal 6
Jul 7 11:21:23 test-01 squid[5207]: Squid Parent: child process 5431 started
Jul 7 11:21:31 test-01 kernel: squid_unix_grou[5443]: segfault at
00000000000000bf rip 00002abf60e624a5 rsp 00007fff4aa785c0 error 4
Jul 7 11:21:31 test-01 kernel: squid_unix_grou[5444]: segfault at
00000000000000bf rip 00002b9a0770d4a5 rsp 00007fffa41ccd10 error 4
Jul 7 11:21:31 test-01 (squid): The unix_group helpers are crashing too
rapidly, need help!
Jul 7 11:21:31 test-01 squid[5207]: Squid Parent: child process 5431 exited due
to signal 6
Jul 7 11:21:31 test-01 squid[5207]: Exiting due to repeated, frequent failures


Version-Release number of selected component (if applicable):
Bug available since kernel 2.6.18-92 (works fine before that)
Squid version : Version 2.6.STABLE6

How reproducible:
Just make squid_unix_group authentication available through :
/etc/squid/squid.conf:
external_acl_type unix_group %LOGIN /usr/lib64/squid/squid_unix_group
acl AccessInternet external unix_group MyInternetAccessGroup
Additional InformationStarts to crash after updating kernel from 2.6.18-53 to 2.6.18-92

Already reported to upstream : https://bugzilla.redhat.com/show_bug.cgi?id=454255
TagsNo tags attached.

Activities

2008-07-10 07:07

 

squid-2.6.STABLE6-external_acl.patch (603 bytes)
diff -aburN squid-2.6.STABLE6.ori/helpers/external_acl/unix_group/check_group.c squid-2.6.STABLE6/helpers/external_acl/unix_group/check_group.c
--- squid-2.6.STABLE6.ori/helpers/external_acl/unix_group/check_group.c	2006-05-22 22:42:05.000000000 +0200
+++ squid-2.6.STABLE6/helpers/external_acl/unix_group/check_group.c	2008-07-09 15:45:41.000000000 +0200
@@ -177,6 +177,8 @@
 	    exit(1);
 	}
     }
+    /* Put the last value of the table grents to NULL to avoid segfault */
+    grents[i] = NULL;
     if (optind < argc) {
 	fprintf(stderr, "Unknown option '%s'\n", argv[optind]);
 	usage(argv[0]);
Clement VERET

Clement VERET

2008-07-10 07:08

reporter   ~0007612

I posted a patch that correct the issue in the squid_unix_group program. But apparently that doesn't interest Red Hat, the problem is not correct :(.
range

range

2008-07-10 09:23

administrator   ~0007616

Upstream issue, let's wait what comes out of there. Thanks for reporting.
Clement VERET

Clement VERET

2008-07-28 09:51

reporter   ~0007765

Upstram has accepted the patch but it is uncommited yet. Hope this will come soon. I think we can close this ticket, no ?
range

range

2008-07-28 10:37

administrator   ~0007766

Want to wait until an errata is out?
range

range

2009-02-18 16:30

administrator   ~0008732

Will be fixed in 5.3

Issue History

Date Modified Username Field Change
2008-07-07 10:53 Clement VERET New Issue
2008-07-10 07:07 Clement VERET File Added: squid-2.6.STABLE6-external_acl.patch
2008-07-10 07:08 Clement VERET Note Added: 0007612
2008-07-10 09:23 range Note Added: 0007616
2008-07-10 09:23 range Status new => acknowledged
2008-07-28 09:51 Clement VERET Note Added: 0007765
2008-07-28 10:37 range Note Added: 0007766
2009-02-18 16:30 range Note Added: 0008732
2009-02-18 16:30 range Status acknowledged => resolved
2009-02-18 16:30 range Fixed in Version => 5.3
2009-02-18 16:30 range Resolution open => fixed