View Issue Details

IDProjectCategoryView StatusLast Update
0003130CentOS-4kernelpublic2009-08-29 17:50
Reporterst 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7 
Target VersionFixed in Version4.8 
Summary0003130: kernel-2.6.9-78.0.1.EL.i586 does not boot
DescriptionAfter the upgrade from CentOS 4.6 to 4.7 on an i586 machine (VIA C3 processor), the machine no longer boots. I get the grub menu, then a blank screen and the machine immediately restarts, resulting in an endless cycle.

It looks to me like the new kernel package for the i586 architecture (2.6.9-78.0.1.EL) is compiled for i686 instead:

$ rpm -q --queryformat "%{NAME}-%{VERSION}-%{RELEASE} %{ARCH}\n" kernel
kernel-2.6.9-67.0.15.EL i586
kernel-2.6.9-67.0.20.EL i586
kernel-2.6.9-67.0.22.EL i586
kernel-2.6.9-78.0.1.EL i586
                       ^^^^

$ grep 'CONFIG_M[56]86=y' /boot/config*
/boot/config-2.6.9-67.0.15.EL:CONFIG_M586=y
/boot/config-2.6.9-67.0.20.EL:CONFIG_M586=y
/boot/config-2.6.9-67.0.22.EL:CONFIG_M586=y
/boot/config-2.6.9-78.0.1.EL:CONFIG_M686=y
                             ^^^^^^^^^^^^^
TagsNo tags attached.

Relationships

has duplicate 0003158 closedJohnnyHughes kernel loading reboot computer on pentium 166 mmx 
has duplicate 0003203 resolvedJohnnyHughes boot failed for install disk on i586 machines 
has duplicate 0003439 resolvedJohnnyHughes 4.7 Installation cd won't boot on my amd-k6 system 
related to 0003792 resolvedJohnnyHughes i586 kernel fails to boot on Pentium-166 

Activities

toracat

toracat

2008-09-13 20:52

manager   ~0007971

I confirm this. kernel-2.6.9-78.0.1.EL.i586.rpm has the 686 bits switched on. I also found that the cplus kernel (kernel-2.6.9-78.0.1.plus.c4.i586.rpm) correctly has 586 enabled. Until the fix is done, maybe this is a temporary solution?
Milan Kerslager

Milan Kerslager

2008-09-15 06:37

reporter   ~0007982

Confirmed.
toracat

toracat

2008-09-15 07:21

manager   ~0007983

I would also like to note that the original kernel in CentOS 4.7 (kernel-2.6.9-78.EL.i586.rpm) has the same issue but its centosplus counterpart (kernel-2.6.9-78.plus.c4.i586.rpm) is correct.
iay

iay

2008-09-16 11:55

reporter   ~0007994

I'm seeing this as well. At the moment, I'm running the affected system on the last issued kernel for CentOS 4.6, which appears to be working.
kbsingh@karan.org

kbsingh@karan.org

2008-09-17 15:07

administrator   ~0008010

If someone wants to submit a patch, I can work on pushing fixed packages ( and if required, an alternate boot.iso )

2008-09-17 16:14

 

kernel-2.6.9-i586.config.diff (1,318 bytes)
--- oldconfig/kernel-2.6.9-i586.config	2008-09-17 09:02:18.000000000 -0700
+++ newconfig/kernel-2.6.9-i586.config	2008-09-17 09:08:12.000000000 -0700
@@ -2,7 +2,7 @@
 #
 # Automatically generated make config: don't edit
 # Linux kernel version: 2.6.9-prep
-# Thu Jul 24 22:10:07 2008
+# Tue Sep 16 12:51:10 2008
 #
 CONFIG_X86=y
 CONFIG_MMU=y
@@ -75,10 +75,10 @@
 # CONFIG_X86_ES7000 is not set
 # CONFIG_M386 is not set
 # CONFIG_M486 is not set
-# CONFIG_M586 is not set
+CONFIG_M586=y
 # CONFIG_M586TSC is not set
 # CONFIG_M586MMX is not set
-CONFIG_M686=y
+# CONFIG_M686 is not set
 # CONFIG_MPENTIUMII is not set
 # CONFIG_MPENTIUMIII is not set
 # CONFIG_MPENTIUMM is not set
@@ -98,13 +98,13 @@
 CONFIG_X86_L1_CACHE_SHIFT=7
 CONFIG_RWSEM_XCHGADD_ALGORITHM=y
 CONFIG_X86_PPRO_FENCE=y
+CONFIG_X86_F00F_BUG=y
 CONFIG_X86_WP_WORKS_OK=y
 CONFIG_X86_INVLPG=y
 CONFIG_X86_BSWAP=y
 CONFIG_X86_POPAD_OK=y
-CONFIG_X86_GOOD_APIC=y
+CONFIG_X86_ALIGNMENT_16=y
 CONFIG_X86_INTEL_USERCOPY=y
-CONFIG_X86_USE_PPRO_CHECKSUM=y
 # CONFIG_X86_4G is not set
 # CONFIG_X86_SWITCH_PAGETABLES is not set
 # CONFIG_X86_4G_VM_LAYOUT is not set
@@ -120,7 +120,6 @@
 CONFIG_X86_UP_IOAPIC=y
 CONFIG_X86_LOCAL_APIC=y
 CONFIG_X86_IO_APIC=y
-CONFIG_X86_TSC=y
 CONFIG_X86_MCE=y
 # CONFIG_X86_MCE_NONFATAL is not set
 CONFIG_X86_MCE_P4THERMAL=y

2008-09-17 16:14

 

kernel-2.6.9-i586-smp.config.diff (1,328 bytes)
--- oldconfig/kernel-2.6.9-i586-smp.config	2008-09-17 09:02:18.000000000 -0700
+++ newconfig/kernel-2.6.9-i586-smp.config	2008-09-17 09:08:49.000000000 -0700
@@ -2,7 +2,7 @@
 #
 # Automatically generated make config: don't edit
 # Linux kernel version: 2.6.9-prep
-# Thu Jul 24 22:11:17 2008
+# Tue Sep 16 12:56:11 2008
 #
 CONFIG_X86=y
 CONFIG_MMU=y
@@ -77,10 +77,10 @@
 CONFIG_X86_CYCLONE_TIMER=y
 # CONFIG_M386 is not set
 # CONFIG_M486 is not set
-# CONFIG_M586 is not set
+CONFIG_M586=y
 # CONFIG_M586TSC is not set
 # CONFIG_M586MMX is not set
-CONFIG_M686=y
+# CONFIG_M686 is not set
 # CONFIG_MPENTIUMII is not set
 # CONFIG_MPENTIUMIII is not set
 # CONFIG_MPENTIUMM is not set
@@ -100,13 +100,13 @@
 CONFIG_X86_L1_CACHE_SHIFT=7
 CONFIG_RWSEM_XCHGADD_ALGORITHM=y
 CONFIG_X86_PPRO_FENCE=y
+CONFIG_X86_F00F_BUG=y
 CONFIG_X86_WP_WORKS_OK=y
 CONFIG_X86_INVLPG=y
 CONFIG_X86_BSWAP=y
 CONFIG_X86_POPAD_OK=y
-CONFIG_X86_GOOD_APIC=y
+CONFIG_X86_ALIGNMENT_16=y
 CONFIG_X86_INTEL_USERCOPY=y
-CONFIG_X86_USE_PPRO_CHECKSUM=y
 # CONFIG_X86_4G is not set
 # CONFIG_X86_SWITCH_PAGETABLES is not set
 # CONFIG_X86_4G_VM_LAYOUT is not set
@@ -123,7 +123,6 @@
 CONFIG_PREEMPT_VOLUNTARY=y
 CONFIG_X86_LOCAL_APIC=y
 CONFIG_X86_IO_APIC=y
-CONFIG_X86_TSC=y
 CONFIG_X86_MCE=y
 # CONFIG_X86_MCE_NONFATAL is not set
 CONFIG_X86_MCE_P4THERMAL=y
toracat

toracat

2008-09-17 16:15

manager   ~0008011

Patch files submitted.

Akemi
toracat

toracat

2008-09-20 04:19

manager   ~0008023

Developers seem to be tied up with other works. Since kernel-2.6.9-78.0.1.EL.src.rpm became available (see bug#3132), I rebuilt the 586 kernel using the patched configs. If you'd like to give it a try for testing, just let me know.

Akemi
kbsingh@karan.org

kbsingh@karan.org

2008-09-30 09:49

administrator   ~0008062

kernel-2.6.9-78.EL.1 is now building for this i586 support, packages will show up in the c4-testing repo once they are done. Once confirmed working I'll have a go at creating an alternative installer path using this kernel.
guzu

guzu

2008-10-18 16:49

reporter   ~0008160

i can not install the 4.7 version wich hopefully has a better pcmcia card support, because the i586 image is not available. please help!
quicksilver03

quicksilver03

2009-01-03 09:43

reporter   ~0008525

A kernel 2.6.9-78.0.8.EL is now in the base repository, and I have successfully updated 2 i586 boxes to it. This issue should probably be marked as closed.
toracat

toracat

2009-01-03 17:08

manager   ~0008527

I think the boot.iso file should be made available before the ticket is closed. Users needing the i586 kernel cannot install from CentOS 4.7 CD/DVD.
quicksilver03

quicksilver03

2009-08-28 10:05

reporter   ~0009838

I'm seeing the exact same symptom after updating to CentOS 4.8 and kernel 2.6.9-89.0.9.EL.

# rpm -q --queryformat "%{NAME}-%{VERSION}-%{RELEASE} %{ARCH}\n" kernel
kernel-2.6.9-34.EL i586
kernel-2.6.9-89.0.9.EL i586

# grep 'CONFIG_M[56]86=y' /boot/config*
/boot/config-2.6.9-34.EL:CONFIG_M586=y
/boot/config-2.6.9-89.0.9.EL:CONFIG_M686=y

I've reverted to the 2.6.9-34.EL kernel in the meantime.
toracat

toracat

2009-08-28 11:34

manager   ~0009839

@quicksilver03,

Please take a look at bug 3792. There is a test kernel to rectify this problem. Could you give it a try and report back with the result?
quicksilver03

quicksilver03

2009-08-29 08:32

reporter   ~0009843

@toracat,

The kernel mentioned on bug 3792 (that is
http://people.centos.org/hughesjr/kernel/4/i586/kernel-2.6.9-89.EL.i586.rpm) boots and works fine for me.
toracat

toracat

2009-08-29 17:50

manager   ~0009846

@quicksilver03,

Thanks for testing. Johnny has published the fixed version of i586 kernels in the updates repository. So, I think this ticket can now be closed.

Issue History

Date Modified Username Field Change
2008-09-13 18:38 st New Issue
2008-09-13 20:52 toracat Note Added: 0007971
2008-09-13 20:53 toracat Status new => confirmed
2008-09-15 06:37 Milan Kerslager Note Added: 0007982
2008-09-15 07:21 toracat Note Added: 0007983
2008-09-16 11:55 iay Note Added: 0007994
2008-09-17 15:07 kbsingh@karan.org Note Added: 0008010
2008-09-17 16:14 toracat File Added: kernel-2.6.9-i586.config.diff
2008-09-17 16:14 toracat File Added: kernel-2.6.9-i586-smp.config.diff
2008-09-17 16:15 toracat Note Added: 0008011
2008-09-20 04:19 toracat Note Added: 0008023
2008-09-29 14:38 toracat Relationship added has duplicate 0003158
2008-09-30 09:49 kbsingh@karan.org Note Added: 0008062
2008-10-18 16:46 toracat Relationship added has duplicate 0003203
2008-10-18 16:49 guzu Note Added: 0008160
2009-01-03 09:43 quicksilver03 Note Added: 0008525
2009-01-03 17:08 toracat Note Added: 0008527
2009-03-23 18:41 toracat Relationship added has duplicate 0003439
2009-08-28 10:05 quicksilver03 Note Added: 0009838
2009-08-28 11:34 toracat Note Added: 0009839
2009-08-28 11:44 toracat Relationship added related to 0003792
2009-08-29 08:32 quicksilver03 Note Added: 0009843
2009-08-29 17:50 toracat Note Added: 0009846
2009-08-29 17:50 toracat Status confirmed => resolved
2009-08-29 17:50 toracat Resolution open => fixed
2009-08-29 17:50 toracat Fixed in Version => 4.8