View Issue Details

IDProjectCategoryView StatusLast Update
0003169CentOS-4kernelpublic2009-08-06 15:19
Reporterdthiel Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7 
Summary0003169: Stopping iptables crashes kernel
DescriptionWe are using the actual CentOS 4.7 kernel 2.6.9-78.0.1.EL on an AMD Opteron singlecore system.

When trying to stop iptables using "/etc/init.d/iptables stop" the kernel always crashes with this message:

Unable to handle kernel paging request at virtual address f88f5168
 printing eip:
c02d4877
*pde = 01928067
Oops: 0000 [#1]
Modules linked in: autofs4 w83627hf eeprom lm75 i2c_sensor i2c_isa i2c_amd756 i2c_dev i2c_core md5 ipv6 ip_conntrack powernow_k8 cpufreq_powersave dm_mirror dm_mod button battery ac ohci_hcd hw_random k8_edac edac_mc tg3 floppy ext3 jbd raid1
CPU: 0
EIP: 0060:[<c02d4877>] Not tainted VLI
EFLAGS: 00010216 (2.6.9-78.0.1.EL)
EIP is at nf_unregister_sockopt+0x47/0x81
eax: 00000002 ebx: c03a2020 ecx: f69a5e60 edx: f88f5160
esi: f8a23380 edi: 00000000 ebp: d7c3c000 esp: d7c3cf5c
ds: 007b es: 007b ss: 0068
Process modprobe (pid: 3959, threadinfo=d7c3c000 task=d7180640)
Stack: 00000000 c037d800 f8a1a732 f8a23880 c014030d 00000000 635f7069 746e6e6f
       6b636172 00000000 d6813b80 b7f8a000 b7f8b000 c01602d6 d6813b80 d94ecdec
       c016067b d8a46660 d6813b80 d6813bb0 00000000 d7c3c000 080cf820 00000000
Call Trace:
 [<f8a1a732>] init_or_cleanup+0x1e6/0x1ea [ip_conntrack]
 [<c014030d>] sys_delete_module+0x139/0x180
 [<c01602d6>] unmap_vma_list+0xe/0x17
 [<c016067b>] do_munmap+0x1a7/0x1b1
 [<c0327973>] syscall_call+0x7/0xb
Code: 17 05 00 89 d9 ff 0d 20 20 3a c0 0f 88 40 0d 00 00 8b 0d 48 20 3a c0 8b 01 0f 18 00 90 81 f9 48 20 3a c0 74 2f 8b 51 08 8b 46 08 <39> 42 08 8b 11 75 1e 8b 41 04 89 42 04 89 10 89 c8 c7 01 00 01
 <0>Fatal exception: panic in 5 seconds
Kernel panic - not syncing: Fatal exception


The machine is still responding to ICMP (ping) but is dead to all other network requests. A hard reset is required to get the machine back to life.


Additional Information# cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 5
model name : AMD Opteron(tm) Processor 146
stepping : 10
cpu MHz : 1000.000
cache size : 1024 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 pni syscall nx mmxext lm 3dnowext 3dnow
bogomips : 2006.08


# free
             total used free shared buffers cached
Mem: 1035556 252372 783184 0 21784 120384
-/+ buffers/cache: 110204 925352
Swap: 2096376 0 2096376


# uname -a
Linux xxxxxxxxx.yyyyyyyy.zz 2.6.9-78.0.1.EL #1 Tue Aug 5 10:49:42 EDT 2008 i686 athlon i386 GNU/Linux
TagsNo tags attached.

Relationships

duplicate of 0003131 resolvedJohnnyHughes kernel-2.6.9-78.0.1 panics when unloading iptables (via service iptables stop or shutdown) 

Activities

toracat

toracat

2008-10-02 19:39

manager   ~0008091

Please see bug #3131
toracat

toracat

2009-08-06 15:19

manager   ~0009723

Fixed in kernel 2.6.9-78.0.17.

Issue History

Date Modified Username Field Change
2008-10-02 19:36 dthiel New Issue
2008-10-02 19:39 toracat Relationship added duplicate of 0003131
2008-10-02 19:39 toracat Note Added: 0008091
2009-08-06 15:19 toracat Note Added: 0009723
2009-08-06 15:19 toracat Status new => resolved
2009-08-06 15:19 toracat Resolution open => fixed