2016-12-02 20:14 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003175CentOS-5-OTHERpublic2008-10-22 11:17
Reporterst_gotbugs 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
Product Version5.2 
Target VersionFixed in Version 
Summary0003175: BackupPC.x86_64 (centos5-testing) fails to start (Can't locate BackupPC/Lib.pm)
DescriptionThe backuppc-3.1.0-1.el5.centos.x86_64 service (centos5-testing) fails to start and gives an error message showing a failure to find BackupPC/Lib.pm. There is no apparent way to correct this via /etc/BackupPC/config.pl.

Symlinking /usr/lib/BackupPC to /usr/lib64/BackupPC allows BackupPC to start (see below).

backuppc.i386 installs and starts OK on both i686 and x86_64 hardware.
Additional Information# yum list installed backuppc

backuppc.x86_64 3.1.0-1.el5.centos installed



# service backuppc start


Starting BackupPC:

Can't locate BackupPC/Lib.pm in @INC (@INC contains:

/usr/lib

/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi

/usr/lib64/perl5/site_perl/5.8.7/x86_64-linux-thread-multi

/usr/lib64/perl5/site_perl/5.8.6/x86_64-linux-thread-multi

/usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi

/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7

/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5

/usr/lib/perl5/site_perl

/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi

/usr/lib64/perl5/vendor_perl/5.8.7/x86_64-linux-thread-multi

/usr/lib64/perl5/vendor_perl/5.8.6/x86_64-linux-thread-multi

/usr/lib64/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi

/usr/lib/perl5/vendor_perl/5.8.8

/usr/lib/perl5/vendor_perl/5.8.7

/usr/lib/perl5/vendor_perl/5.8.6

/usr/lib/perl5/vendor_perl/5.8.5

/usr/lib/perl5/vendor_perl

/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi

/usr/lib/perl5/5.8.8

.) at /usr/bin/BackupPC line 60.

BEGIN failed--compilation aborted at /usr/bin/BackupPC line 60.

                                                           [FAILED]

# locate BackupPC/Lib.pm

/usr/lib64/BackupPC/Lib.pm



# less +60 /usr/bin/BackupPC

use BackupPC::Lib;


# ln -s /usr/lib64/BackupPC /usr/lib/BackupPC



# service backuppc start

Starting BackupPC: [ OK ]



$ less rpmbuild/SPECS/backuppc.spec

...

%ifarch x86_64

ln -s lib lib64

%endif
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0008129

toracat (manager)

I can confirm the bug.

Johnny, did you stop developing BackupPC for CentOS? Because EPEL has it or... ???

~0008180

JohnnyHughes (administrator)

is it in epel ... I don't use stuff from there :D

I use backuppc in production on x86_64 and I think it works OK without issues for me, but I will check this.
+Notes

-Issue History
Date Modified Username Field Change
2008-10-06 19:46 st_gotbugs New Issue
2008-10-12 16:13 toracat Note Added: 0008129
2008-10-22 11:17 JohnnyHughes Note Added: 0008180
+Issue History