View Issue Details

IDProjectCategoryView StatusLast Update
0003252CentOS-5pcrepublic2011-01-12 15:59
Reporterheil 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status newResolutionopen 
Product Version5.2 
Target VersionFixed in Version 
Summary0003252: prce has no unicode properties support
Descriptionif we try to work with unicode character classes, we get
pcre unicode support is off

php---
if (@preg_match('/\pL/u', 'a') == 1) {
    echo "PCRE unicode support is turned on.\n";
} else {
    echo "PCRE unicode support is turned off.\n";
}
--
you may also simply test with pcretest -C
which says, tha no unicode properties support is builtin.



Additional InformationThe Problem could be simply solved by changing by changing the %build line in the spec file
to
%build
%configure --enable-utf8 --enable-unicode-properties

from
%build
%configure --enable-utf8

Hope that a package maintainer could fix it in the mainstream.
TagsNo tags attached.

Activities

range

range

2008-11-19 13:44

administrator   ~0008305

See https://bugzilla.redhat.com/show_bug.cgi?id=457064
heil

heil

2008-11-19 17:39

reporter   ~0008307

it seems, that redhat will not fix that in the next time. what can I do to speed up the process in conjunction to bugzilla.redhat.com ?
prschaffner

prschaffner

2008-12-12 21:38

reporter   ~0008441

Added this issue as an External Bug link to the upstream BZ entry.
intel352

intel352

2009-04-14 14:33

reporter   ~0009172

This page details how to build a fixed PCRE with Unicode support, or you can just download the RPM that has been already compiled for Centos 5.2

http://gaarai.com/2009/01/31/unicode-support-on-centos-52-with-php-and-pcre/
Phil Schaffner

Phil Schaffner

2011-01-12 15:59

reporter   ~0012336

The upstream bug is now marked "RELEASE_PENDING".

Issue History

Date Modified Username Field Change
2008-11-19 13:34 heil New Issue
2008-11-19 13:44 range Note Added: 0008305
2008-11-19 17:39 heil Note Added: 0008307
2008-12-12 21:38 prschaffner Note Added: 0008441
2009-04-14 14:33 intel352 Note Added: 0009172
2011-01-12 15:59 Phil Schaffner Note Added: 0012336