2017-08-23 02:13 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003462CentOS-5gdmpublic2011-12-04 02:23
Reporteroogabooga 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionreopened 
Product Version5.3 
Target VersionFixed in Version 
Summary0003462: CentOS 5.3 fresh install has an erroneous "CentOS Cubes" theme for the login window
DescriptionAfter performing a fresh CentOS 5.3 install from the x86_64 DVD, I went into System > Administration > Login Screen, and noticed that there are two themes offered:

- "CentOS Cubes"
- "CentOS Default"

In the visual preview, both themes look identical. i.e., the preview of the "CentOS Cubes" login theme does not indicate that it's the same 5.2 theme that actually did feature the "cubes"; rather, the preview of the Cubes login theme in this window reveals it to look the same as the new Default theme (that is, using the new Tree Flower artwork).

I've attached a screenshot that shows what I'm seeing.

By default, the "CentOS Default" theme is selected as the *default* login window theme.

Anyway, I decided to go ahead and select the "CentOS Cubes" login theme, and then I logged out.

However, upon logging out -- and thus returning to the GDM login window -- I was shown an empty black window with a simple error dialogue, which read:

"
There was an error loading the theme CentOSCubes

Failed to open file '/usr/share/gdm/themes/CentOSCubes/background2.png': No such file or directory
"

Once I dismissed that error dialogue, I was then presented with another one, reading:

"
There was an error loading the theme, and the default theme could not be loaded.
Attempting to start the standard greeter
"

Finally, after dismissing after that error dialogue, I was taken to the plain ol' GDM standard greeter (without any theme), where I could log in again.

Once logged in again, I was able to use Login Screen preferences to change the machine's login theme back to "CentOS Default" (note that "CentOS Cubes" was still listed as the other option). After that, the CentOS Default login theme worked properly in the GDM window (as it originally had upon first boot before I tried changing the theme to "CentOS Cubes").
TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0003488closedkbsingh@karan.org File background2.png for Theme CentOSCubes is missing 
has duplicate 0003519closedkbsingh@karan.org Missing background2.jpg(png) file for GDM theme "CentOSCubes" 
+Relationships

-Notes

~0008988

range (administrator)

Last edited: 2009-04-01 20:01

Hmmm. I've tested these packages so often, somehow this slipped through ...

~0009001

cepheid (reporter)

It appears that the CentOS Cubes theme is not included in the latest redhat-artwork (5.1.0-28), while it was included with the previous redhat-artwork (5.1.0-26). This is apparent upon doing an 'rpm -ql' on both packages and diff'ing the output.

~0009003

range (administrator)

Strange. I thought I packaged that, so people wanting to stay with CentOS Cubes could stay there.

I look at that over the weekend, if time permits.

~0009015

cepheid (reporter)

Just to save you the trouble of doing the diff on the RPMs:

max:~/temp [159] rpm -qlp redhat-artwork-5.1.0-26.el5.centos.i386.rpm > r26
max:~/temp [160] rpm -qlp redhat-artwork-5.1.0-28.el5.centos.i386.rpm > r28
max:~/temp [162] diff -iw r26 r28
36,52c36,48
< /usr/share/apps/kdm/themes/CentOSCubes
< /usr/share/apps/kdm/themes/CentOSCubes/CentOSCubes.xml
< /usr/share/apps/kdm/themes/CentOSCubes/GdmGreeterTheme.desktop
< /usr/share/apps/kdm/themes/CentOSCubes/background.png
< /usr/share/apps/kdm/themes/CentOSCubes/background2.png
< /usr/share/apps/kdm/themes/CentOSCubes/curve-bottom_left.png
< /usr/share/apps/kdm/themes/CentOSCubes/curve-bottom_right.png
< /usr/share/apps/kdm/themes/CentOSCubes/curve-top_left.png
< /usr/share/apps/kdm/themes/CentOSCubes/curve-top_right.png
< /usr/share/apps/kdm/themes/CentOSCubes/dotline.png
< /usr/share/apps/kdm/themes/CentOSCubes/icon-language.png
< /usr/share/apps/kdm/themes/CentOSCubes/icon-reboot.png
< /usr/share/apps/kdm/themes/CentOSCubes/icon-session.png
< /usr/share/apps/kdm/themes/CentOSCubes/icon-shutdown.png
< /usr/share/apps/kdm/themes/CentOSCubes/logo.png
< /usr/share/apps/kdm/themes/CentOSCubes/screenshot.png
< /usr/share/apps/kdm/themes/CentOSCubes/shade-right.png
---
> /usr/share/apps/kdm/themes/TreeFlower
> /usr/share/apps/kdm/themes/TreeFlower/GdmGreeterTheme.desktop
> /usr/share/apps/kdm/themes/TreeFlower/background.png
> /usr/share/apps/kdm/themes/TreeFlower/curve-bottom_left.png
> /usr/share/apps/kdm/themes/TreeFlower/curve-bottom_right.png
> /usr/share/apps/kdm/themes/TreeFlower/curve-top_left.png
> /usr/share/apps/kdm/themes/TreeFlower/curve-top_right.png
> /usr/share/apps/kdm/themes/TreeFlower/icon-language.png
> /usr/share/apps/kdm/themes/TreeFlower/icon-reboot.png
> /usr/share/apps/kdm/themes/TreeFlower/icon-session.png
> /usr/share/apps/kdm/themes/TreeFlower/icon-shutdown.png
> /usr/share/apps/kdm/themes/TreeFlower/screenshot.png
> /usr/share/apps/kdm/themes/TreeFlower/treeflower.xml
69a66,72
> /usr/share/gdm/themes/TreeFlower
> /usr/share/gdm/themes/TreeFlower/GdmGreeterTheme.desktop
> /usr/share/gdm/themes/TreeFlower/icon-language.png
> /usr/share/gdm/themes/TreeFlower/icon-reboot.png
> /usr/share/gdm/themes/TreeFlower/icon-session.png
> /usr/share/gdm/themes/TreeFlower/icon-shutdown.png
> /usr/share/gdm/themes/TreeFlower/treeflower.xml

As you can easily see, version -28 does not include CentOSCubes, while version -26 does. Hope this helps.

~0009118

range (administrator)

Would you be willing to test the -29 packages in

http://people.centos.org/ralph/artwork

? They are signed with the key 0xFD0BEDE5. Please ignore the "br" repo tag, this comes from my internal build system.

Thanks.

~0009228

range (administrator)

Have you tested those packages?

~0009233

oogabooga (reporter)

Is your request (to test) directed at me or cepheid?

~0009234

cepheid (reporter)

I am unable to test these packages as the CentOS server I manage is headless and I don't manage the "headed" one.

~0009235

range (administrator)

oogabooga: Both of you - if possible. It works for me, but I'd like to have a second opinion before we do an update.

Thanks.

~0009316

grouch0 (reporter)

I installed rpm successfully via supplied http link. Message does not appear any more. I don't know what to expect the appearance/behavior to be. The message was my only sense that anything was wrong. It does not appear any more and login proceeds as normal. I would say this is the fix.

~0009317

range (administrator)

Okay, we'll push that as an update soon.

Thank you.

~0012448

toracat (manager)

Reopening as requested in bug #4743 .

~0013863

rmisra1 (reporter)

hi,

i am facing same issue ..but solution given in orignal thread is "Once I dismissed that error dialogue" ...can't be implemtned in my environment , as i am not able to find any box to "dismiss that error"... instead i am gtting being directled to "user name " then "password "...i even used my root loging but it ggives error "password / user name invliad" ... but i am able to use same root password via SS from remote desktop ...

pl help to esolve this issue...

Regards
Rakesh
+Notes

-Issue History
Date Modified Username Field Change
2009-04-01 18:31 oogabooga New Issue
2009-04-01 18:31 oogabooga File Added: CentOS_5.3_Login_Screen_Bug.jpg
2009-04-01 20:01 range Note Added: 0008988
2009-04-01 20:01 range Note Edited: 0008988
2009-04-02 06:53 cepheid Note Added: 0009001
2009-04-02 08:40 range Note Added: 0009003
2009-04-02 12:15 cepheid Note Added: 0009015
2009-04-03 08:05 range Relationship added has duplicate 0003488
2009-04-03 08:06 range Status new => confirmed
2009-04-07 07:23 tru Relationship added has duplicate 0003519
2009-04-08 10:14 range Note Added: 0009118
2009-04-21 14:10 range Note Added: 0009228
2009-04-21 14:10 range Status confirmed => feedback
2009-04-21 18:00 oogabooga Note Added: 0009233
2009-04-21 18:16 cepheid Note Added: 0009234
2009-04-21 20:48 range Note Added: 0009235
2009-05-06 15:15 grouch0 Note Added: 0009316
2009-05-06 15:18 range Note Added: 0009317
2009-05-06 15:18 range Status feedback => resolved
2009-05-06 15:18 range Resolution open => fixed
2011-02-26 13:46 toracat Note Added: 0012448
2011-02-26 13:46 toracat Status resolved => feedback
2011-02-26 13:46 toracat Resolution fixed => reopened
2011-02-26 13:47 toracat Status feedback => assigned
2011-12-03 07:06 rmisra1 Note Added: 0013863
+Issue History