View Issue Details

IDProjectCategoryView StatusLast Update
0003467CentOS-5yumpublic2009-04-16 12:11
Reporterbjrosen 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version5.3 
Target VersionFixed in Version 
Summary0003467: Missing package in for 5.2 to 5.3 upgrade
DescriptionI just tried to do a yum upgrade, The following package is missing

Error: Missing Dependency: nss = 3.12.2.0-2.el5.centos is needed by package nss-devel
TagsNo tags attached.

Relationships

related to 0003481 closedrange yum install openmotif22 dies with 'TypeError: unsubscriptable object' 
related to 0003486 newkbsingh@karan.org Can't install eclipse 

Activities

cepheid

cepheid

2009-04-02 06:55

reporter   ~0009002

Have you made sure to enable the updates repo? See bug #3459.
bjrosen

bjrosen

2009-04-02 12:05

reporter   ~0009014

The updates repo is enabled. This problem may be caused by the extras repo, I disabled that and the error changed. I also did an update on yum by itself, the new version of yum is broken,

---> Package nspr-devel.x86_64 0:4.7.3-2.el5 set to be updated
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 145, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 647, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 704, in resolveDeps
    for po, dep in self._checkFileRequires():
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 939, in _checkFileRequires
    if not self.tsInfo.getOldProvides(filename) and not self.tsInfo.getNewProvides(filename):
  File "/usr/lib/python2.4/site-packages/yum/transactioninfo.py", line 414, in getNewProvides
    for pkg, hits in self.pkgSack.getProvides(name, flag, version).iteritems():
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 300, in getProvides
    return self._computeAggregateDictResult("getProvides", name, flags, version)
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 470, in _computeAggregateDictResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 861, in getProvides
    return self._search("provides", name, flags, version)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 43, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 837, in _search
    for pkg in self.searchFiles(name, strict=True):
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 43, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 586, in searchFiles
    self._sql_pkgKey2po(rep, cur, pkgs)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 470, in _sql_pkgKey2po
    pkg = self._packageByKey(repo, ob['pkgKey'])
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 413, in _packageByKey
    po = self.pc(repo, cur.fetchone())
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 68, in __init__
    self._read_db_obj(db_obj)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 94, in _read_db_obj
    setattr(self, item, _share_data(db_obj[item]))
TypeError: unsubscriptable object
Charlie Brady

Charlie Brady

2009-04-02 21:34

reporter   ~0009026

I had what I think is the same traceback attempting to install openmotif22.
range

range

2009-04-03 08:27

administrator   ~0009033

That seems to be a problem of updating yum before pulling in all other updates to 5.3.
Charlie Brady

Charlie Brady

2009-04-03 20:03

reporter   ~0009051

> That seems to be a problem of updating yum before pulling in all other
> updates to 5.3.

Not in my case. yum was updated with everything else.

The exception didn't occur after "yum clean metadata".
tupari

tupari

2009-04-07 23:15

reporter   ~0009112

I had the same problem when upgrading 5.2 -> 5.3. I solved it by deleting all files under /var/yum that ended in .sqllite
Charlie Brady

Charlie Brady

2009-04-07 23:38

reporter   ~0009113

> I had the same problem when upgrading 5.2 -> 5.3. I solved it by deleting
> all files under /var/yum that ended in .sqllite

Did you first try "yum clean metadata"?
tupari

tupari

2009-04-07 23:41

reporter   ~0009114

no
engelbrechtd

engelbrechtd

2009-04-16 12:11

reporter   ~0009177

Thank you Charlie! yum clean all did the trick for me!

Issue History

Date Modified Username Field Change
2009-04-01 21:46 bjrosen New Issue
2009-04-02 06:55 cepheid Note Added: 0009002
2009-04-02 12:05 bjrosen Note Added: 0009014
2009-04-02 21:34 Charlie Brady Note Added: 0009026
2009-04-03 08:27 range Note Added: 0009033
2009-04-03 09:19 range Relationship added related to 0003481
2009-04-03 09:20 range Relationship added related to 0003486
2009-04-03 20:03 Charlie Brady Note Added: 0009051
2009-04-07 23:15 tupari Note Added: 0009112
2009-04-07 23:38 Charlie Brady Note Added: 0009113
2009-04-07 23:41 tupari Note Added: 0009114
2009-04-16 12:11 engelbrechtd Note Added: 0009177