View Issue Details

IDProjectCategoryView StatusLast Update
0003564CentOS-5yum-updatesdpublic2010-02-07 20:54
ReporterMarcuccio 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version5.3 
Target VersionFixed in Version5.4 
Summary0003564: yum-updatesd not working after upgrade to centos 5.3
DescriptionAfter Upgrading from 5.2 to 5.3 yum-updatesd has stopped working.
The daemon starts at boot and remain silent for a while (an hour or more,without producing any notification of the availability of software updates) then suddenly the process dies without any messages in the log.

yum instead works perfectly and a check-update command cofirms the presence of new updates
Additional InformationThe file in attachement is the output of the following command:

yum-updatesd -f -d

This bug looks very similar to #0003540
TagsNo tags attached.

Relationships

has duplicate 0003565 closedkbsingh@karan.org After update from 5.2 to 5.3, puplet does not work 
related to 0003540 closedkbsingh@karan.org yum-updatesd package fails to notify of availability of updates. 

Activities

2009-04-16 16:24

 

yum-updatesd.debug.log (164,492 bytes)
Marcuccio

Marcuccio

2009-04-17 14:43

reporter   ~0009188

I forgot to say that I have exactly the same issue on two different desktop pc (different hw but similar software configuration).
etfong

etfong

2009-04-18 01:14

reporter   ~0009190

Having the same issue with a new 5.3 install with yum-updatesed dieing and dbus error with puplet

"Traceback (most recent call last):
  File "/usr/bin/puplet", line 467, in ?
    main()
  File "/usr/bin/puplet", line 464, in main
    p.run()
  File "/usr/bin/puplet", line 451, in run
    self._refreshInfo()
  File "/usr/bin/puplet", line 191, in _refreshInfo
    if self.updatesObject is not None and \
AttributeError: DBusException instance has no attribute '_dbus_error_name'
Phil Schaffner

Phil Schaffner

2009-05-13 15:04

reporter   ~0009353

A workaround has been posted in a forum thread:
http://www.centos.org/modules/newbb/viewtopic.php?post_id=76607&topic_id=20236&forum=38

2009-05-14 10:00

 

yum-error-log.txt (2,469 bytes)
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 145, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 647, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 704, in resolveDeps
    for po, dep in self._checkFileRequires():
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 939, in _checkFileRequires
    if not self.tsInfo.getOldProvides(filename) and not self.tsInfo.getNewProvides(filename):
  File "/usr/lib/python2.4/site-packages/yum/transactioninfo.py", line 414, in getNewProvides
    for pkg, hits in self.pkgSack.getProvides(name, flag, version).iteritems():
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 300, in getProvides
    return self._computeAggregateDictResult("getProvides", name, flags, version)
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 470, in _computeAggregateDictResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 861, in getProvides
    return self._search("provides", name, flags, version)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 43, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 837, in _search
    for pkg in self.searchFiles(name, strict=True):
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 43, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 586, in searchFiles
    self._sql_pkgKey2po(rep, cur, pkgs)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 470, in _sql_pkgKey2po
    pkg = self._packageByKey(repo, ob['pkgKey'])
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 413, in _packageByKey
    po = self.pc(repo, cur.fetchone())
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 68, in __init__
    self._read_db_obj(db_obj)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 94, in _read_db_obj
    setattr(self, item, _share_data(db_obj[item]))
TypeError: unsubscriptable object
yum-error-log.txt (2,469 bytes)
ASI_Sysnet

ASI_Sysnet

2009-05-14 10:05

reporter   ~0009354

Yum update doesn't work on CentOS 5.3 system configured like DNS server, I attached error log about yum.

ASI System & Network administrators.
BartSimpson

BartSimpson

2009-06-18 06:21

reporter   ~0009488

It is noted at upstream.
https://bugzilla.redhat.com/show_bug.cgi?id=480339
JohnnyHughes

JohnnyHughes

2009-08-25 12:16

administrator   ~0009807

I have built and made available dbus-python-0.82 as a temporary work around. You can get the RPM here:

http://people.centos.org/hughesjr/dbus-python-0.82/

Download the correct RPM for your arch and install it with the command:

rpm -Uvh dbus-python-0.82.4-2.el5_3.i386.rpm

OR

rpm -Uvh dbus-python-0.82.4-2.el5_3.x86_64.rpm


Then make sure yum-updatesd is installed and running.

NOTE: This will allow puplet to run and it is the solution that the upstream provider says they will implement. It might cause issues with other programs and should only be seen as a temporary fix.
ohw0571

ohw0571

2009-11-05 14:33

reporter   ~0010295

On my systems, the update notification is still not functional after upgrade to CentOS 5.4! Specifically, .xsession-errors still shows:

"Error getting update info: Message did not receive a reply (timeout by message b
us)
Introspect error: The name edu.duke.linux.yum was not provided by any .service f
iles
Traceback (most recent call last):
  File "/usr/bin/puplet", line 191, in _refreshInfo
    if self.updatesObject is not None and \
AttributeError: DBusException instance has no attribute '_dbus_error_name'"

Does this mean the problem still has not been fixed upstream? Quite annoying, although it is - admittedly - not a severe issue.
Marcuccio

Marcuccio

2010-02-07 18:18

reporter   ~0010953

Upgrading from Centos 5.3 to Centos 5.4 (through yum) solved the issue on two different machines on which I have had the problem.
toracat

toracat

2010-02-07 19:19

manager   ~0010954

According to the upstream bugzilla, the problem was fixed with dbus-python-0.70-9.el5_4. People still seeing the issue should update to this version.

Issue History

Date Modified Username Field Change
2009-04-16 16:24 Marcuccio New Issue
2009-04-16 16:24 Marcuccio File Added: yum-updatesd.debug.log
2009-04-17 14:43 Marcuccio Note Added: 0009188
2009-04-18 01:14 etfong Note Added: 0009190
2009-04-19 22:39 toracat Relationship added related to 0003540
2009-04-20 12:40 range Relationship added has duplicate 0003565
2009-05-13 15:04 Phil Schaffner Note Added: 0009353
2009-05-14 09:58 ASI_Sysnet Tag Attached: 5.3
2009-05-14 09:59 ASI_Sysnet Tag Detached: 5.3
2009-05-14 10:00 ASI_Sysnet File Added: yum-error-log.txt
2009-05-14 10:05 ASI_Sysnet Note Added: 0009354
2009-06-18 06:21 BartSimpson Note Added: 0009488
2009-08-25 12:16 JohnnyHughes Note Added: 0009807
2009-11-05 14:33 ohw0571 Note Added: 0010295
2010-02-07 18:18 Marcuccio Note Added: 0010953
2010-02-07 19:19 toracat Note Added: 0010954
2010-02-07 20:54 toracat Status new => resolved
2010-02-07 20:54 toracat Resolution open => fixed
2010-02-07 20:54 toracat Fixed in Version => 5.4