View Issue Details

IDProjectCategoryView StatusLast Update
0003697CentOS-4kernelpublic2009-06-19 17:23
Reportervaughnskinner Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product Version4.7 
Summary0003697: Kernel panic on iptables reload
DescriptionKernel panic when iptables reloaded. Perhaps due to simultaneous tcpdump monitoring on interface?
Additional Information
[root@sky-monitor log]# cat /etc/redhat-release
CentOS release 4.7 (Final)
Red Hat Enterprise Linux ES release 4
[root@sky-monitor log]# uname -a
Linux sky-monitor.madras.net 2.6.9-78.0.13.ELsmp #1 SMP Wed Jan 14 16:12:46 EST 2009 i686 i686 i386 GNU/Linux
[root@sky-monitor log]#


Jun 19 09:08:21 sky-monitor kernel: Unable to handle kernel paging request at virtual address f8a8f5e8
Jun 19 09:08:21 sky-monitor kernel: printing eip:
Jun 19 09:08:21 sky-monitor kernel: c02945ca
Jun 19 09:08:21 sky-monitor kernel: *pde = eee4104c
Jun 19 09:08:21 sky-monitor kernel: Oops: 0000 [#1]
Jun 19 09:08:21 sky-monitor kernel: SMP
Jun 19 09:08:21 sky-monitor kernel: Modules linked in: parport_pc lp parport autofs4 i2c_dev i2c_core sunrpc ip_conntrack cpufreq_powersave ib_srp ib_sdp ib_ipoib md5 ipv6 rdma_ucm rdma_
cm iw_cm ib_addr ib_umad ib_ucm ib_uverbs ib_cm ib_sa ib_mad ib_core button battery ac uhci_hcd ehci_hcd hw_random 8139too mii pata_jmicron dm_snapshot dm_zero dm_mirror ext3 jbd dm_mod
ata_piix libata sd_mod scsi_mod
Jun 19 09:08:21 sky-monitor kernel: CPU: 0
Jun 19 09:08:21 sky-monitor kernel: EIP: 0060:[<c02945ca>] Not tainted VLI
Jun 19 09:08:21 sky-monitor kernel: EFLAGS: 00010216 (2.6.9-78.0.13.ELsmp)
Jun 19 09:08:21 sky-monitor kernel: EIP is at nf_unregister_sockopt+0x48/0x83
Jun 19 09:08:21 sky-monitor kernel: eax: 00000002 ebx: c035e6a4 ecx: c3af6f40 edx: f8a8f5e0
Jun 19 09:08:21 sky-monitor kernel: esi: f8b1e7e0 edi: 00000000 ebp: c99c4000 esp: c99c4f5c
Jun 19 09:08:21 sky-monitor kernel: ds: 007b es: 007b ss: 0068
Jun 19 09:08:21 sky-monitor kernel: Process modprobe (pid: 19617, threadinfo=c99c4000 task=f320e6b0)
Jun 19 09:08:21 sky-monitor kernel: Stack: 00000000 c0337ba8 f8b15769 f8b1ec80 c01373e6 00000000 635f7069 746e6e6f
Jun 19 09:08:21 sky-monitor kernel: 6b636172 c0151e00 c3ae90c4 c3bf48b4 c0152222 b7f28000 b7f29000 b7f29000
Jun 19 09:08:21 sky-monitor kernel: b7f29000 e0f250cc c3ae9080 c3ae90b0 00000000 c99c4000 08731890 00000000
Jun 19 09:08:21 sky-monitor kernel: Call Trace:
Jun 19 09:08:21 sky-monitor kernel: [<f8b15769>] init_or_cleanup+0x1e6/0x1ea [ip_conntrack]
Jun 19 09:08:21 sky-monitor kernel: [<c01373e6>] sys_delete_module+0x13b/0x184
Jun 19 09:08:21 sky-monitor kernel: [<c0151e00>] find_extend_vma+0x31/0x4f
Jun 19 09:08:21 sky-monitor kernel: [<c0152222>] do_munmap+0x108/0x116
Jun 19 09:08:21 sky-monitor kernel: [<c02e0767>] syscall_call+0x7/0xb
Jun 19 09:08:21 sky-monitor kernel: Code: 04 00 89 d9 f0 ff 0d a4 e6 35 c0 0f 88 93 0c 00 00 8b 0d bc e6 35 c0 8b 01 0f 18 00 90 81 f9 bc e6 35 c0 74 2f 8b 51 08 8b 46 08 <39> 42 08 8b 1
1 75 1e 8b 41 04 89 42 04 89 10 89 c8 c7 01 00 01
Jun 19 09:08:21 sky-monitor kernel: <0>Fatal exception: panic in 5 seconds


TagsNo tags attached.

Relationships

duplicate of 0003131 resolvedJohnnyHughes kernel-2.6.9-78.0.1 panics when unloading iptables (via service iptables stop or shutdown) 

Activities

vaughnskinner

vaughnskinner

2009-06-19 17:13

reporter   ~0009493

This was triggered when I ran 'service iptables restart'

user430

2009-06-19 17:23

  ~0009494

This is fixed in newer kernels.

Issue History

Date Modified Username Field Change
2009-06-19 17:13 vaughnskinner New Issue
2009-06-19 17:13 vaughnskinner Note Added: 0009493
2009-06-19 17:22 user430 Relationship added duplicate of 0003131
2009-06-19 17:23 user430 Note Added: 0009494
2009-06-19 17:23 user430 Duplicate ID 0 => 3131
2009-06-19 17:23 user430 Status new => resolved
2009-06-19 17:23 user430 Resolution open => duplicate