View Issue Details

IDProjectCategoryView StatusLast Update
0003822CentOS-5-OTHERpublic2009-09-04 09:41
Reporteriocc Assigned To 
PrioritynormalSeveritytweakReproducibilitysometimes
Status closedResolutionnot fixable 
Product Version5.3 
Summary0003822: Network card order naming
DescriptionThis problem isnt specific to CentOS, its the Linux kernel itself.
Linux really have to set a standard how to name network cards.
Right now the first card that is found is named eth0 and 10 ns later,
one more card is found, and its named eth1.
14 ns later, one more card is found and its named eth2.

If the computer is rebooted, the card that was eth1 might be named eth0
and eth1 will be named eth2. And eth0 will be named eth1.
As you understand, this is a problem.

So pretty please, with suger on top. WAIT until ALL cards are detected.
THEN name them. IN THE SAME ORDER ALL THE TIME. It doesnt matter what
order. Just do the same all the time. AND NEVER CHANGE THAT UNTIL THE
UNIVERSE CEASE TO EXISTS AND MANKIND DIES :)

I have seen this problem so many times during the 10 years I have worked
with Linux. COLD reboot, eth0 is eth0 and eth1 is eth1. WARM reboot,
eth0 is eth1 and eth1 is eth0. Or whatever. ITS ANNOYING. It doesnt
happend with every computer or all the time but it does happend. Its time
to solve this. It doesnt get more funny than this.

My BGP router/gateway/firewall computer with 3 network card has exactly
this problem. COLD reboot gives a specific network card order (the wrong
one!) and warm gives and other. Warm reboot gave a random network card order
before this;

rmmod e100
rmmod e1000
sleep 1
modprobe e1000
modprobe e100

fix in rc.sysinit directly after "Start up swapping". It took like 6 hours
before I realized that its the only workaround that will work. Nothing
else helped. Its NOT funny to reboot a BGP router all the time, the world
will not be happy. I pulled the plug so I wouldnt annoy the world however.

This is intel network card specific but the problem is deeper than just
intel network cards.

1. WAIT until ALL cards are detected.
2. THEN name them.
3. IN THE SAME ORDER ALL THE TIME.
4. ????
5. PROFIT!!!!
TagsNo tags attached.

Activities

user430

2009-09-04 09:40

  ~0009877

The /etc/sysconfig/network-scripts/ifcfg-* provide a way around that, you can get consistent naming with ifrename(8) or do it with udev. Everything is there.

user430

2009-09-04 09:41

  ~0009878

Nice rant, but not a bug report.

Issue History

Date Modified Username Field Change
2009-09-04 08:24 iocc New Issue
2009-09-04 09:40 user430 Note Added: 0009877
2009-09-04 09:41 user430 Note Added: 0009878
2009-09-04 09:41 user430 Status new => closed
2009-09-04 09:41 user430 Resolution open => not fixable