View Issue Details

IDProjectCategoryView StatusLast Update
0004092CentOS-5anacondapublic2010-01-07 13:52
ReporterCompuabba Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Product Version5.4 
Summary0004092: Exception on install causes Anaconda to abort install
DescriptionAnaconda aborts after receiving an exception during install of 5.4
Selected custom layout to preserve layout from prior 5.3 install.
Manually assigned network addresses.
Did not select Virtualization, clustering, or storage clustering.
Have Selected both "Customize now" during install and "Customize later" but I get an exception regardless.
last part of traceback:
 File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 309, in _sql_MD
    cache = getattr(self, MD + 'db')[repo]
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 44, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 317, in _sql_MD_pkg_num
    return self._sql_MD('primary', repo, sql).fetchone()[0]
Additional Informationamd Phenom 9650 quad core cpu
2 Seagate 750 GB drives
8 GB memory
HP Pavilion A6750F
TagsNo tags attached.

Relationships

child of 0003961 confirmedkbsingh@karan.org Anaconda installation bug 

Activities

2009-12-23 18:22

 

bug.centos5.4 (116,327 bytes)
papasmurf

papasmurf

2009-12-28 22:21

reporter   ~0010631

I am having essentially the same issue. Install crashes after a custom disk layout was selected.

Boot method: 5.4 i386 network boot image, data source = mirror.centos.org

"Server" install profile selected with the CentOS Extras repository selected but no custom RPMs chosen.

Hardware, Dell PE 2850 with a PERC 4 controller.

The exception occurs a few seconds after the dependency calculation of the selected RPMs starts. Exception happens predictably in the same place over and over.
papasmurf

papasmurf

2009-12-28 23:47

reporter   ~0010634

I believe I've narrowed down the problem to either the 'Server' default package group selection, or the button that includes the CentOS extras repository. I don't believe the choice of partitioning schemes has any impact.
thog

thog

2009-12-29 18:52

reporter   ~0010642

I believe it is indeed related to the "CentOS Extras" repository being checked. I did an identical install to a failed one with the same messages (Image over NFS, server install) with the only difference being that selection. It worked fine without the "CentOS Extras" repository checked.
doors_real

doors_real

2010-01-01 12:07

reporter   ~0010660

I had the same issue too. I used netinstall img.

the "CentOS Extras" repository was checked in.

without "CentOS Extras" repository worked fine
tru

tru

2010-01-07 13:52

administrator   ~0010697

#3961

Issue History

Date Modified Username Field Change
2009-12-23 18:22 Compuabba New Issue
2009-12-23 18:22 Compuabba File Added: bug.centos5.4
2009-12-28 22:21 papasmurf Note Added: 0010631
2009-12-28 23:47 papasmurf Note Added: 0010634
2009-12-29 17:02 toracat Relationship added child of 0003961
2009-12-29 18:52 thog Note Added: 0010642
2010-01-01 12:07 doors_real Note Added: 0010660
2010-01-07 13:52 tru Note Added: 0010697
2010-01-07 13:52 tru Status new => closed
2010-01-07 13:52 tru Resolution open => duplicate