View Issue Details

IDProjectCategoryView StatusLast Update
0004192CentOS-5CentOS-5-Pluspublic2011-05-17 15:59
Reporterntm 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.4 
Target VersionFixed in Version5.4 
Summary0004192: touchpad on dell E6400 not detected correctly
DescriptionUsing a fully up to date centos 5 x86_64 on a Dell Lattitude E6400, the touchpad is not detected as a synaptics/ALPS device.
As a result, it can work as a regular mouse but the nice capabilities of the synaptics touchpad driver are not available (eg scrolling).

I've tracked this down to a problem in drivers/input/mouse/alps.c , which doesn't know the signature of the newer Dell touchpad.
The attached trivial patch solves the issue. I have tested by rebuilding the latest C5 kernel (kernel-2.6.18-164.11.1.el5.x86_64) with this patch applied via the SPEC file.

The patch comes from:
http://lkml.org/lkml/2008/9/7/133 (solution for E6400 and E6500)
http://lkml.org/lkml/2007/8/4/41 (solves same problem for Vostro 1400)

TagsNo tags attached.

Activities

2010-02-11 18:03

 

linux-2.6-alps-E6400.patch (576 bytes)
--- a/drivers/input/mouse/alps.c	2010-02-11 11:07:45.000000000 +0100
+++ b/drivers/input/mouse/alps.c	2010-02-11 11:03:08.000000000 +0100
@@ -53,6 +53,8 @@
 	{ { 0x20, 0x02, 0x0e },	0xf8, 0xf8, ALPS_PASS | ALPS_DUALPOINT }, /* XXX */
 	{ { 0x22, 0x02, 0x0a },	0xf8, 0xf8, ALPS_PASS | ALPS_DUALPOINT },
 	{ { 0x22, 0x02, 0x14 }, 0xff, 0xff, ALPS_PASS | ALPS_DUALPOINT }, /* Dell Latitude D600 */
+	{ { 0x62, 0x02, 0x14 }, 0xcf, 0xcf, ALPS_PASS | ALPS_DUALPOINT }, /* Dell Latitude E6500 */
+ 	{ { 0x73, 0x02, 0x50 }, 0xcf, 0xcf, ALPS_FW_BK_1 } /* Dell Vostro 1400 */
 };
 
 /*
toracat

toracat

2010-02-11 18:12

manager   ~0010971

Last edited: 2010-02-11 18:20

While there is no way this can be added to the distro kernel, we can do it with the centosplus kernel.

Also, there is no need to recompile the whole kernel. A better solution would be to build a kABI-tracking kernel module.

toracat

toracat

2010-02-11 18:21

manager   ~0010973

Please file a report upstream ( http://bugzilla.redhat.com ) so that the fix gets incorporated into the distro kernel.
ntm

ntm

2010-02-11 19:56

reporter   ~0010975

I'm aware that it can't be fixed in the distro, but wanted it at least documented somewhere.

Building a kabi-tracking kmod would be cool, but I just didn't know how to do that (and couldn't research it just right now) while I'm familiar with rebuilding srpms ;-) .

Bug filed upstream here:
https://bugzilla.redhat.com/show_bug.cgi?id=564086

thanks!
toracat

toracat

2010-02-11 20:08

manager   ~0010977

Thanks for filing a bugzilla report. Could you also add this CentOS bug number in the "external bug" section?

Regarding building a kernel module, It might be kernel built-in rather than part of a module. This is under investigation.
ntm

ntm

2010-02-11 20:32

reporter   ~0010978

"external bug" added in RH bugzilla.
AlanBartlett

AlanBartlett

2010-02-11 20:39

reporter   ~0010979

With reference to the second and third sentences of note 10971 --

I have taken a look at the configuration for the distro kernel and find that the relevant section of code is compiled as a "built-in" and not as a module. So, unfortunately, a kernel independent, kABI tracking, kmod package is out of the question.

Incorporating the patch into the C-Plus kernel would be the only way to provide this functionality.
toracat

toracat

2010-02-11 20:48

manager   ~0010980

Last edited: 2010-02-11 20:58

Thanks, ntm, for adding the link.

Thanks, Alan, for looking into this issue. This patch should show up in the next cplus kernel update.

AlanBartlett

AlanBartlett

2010-02-11 20:49

reporter   ~0010981

Perhaps Nicholas (ntm -- the original reporter) would like to test the RHEL 5.5beta kernel (kernel-2.6.18-186.el5), which can be downloaded from --

http://people.redhat.com/jwilson/el5/186.el5/

-- letting us know the outcome and also posting the result to his upstream bz.
ntm

ntm

2010-02-11 21:18

reporter   ~0010982

I'm home now and my laptop isn't, but I'll test kernel-2.6.18-186.el5 tomorrow and report back.
But looking at the srpm, I doubt it'll be fixed.
toracat

toracat

2010-02-12 08:38

manager   ~0010985

I have added the patch to the current test version of centosplus kernel. It is named "kernel-2.6.18-164.11.1.el5.bug4139.4192.ayplus" and can be found here:

http://centos.toracat.org/kernel/centos5/bug4139plus/

Can you confirm that this fixes the problem?
ntm

ntm

2010-02-12 10:16

reporter   ~0010988

OK, I have tested both kernels:

Akemi, your kernel-2.6.18-164.11.1.el5.bug4139.4192.ayplus.x86_64 fixes the problem.

The RHEL 5.5beta 2.6.18-186.el5 does not.
toracat

toracat

2010-02-12 15:43

manager   ~0010989

@ntm

Thanks for testing. The patch will be in the next cplus kernel update.
ntm

ntm

2010-02-12 17:23

reporter   ~0010990

excellent, thanks Akemi!
toracat

toracat

2010-03-18 16:47

manager   ~0011092

kernel-2.6.18-164.15.1.el5.centos.plus is out that contains the patch reported here. Closing as resolved.
toracat

toracat

2010-11-30 16:56

manager   ~0012122

Reopening. A patch that addresses the issue reported here has been offered upstream:

https://bugzilla.redhat.com/show_bug.cgi?id=564086

The current CentOS patch will be replaced by that one in the next update to the cplus kernel.
ntm

ntm

2010-11-30 18:46

reporter   ~0012124

I will test the new patch in the next cplus kernel when it gets updated.
However since the previous patched kernel worked for me and I never noticed anything wrong with it, I will only be able to assess whether the new patch causes a regression for me compared to the old one.
I guess the new patch with the ALPS_PS2_INTERLEAVED stuff solves some issues that don't occur in my typical usage (which is admittedly limited, I mainly use this laptop for conferences or lectures).
toracat

toracat

2010-12-01 20:19

manager   ~0012126

@ntm

I went ahead and rebuilt the current cplus kernel using the patch from upstream. When you get a chance, could you try and see if that works for you as before?

http://centos.toracat.org/kernel/centos5/bz564086/
ntm

ntm

2010-12-02 12:05

reporter   ~0012130

@toracat

I just tested the x86_64 kernel from
http://centos.toracat.org/kernel/centos5/bz564086/

It works for me as before.

Furthermore, I played around with the old patched version and managed to break it by using the touchpad and trackpoint simultaneously. I never use the trackpoint so I had probably not triggered the problem before. The kernel logged some error messages such as:
psmouse.c: DualPoint TouchPad at isa0060/serio1/input0 lost sync at byte [some number]
and then scrolling no longer worked.

I tried reproducing this breakage with the new patched kernel but could not.
So, the new patch seems all good! Thank you.
toracat

toracat

2010-12-02 13:35

manager   ~0012131

@ntm

That is excellent news. Thank you for testing and reporting back. The new patch will be in the next cplus kernel update. Not sure how soon it will appear in the upstream (RH) kernel though. May be too late to be included in 5.6.
toracat

toracat

2010-12-13 19:44

manager   ~0012226

The upstream vendor closed the bugzilla as WONTFIX[1]. The reason was:

"We have closed this bug WONTFIX in order to prioritize more urgent bugs being reported by our customer base. Again, per comment #20, if you would like to see this bug fixed, please contact Red Hat Support and we'll make sure this gets handled appropriately."

The patch offered by them will be included in the cplus kernel indefinitely.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=564086

Issue History

Date Modified Username Field Change
2010-02-11 18:03 ntm New Issue
2010-02-11 18:03 ntm File Added: linux-2.6-alps-E6400.patch
2010-02-11 18:12 toracat Note Added: 0010971
2010-02-11 18:12 toracat Status new => assigned
2010-02-11 18:20 toracat Note Edited: 0010971
2010-02-11 18:21 toracat Note Added: 0010973
2010-02-11 19:56 ntm Note Added: 0010975
2010-02-11 20:08 toracat Note Added: 0010977
2010-02-11 20:32 ntm Note Added: 0010978
2010-02-11 20:39 AlanBartlett Note Added: 0010979
2010-02-11 20:48 toracat Note Added: 0010980
2010-02-11 20:49 AlanBartlett Note Added: 0010981
2010-02-11 20:58 toracat Note Edited: 0010980
2010-02-11 21:18 ntm Note Added: 0010982
2010-02-12 08:38 toracat Note Added: 0010985
2010-02-12 08:39 toracat Status assigned => feedback
2010-02-12 10:16 ntm Note Added: 0010988
2010-02-12 15:43 toracat Note Added: 0010989
2010-02-12 15:43 toracat Status feedback => confirmed
2010-02-12 15:43 toracat Resolution open => fixed
2010-02-12 17:23 ntm Note Added: 0010990
2010-03-18 16:47 toracat Note Added: 0011092
2010-03-18 16:47 toracat Status confirmed => resolved
2010-03-18 16:47 toracat Fixed in Version => 5.4
2010-11-30 16:56 toracat Note Added: 0012122
2010-11-30 16:56 toracat Status resolved => feedback
2010-11-30 16:56 toracat Resolution fixed => reopened
2010-11-30 16:56 toracat Status feedback => assigned
2010-11-30 18:46 ntm Note Added: 0012124
2010-12-01 20:19 toracat Note Added: 0012126
2010-12-02 12:05 ntm Note Added: 0012130
2010-12-02 13:35 toracat Note Added: 0012131
2010-12-13 19:44 toracat Note Added: 0012226
2011-02-22 20:25 toracat Category kernel => CentOS-5-Plus
2011-05-17 15:59 toracat Status assigned => resolved
2011-05-17 15:59 toracat Resolution reopened => fixed