View Issue Details

IDProjectCategoryView StatusLast Update
0004282websitewebsitepublic2010-05-10 01:37
Reporterprschaffner 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0004282: Private Message Notifications no longer working for CentOS Fora
DescriptionSome time on about Tuesday April 20, 2010 Private Message Notifications stopped working for the CentOS Fora. I use notifications extensively on the fora and have gotten no new notifications for the past two days, despite the presence of numerous new posts and topics that should have generated notifications. Have tried changing notification method to Email, temporarily suspended, and back to PM; also editing Notifications, adding and deleting, to no effect. Old messages remained in the inbox after the problem started until they were deleted. No new messages have appeared, nor does sending a PM appear to work.
Additional InformationThe problem has been confirmed by toracat. Forum thread on the issue:
https://www.centos.org/modules/newbb/viewtopic.php?viewmode=flat&topic_id=25885&forum=1
TagsNo tags attached.

Activities

prschaffner

prschaffner

2010-04-22 10:18

reporter   ~0011167

Notifications do work when Notification method is set to "email".
donavan

donavan

2010-04-30 19:52

reporter   ~0011199

I deleted a bunch of message from the private message queue.

mysql> DELETE from xoops_priv_msgs WHERE read_msg = '0' AND msg_time < 1271656470;
Query OK, 427572 rows affected (1 min 22.33 sec)

Let me know if notifications begin to work.
prschaffner

prschaffner

2010-05-02 11:41

reporter   ~0011203

I see posts on the fora that should have generated PM notifications after the time of the delete, but still nothing in my queue. An attempt to send a PM still returns "Error" "None" as it did previously. Still seems broken.
AlanBartlett

AlanBartlett

2010-05-02 13:28

reporter   ~0011204

I have tested this by attempting to send Phil (prschaffner) a PM on 2010-04-30 which, in the light of note 11203, has not been received . . .
AlanBartlett

AlanBartlett

2010-05-07 00:58

reporter   ~0011230

I recently received an e-mail message from a forum member in which it was mentioned that a PM had been sent to me.

On checking, I saw that the message had not been delivered.

Hence I deduce that the system is still broken.
donavan

donavan

2010-05-09 00:20

reporter   ~0011238

mysql and/or xoops kiddieware issue.

msg_id's start at 0 and go to 16777215, at which point mysql inserts fail. WHY WHY WHY @ 24bits?

I deleted all private messages, tested sending PMs again and all is well.

Someday when the centos website is designed...
donavan

donavan

2010-05-09 00:21

reporter   ~0011239

nothing to add. toy systems? I'm sure this problem is present in numerous other areas as well.
toracat

toracat

2010-05-09 15:15

manager   ~0011240

Donavan,

First of all, thanks for your effort to rectify the issue. I am reopening this report because Phil indicated in the forum thread that PM was still not working and I could confirm it. I attempted to send a PM for testing and got the error:

Errors
None

Go Back

I tried twice and got that same error message both times. Any ideas?
toracat

toracat

2010-05-09 15:17

manager   ~0011241

... Or is that saying "Errors" were "None" ? It looks as if that is the case.
toracat

toracat

2010-05-09 15:20

manager   ~0011242

I will wait for Phil's response. If/when it is confirmed by him that he got the test PMs, I will ask you to close the report (once again).
AlanBartlett

AlanBartlett

2010-05-09 15:21

reporter   ~0011243

toracat, please send me a test PM.
toracat

toracat

2010-05-09 15:28

manager   ~0011244

A test PM sent to you.
AlanBartlett

AlanBartlett

2010-05-09 15:41

reporter   ~0011245

Message sent by toracat was not received by me.

Hence this functionality is still broken.
donavan

donavan

2010-05-10 01:04

reporter   ~0011247

Did you folks logout and log back into the centos.org website? Persistent connections might be causing the excessive value to be used when xoops goes for the next message ID.

.dn

2010-05-10 01:04

 

centos.pm.png (72,724 bytes)
centos.pm.png (72,724 bytes)
donavan

donavan

2010-05-10 01:05

reporter   ~0011248

I uploaded a screen shot of a successful PM send and the resulting PM opened...
donavan

donavan

2010-05-10 01:10

reporter   ~0011249

I hope this is a reopen. I'll confirm the issue persists.

.dn
donavan

donavan

2010-05-10 01:37

reporter   ~0011250

priv_msgs table has an auto_increment on msg_id.

This drops all messages and resets the auto_increment back on it's way to 24bits...

truncate table xoops_priv_msgs;
donavan

donavan

2010-05-10 01:37

reporter   ~0011251

Lets try this again. :)

Issue History

Date Modified Username Field Change
2010-04-22 09:50 prschaffner New Issue
2010-04-22 10:18 prschaffner Note Added: 0011167
2010-04-30 19:52 donavan Note Added: 0011199
2010-05-02 11:41 prschaffner Note Added: 0011203
2010-05-02 13:28 AlanBartlett Note Added: 0011204
2010-05-07 00:58 AlanBartlett Note Added: 0011230
2010-05-09 00:20 donavan Note Added: 0011238
2010-05-09 00:21 donavan Note Added: 0011239
2010-05-09 00:21 donavan Status new => resolved
2010-05-09 00:21 donavan Resolution open => fixed
2010-05-09 15:15 toracat Note Added: 0011240
2010-05-09 15:15 toracat Status resolved => feedback
2010-05-09 15:15 toracat Resolution fixed => reopened
2010-05-09 15:17 toracat Note Added: 0011241
2010-05-09 15:20 toracat Note Added: 0011242
2010-05-09 15:21 AlanBartlett Note Added: 0011243
2010-05-09 15:28 toracat Note Added: 0011244
2010-05-09 15:41 AlanBartlett Note Added: 0011245
2010-05-10 01:04 donavan Note Added: 0011247
2010-05-10 01:04 donavan File Added: centos.pm.png
2010-05-10 01:05 donavan Note Added: 0011248
2010-05-10 01:10 donavan Note Added: 0011249
2010-05-10 01:10 donavan Status feedback => confirmed
2010-05-10 01:37 donavan Note Added: 0011250
2010-05-10 01:37 donavan Note Added: 0011251
2010-05-10 01:37 donavan Status confirmed => resolved
2010-05-10 01:37 donavan Resolution reopened => fixed