View Issue Details

IDProjectCategoryView StatusLast Update
0004345mirrorunclassifiedpublic2010-05-28 21:04
Reportercrispygoth 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Summary0004345: 'yum update' failing: device-mapper "Package does not match intended download"
DescriptionWhen trying to run an update this morning, I get the following error:


[root@officevps ~]# yum clean all
Loaded plugins: fastestmirror
Cleaning up Everything
Cleaning up list of fastest mirrors
[root@officevps ~]# yum update
Loaded plugins: fastestmirror
Determining fastest mirrors
 * addons: mirrors.manchester.icecolo.com
 * base: mirrors.manchester.icecolo.com
 * extras: mirrors.manchester.icecolo.com
 * openvz-kernel-rhel5: mirror.fr.it2go.eu
 * openvz-utils: mirror.fr.it2go.eu
 * updates: www.mirrorservice.org
addons | 951 B 00:00
addons/primary | 202 B 00:00
base | 1.1 kB 00:00
base/primary | 920 kB 00:02
base 2599/2599
extras | 2.1 kB 00:00
extras/primary_db | 180 kB 00:00
openvz-kernel-rhel5 | 951 B 00:00
openvz-kernel-rhel5/primary | 27 kB 00:00
openvz-kernel-rhel5 14/14
openvz-utils | 951 B 00:00
openvz-utils/primary | 5.8 kB 00:00
openvz-utils 26/26
updates | 1.9 kB 00:00
updates/primary_db | 127 kB 00:00
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package device-mapper.i386 0:1.02.39-1.el5_5.2 set to be updated
---> Package device-mapper-event.i386 0:1.02.39-1.el5_5.2 set to be updated
---> Package krb5-libs.i386 0:1.6.1-36.el5_5.4 set to be updated
---> Package krb5-workstation.i386 0:1.6.1-36.el5_5.4 set to be updated
---> Package lvm2.i386 0:2.02.56-8.el5_5.4 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================
 Package Arch Version Repository Size
====================================================================================================================
Updating:
 device-mapper i386 1.02.39-1.el5_5.2 updates 724 k
 device-mapper-event i386 1.02.39-1.el5_5.2 updates 20 k
 krb5-libs i386 1.6.1-36.el5_5.4 updates 662 k
 krb5-workstation i386 1.6.1-36.el5_5.4 updates 881 k
 lvm2 i386 2.02.56-8.el5_5.4 updates 2.5 M

Transaction Summary
====================================================================================================================
Install 0 Package(s)
Upgrade 5 Package(s)

Total download size: 4.8 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): device-mapper-event-1.02.39-1.el5_5.2.i386.rpm | 20 kB 00:00
(2/5): krb5-libs-1.6.1-36.el5_5.4.i386.rpm | 662 kB 00:01
(3/5): device-mapper-1.02.39-1.el5_5.2.i386.rpm | 724 kB 00:01
http://www.mirrorservice.org/sites/mirror.centos.org/5.5/updates/i386/RPMS/device-mapper-1.02.39-1.el5_5.2.i386.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(3/5): device-mapper-1.02.39-1.el5_5.2.i386.rpm | 724 kB 00:00
http://mirror.as29550.net/mirror.centos.org/5.5/updates/i386/RPMS/device-mapper-1.02.39-1.el5_5.2.i386.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(3/5): device-mapper-1.02.39-1.el5_5.2.i386.rpm | 724 kB 00:00
http://mirror.ox.ac.uk/sites/mirror.centos.org/5.5/updates/i386/RPMS/device-mapper-1.02.39-1.el5_5.2.i386.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(3/5): device-mapper-1.02.39-1.el5_5.2.i386.rpm | 724 kB 00:01
http://mirrors.melbourne.co.uk/sites/ftp.centos.org/centos/5.5/updates/i386/RPMS/device-mapper-1.02.39-1.el5_5.2.i386.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(3/5): device-mapper-1.02.39-1.el5_5.2.i386.rpm | 724 kB 00:00
http://anorien.csc.warwick.ac.uk/mirrors/centos/5.5/updates/i386/RPMS/device-mapper-1.02.39-1.el5_5.2.i386.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(3/5): device-mapper-1.02.39-1.el5_5.2.i386.rpm | 724 kB 00:00
http://mirror.liteserver.nl/pub/centos/5.5/updates/i386/RPMS/device-mapper-1.02.39-1.el5_5.2.i386.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(3/5): device-mapper-1.02.39-1.el5_5.2.i386.rpm | 724 kB 00:01
http://ftp.heanet.ie/pub/centos/5.5/updates/i386/RPMS/device-mapper-1.02.39-1.el5_5.2.i386.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(3/5): device-mapper-1.02.39-1.el5_5.2.i386.rpm | 724 kB 00:00
http://centos.mirror.transip.nl/5.5/updates/i386/RPMS/device-mapper-1.02.39-1.el5_5.2.i386.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(3/5): device-mapper-1.02.39-1.el5_5.2.i386.rpm | 724 kB 00:00
http://ftp.tudelft.nl/centos.org/5.5/updates/i386/RPMS/device-mapper-1.02.39-1.el5_5.2.i386.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(3/5): device-mapper-1.02.39-1.el5_5.2.i386.rpm | 724 kB 00:00
http://archive.cs.uu.nl/mirror/Linux/centos/5.5/updates/i386/RPMS/device-mapper-1.02.39-1.el5_5.2.i386.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(4/5): krb5-workstation-1.6.1-36.el5_5.4.i386.rpm | 881 kB 00:02
(5/5): lvm2-2.02.56-8.el5_5.4.i386.rpm | 2.5 MB 00:07


Error Downloading Packages:
  device-mapper-1.02.39-1.el5_5.2.i386: failure: RPMS/device-mapper-1.02.39-1.el5_5.2.i386.rpm from updates: [Errno 256] No more mirrors to try.
TagsNo tags attached.

Relationships

has duplicate 0004344 closedkbsingh@karan.org CentOS-5 Missing Dependency for firefox-3.0.19-1.el5.centos.i386 

Activities

tru

tru

2010-05-28 12:23

administrator   ~0011358

public mirrors out of sync, they don't update hourly but about 4 times a day.
Please retry later and report if still broken after a day.
tru

tru

2010-05-28 12:25

administrator   ~0011359

public mirrors staus at http://mirror-status.centos.org/

 * openvz-kernel-rhel5: mirror.fr.it2go.eu
 * openvz-utils: mirror.fr.it2go.eu
are not CentOS ;)
tru

tru

2010-05-28 12:53

administrator   ~0011362

https://www.centos.org/modules/newbb/viewtopic.php?topic_id=26477&start=0
rgagnon

rgagnon

2010-05-28 18:17

reporter   ~0011370

Are you sure about the public mirrors being behind? Even your own mirror status shows some mirrors that have updated less than one hour ago, and still the files in repodata are not matching the RPMS.
kstange

kstange

2010-05-28 19:15

reporter   ~0011371

This is not a case of public mirrors being out of sync. This is happening for the following 19 packages. I'm a public mirror admin and have tested the packages locally on my mirror. This affects only i386:


  verifying xen-libs-3.0.3-105.el5_5.2.i386 checksum FAILED
  verifying openais-devel-0.80.6-16.el5_5.1.i386 checksum FAILED
  verifying pango-devel-1.14.9-8.el5.centos.i386 checksum FAILED
  verifying quagga-devel-0.98.6-5.el5_5.1.i386 checksum FAILED
  verifying device-mapper-1.02.39-1.el5_5.2.i386 checksum FAILED
  verifying nss-pkcs11-devel-3.12.6-1.el5.centos.i386 checksum FAILED
  verifying nss-3.12.6-1.el5.centos.i386 checksum FAILED
  verifying libpurple-2.6.6-2.el5_4.i386 checksum FAILED
  verifying gnutls-devel-1.4.1-3.el5_4.8.i386 checksum FAILED
  verifying nspr-devel-4.8.4-1.el5_4.i386 checksum FAILED
  verifying krb5-libs-1.6.1-36.el5_5.2.i386 checksum FAILED
  verifying xen-devel-3.0.3-105.el5_5.2.i386 checksum FAILED
  verifying 1:net-snmp-libs-5.3.2.2-9.el5_5.1.i386 checksum FAILED
  verifying nspr-4.8.4-1.el5_4.i386 checksum FAILED
  verifying 1:net-snmp-devel-5.3.2.2-9.el5_5.1.i386 checksum FAILED
  verifying nss-devel-3.12.6-1.el5.centos.i386 checksum FAILED
  verifying krb5-devel-1.6.1-36.el5_5.2.i386 checksum FAILED
  verifying nss_db-2.2-35.4.el5_5.i386 checksum FAILED
  verifying gnutls-1.4.1-3.el5_4.8.i386 checksum FAILED
kstange

kstange

2010-05-28 19:18

reporter   ~0011372

To clarify, this occurs after I have run a manual update a few times after deleting the repodata and/or one or two problem packages. This problem exists with rsync content from either centosu or centosk2.
tru

tru

2010-05-28 20:39

administrator   ~0011373

main (non public) centos server has:

$ md5sum 5.5/updates/i386/repodata/*
d8853c851fe7dad450b90628e614b9d7 5.5/updates/i386/repodata/filelists.sqlite.bz2
fed0a934d038192cc58dbbcc6d423f21 5.5/updates/i386/repodata/filelists.xml.gz
a22b69e06082210126a4ce4ff1933f46 5.5/updates/i386/repodata/other.sqlite.bz2
53f92126ab388dd03cc41ecc1210e24c 5.5/updates/i386/repodata/other.xml.gz
36d34879c086e157bf6ea11504bd6e45 5.5/updates/i386/repodata/primary.sqlite.bz2
f0f1bf1b78ca04e5a01ea19a61f9944e 5.5/updates/i386/repodata/primary.xml.gz
e4fe3967cc447bcf03a8947f364638ca 5.5/updates/i386/repodata/repomd.xml
$ ll 5.5/updates/i386/repodata/*
-rw-r--r-- 1 tru centos5 539813 May 28 16:58 5.5/updates/i386/repodata/filelists.sqlite.bz2
-rw-r--r-- 1 tru centos5 418755 May 28 16:58 5.5/updates/i386/repodata/filelists.xml.gz
-rw-r--r-- 1 tru centos5 1612372 May 28 16:58 5.5/updates/i386/repodata/other.sqlite.bz2
-rw-r--r-- 1 tru centos5 2019455 May 28 16:58 5.5/updates/i386/repodata/other.xml.gz
-rw-r--r-- 1 tru centos5 129601 May 28 16:58 5.5/updates/i386/repodata/primary.sqlite.bz2
-rw-r--r-- 1 tru centos5 72766 May 28 16:58 5.5/updates/i386/repodata/primary.xml.gz
-rw-r--r-- 1 tru centos5 1953 May 28 16:58 5.5/updates/i386/repodata/repomd.xml
kstange

kstange

2010-05-28 20:45

reporter   ~0011374

My mirror matches those md5s, sizes and timestamps. So either the content is globally wrong or the packages themselves are not correct.
tru

tru

2010-05-28 20:51

administrator   ~0011375

I have now cleared the 'corrupted?' createrepo cache...

[tru@sillage master2]$ md5sum 5.5/updates/i386/repodata/*
7d4408d2355bfc32ec8fe1408e66c9e2 5.5/updates/i386/repodata/filelists.sqlite.bz2
c0133614c4d9c925ab899fee5448a2cf 5.5/updates/i386/repodata/filelists.xml.gz
0bcb86a4c2408c7c29a095a49a574e86 5.5/updates/i386/repodata/other.sqlite.bz2
e92a71fbce741b2e4c4f783de6efd6f4 5.5/updates/i386/repodata/other.xml.gz
56961eaa6f732c5edec377c957d33697 5.5/updates/i386/repodata/primary.sqlite.bz2
b6d2d3e3c871a8da72802073ea549e0e 5.5/updates/i386/repodata/primary.xml.gz
86c861eea1fe583f6e2c1fcdc960cf5c 5.5/updates/i386/repodata/repomd.xml
[tru@sillage master2]$ ll !$
ll 5.5/updates/i386/repodata/*
-rw-r--r-- 1 tru Bis 539339 May 28 22:47 5.5/updates/i386/repodata/filelists.sqlite.bz2
-rw-r--r-- 1 tru Bis 418757 May 28 22:47 5.5/updates/i386/repodata/filelists.xml.gz
-rw-r--r-- 1 tru Bis 1612697 May 28 22:47 5.5/updates/i386/repodata/other.sqlite.bz2
-rw-r--r-- 1 tru Bis 2019455 May 28 22:47 5.5/updates/i386/repodata/other.xml.gz
-rw-r--r-- 1 tru Bis 129593 May 28 22:47 5.5/updates/i386/repodata/primary.sqlite.bz2
-rw-r--r-- 1 tru Bis 72772 May 28 22:47 5.5/updates/i386/repodata/primary.xml.gz
tru

tru

2010-05-28 21:03

administrator   ~0011376

#centos-mirror to any public mirror is the direct channel
or centos-mirror mailing list
tru

tru

2010-05-28 21:04

administrator   ~0011377

new metadata should be available now, please check md5sum and date

Issue History

Date Modified Username Field Change
2010-05-28 11:18 crispygoth New Issue
2010-05-28 12:23 tru Note Added: 0011358
2010-05-28 12:25 tru Note Added: 0011359
2010-05-28 12:52 tru Relationship added has duplicate 0004344
2010-05-28 12:53 tru Note Added: 0011362
2010-05-28 12:53 tru Status new => feedback
2010-05-28 18:17 rgagnon Note Added: 0011370
2010-05-28 19:15 kstange Note Added: 0011371
2010-05-28 19:18 kstange Note Added: 0011372
2010-05-28 19:23 toracat Description Updated
2010-05-28 19:34 kstange Status feedback => confirmed
2010-05-28 20:39 tru Note Added: 0011373
2010-05-28 20:45 kstange Note Added: 0011374
2010-05-28 20:51 tru Note Added: 0011375
2010-05-28 21:03 tru Note Added: 0011376
2010-05-28 21:04 tru Note Added: 0011377
2010-05-28 21:04 tru Status confirmed => resolved
2010-05-28 21:04 tru Resolution open => fixed