View Issue Details

IDProjectCategoryView StatusLast Update
0004471CentOS-5httpdpublic2013-03-23 13:20
Status resolvedResolutionfixed 
Product Version5.2 
Target VersionFixed in Version 
Summary0004471: httpd child segmentation fault
DescriptionConnection to the Apache server results in a blank page (using firefox), or Page cannot be displayed (using IE6/8).

All subsequent requests have the same result until the httpd process is restarted.
Additional Information[notice] child pid 6085 exit signal Segmentation fault (11)
is seen in the apache error log for every connection to the server

CentOS 5.2 64bit

TagsNo tags attached.




2010-08-06 08:58

administrator   ~0011721

Is there a way to reproduce that?

2010-08-06 10:27

administrator   ~0011723

A yum upgrade wont go amiss either.


2010-08-20 13:19

reporter   ~0011781

We just had the same problem on our server.

Restarting Apache solved it (/etc/init.d/httpd restart).

Server configuration:
CentOS release 5.5 (Final)
OVH Kernel: #1 (amd64 with GRSecurity patch)
CPU: Xeon E5405 (2Ghz)

We never had this problem before (this configuration is running for months).

Error in dmesg:
grsec: From Segmentation fault occurred at (null) in /usr/sbin/httpd[httpd:18475] uid/euid:48/48 gid/egid:48/48, parent /usr/sbin/httpd[httpd:5037] uid/euid:0/0 gid/egid:0/0

Error in error_log of apache:
[Fri Aug 20 14:58:21 2010] [notice] child pid 18475 exit signal Segmentation fault (11)

Had many of those messages (with different child & IP).

Strange thing is 2 of our virtualhosts were working correctly and all the others were seg faulting (same instance of Apache).


2010-08-20 13:22

reporter   ~0011782

Using httpd-2.2.3-43.el5.centos (x86_64).


2010-09-01 11:40

reporter   ~0011809

I had this with CentOS 5.5, httpd-2.2.3-43.el5.centos.3 x86_64.

Running strace on the child process gave...

open("/usr/lib64/apr-util-1/", O_RDONLY) = -1 ENOENT (No such file or directory)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
chdir("/etc/httpd") = 0
rt_sigaction(SIGSEGV, {SIG_DFL, [], SA_RESTORER|SA_INTERRUPT, 0x2abe11877b10}, {SIG_DFL, [], SA_RESTORER|SA_RESETHAND, 0x2abe11877b10}, 8) = 0
kill(27561, SIGSEGV) = 0
rt_sigreturn(0x6ba9) = 46995892028160

Installing apr-util-ldap was a workaround for me.


2010-09-01 12:04

administrator   ~0011810

So you are describing *THREE* different problems. Elbereth: You have a grsec kernel. That is not CentOS, so we frankly don't care here.

None of those seems to be reproducable.

What are we supposed to do here?


2010-09-01 12:17

reporter   ~0011811

Thanks for not caring. Good to know.

Anyway we found the problem, it was the PHP version of CentOS which was too old in the repository and was causing this. An upgrade to 5.3.3 fixed the segfaulting... But that was not CentOS problem of course. Sorry for bothering you.


2013-03-23 13:20

manager   ~0016838

Marked as solved per reporters feedback

Issue History

Date Modified Username Field Change
2010-08-06 02:02 ceakins New Issue
2010-08-06 08:58 range Note Added: 0011721
2010-08-06 10:27 Note Added: 0011723
2010-08-20 13:19 Elbereth Note Added: 0011781
2010-08-20 13:22 Elbereth Note Added: 0011782
2010-09-01 11:40 am399 Note Added: 0011809
2010-09-01 12:04 range Note Added: 0011810
2010-09-01 12:17 Elbereth Note Added: 0011811
2013-03-23 13:20 tigalch Note Added: 0016838
2013-03-23 13:20 tigalch Status new => resolved
2013-03-23 13:20 tigalch Resolution open => fixed