View Issue Details

IDProjectCategoryView StatusLast Update
0004648CentOS-6reportpublic2011-07-06 23:16
Reporterarrfab 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product VersionPre Release 
Target VersionFixed in Version6.0 
Summary0004648: report SRPM will produce report-config-RHEL-bugzilla-redhat-com which points upstream
Descriptionthe package report-config-RHEL-bugzilla-redhat-com that contains links to upstream
TagsNo tags attached.

Relationships

related to 0004647 resolvedkbsingh@karan.org Abrt needs to be addressed - it pushes content to bugzilla.r.c 

Activities

2010-12-02 05:18

 

report-0.18-el6_example.patch (7,726 bytes)
diff -uNr report-0.18.orig/etc/report.d/bugzilla.redhat.com.conf report-0.18/etc/report.d/bugzilla.redhat.com.conf
--- report-0.18.orig/etc/report.d/bugzilla.redhat.com.conf	2010-06-19 12:02:06.000000000 -0400
+++ report-0.18/etc/report.d/bugzilla.redhat.com.conf	2010-11-30 04:36:07.000000000 -0500
@@ -1,7 +1,7 @@
-[bugzilla.redhat.com]
+[bugzilla.centos.org]
 # plugin
 plugin=bugzilla
 
 # rhbz url
-bugzilla_host=bugzilla.redhat.com
+bugzilla_host=bugzilla.centos.org
 
diff -uNr report-0.18.orig/etc/report.d/RHEL-bugzilla.redhat.com.conf report-0.18/etc/report.d/RHEL-bugzilla.redhat.com.conf
--- report-0.18.orig/etc/report.d/RHEL-bugzilla.redhat.com.conf	2010-06-17 14:06:07.000000000 -0400
+++ report-0.18/etc/report.d/RHEL-bugzilla.redhat.com.conf	2010-11-30 04:41:33.000000000 -0500
@@ -1,4 +1,4 @@
-[RHEL-bugzilla.redhat.com]
+[RHEL-bugzilla.centos.org]
 
 plugin=RHEL-bugzilla
-bugzilla_host=bugzilla.redhat.com
+bugzilla_host=bugzilla.centos.org
diff -uNr report-0.18.orig/etc/report.d/RHEL.conf report-0.18/etc/report.d/RHEL.conf
--- report-0.18.orig/etc/report.d/RHEL.conf	2010-11-30 04:33:34.000000000 -0500
+++ report-0.18/etc/report.d/RHEL.conf	2010-11-30 04:39:33.000000000 -0500
@@ -1,4 +1,4 @@
-[Red Hat Global Support]
+[CentOS Global Support]
 
 priority=1
 
@@ -7,10 +7,10 @@
 
 # strataURL is the base URL of the Strata server
 #   if not set, strataURL defaults to http://<strata_host>/Strata
-strataURL = https://api.access.redhat.com/rs
+strataURL = https://api.access.centos.org/rs
 
-buttonURLPattern = api.access.redhat.com/rs
-buttonURLRepl = access.redhat.com/support
+buttonURLPattern = api.access.centos.org/rs
+buttonURLRepl = access.centos.org/support
 
 # if strataURL is not set, strata_host can be, and is used to 
 #    create the default strataURL
@@ -21,7 +21,7 @@
 #strata_host = access.redhat.com
 
 
-[Red Hat Global Support (FTP)]
+[CentOS Global Support (FTP)]
 
 priority=2
 
@@ -30,4 +30,4 @@
 
 # urldir is the directory that the report should be uploaded to
 #  it must be formatted as a URL, and must be a directory 
-urldir=ftp://dropbox.redhat.com/incoming
+urldir=ftp://dropbox.centos.org/incoming
diff -uNr report-0.18.orig/etc/report.d/strata-test.conf report-0.18/etc/report.d/strata-test.conf
--- report-0.18.orig/etc/report.d/strata-test.conf	2010-11-30 04:33:34.000000000 -0500
+++ report-0.18/etc/report.d/strata-test.conf	2010-11-30 04:42:50.000000000 -0500
@@ -9,8 +9,8 @@
 
 sslcertdata = INSECURE
 
-buttonURLPattern = api.avalon-ci.gss.redhat.com/rs
-buttonURLRepl = avalon-ci.gss.redhat.com/support
+buttonURLPattern = api.avalon-ci.gss.centos.org/rs
+buttonURLRepl = avalon-ci.gss.centos.org/support
 
 # if strataURL is not set, strata_host can be, and is used to 
 #    create the default strataURL
diff -uNr report-0.18.orig/python/bin/report report-0.18/python/bin/report
--- report-0.18.orig/python/bin/report	2010-11-30 04:33:34.000000000 -0500
+++ report-0.18/python/bin/report	2010-11-30 04:47:25.000000000 -0500
@@ -47,7 +47,7 @@
 except:
     pass
 
-Username_account_name = "bugzilla.redhat.com"
+Username_account_name = "bugzilla.centos.org"
 Username_config_filename = None
 try:
     Username_config_filename = os.environ['HOME'] + "/.report_username_for_" + Username_account_name
diff -uNr report-0.18.orig/python/bin/report.1 report-0.18/python/bin/report.1
--- report-0.18.orig/python/bin/report.1	2010-06-19 12:02:06.000000000 -0400
+++ report-0.18/python/bin/report.1	2010-11-30 04:47:56.000000000 -0500
@@ -58,4 +58,4 @@
 .fi
 
 .SH "BUGS"
-File a ticket within http://bugzilla.redhat.com/
+File a ticket within http://bugzilla.centos.org/
diff -uNr report-0.18.orig/python/report/plugins/bugzilla/filer.py report-0.18/python/report/plugins/bugzilla/filer.py
--- report-0.18.orig/python/report/plugins/bugzilla/filer.py	2010-06-19 20:45:49.000000000 -0400
+++ report-0.18/python/report/plugins/bugzilla/filer.py	2010-11-30 04:49:59.000000000 -0500
@@ -24,8 +24,8 @@
 from report import _report as _
 import report.release_information
 
-_hardcoded_default_product = 'Fedora'
-_hardcoded_default_version = 'rawhide'
+_hardcoded_default_product = 'CentOS'
+_hardcoded_default_version = '6'
 _hardcoded_default_product_for_bugzilla = _hardcoded_default_product
 
 def getProduct():
diff -uNr report-0.18.orig/python/report/plugins/RHEL-bugzilla/bugzillaCopy/base.py report-0.18/python/report/plugins/RHEL-bugzilla/bugzillaCopy/base.py
--- report-0.18.orig/python/report/plugins/RHEL-bugzilla/bugzillaCopy/base.py	2010-06-30 12:50:30.000000000 -0400
+++ report-0.18/python/report/plugins/RHEL-bugzilla/bugzillaCopy/base.py	2010-11-30 04:55:01.000000000 -0500
@@ -56,7 +56,7 @@
 class BugzillaBase(object):
     '''An object which represents the data and methods exported by a Bugzilla
     instance. Uses xmlrpclib to do its thing. You'll want to create one thusly:
-    bz=Bugzilla(url='https://bugzilla.redhat.com/xmlrpc.cgi',user=u,password=p)
+    bz=Bugzilla(url='https://bugzilla.centos.org/xmlrpc.cgi',user=u,password=p)
 
     You can get authentication cookies by calling the login() method. These
     cookies will be stored in a MozillaCookieJar-style file specified by the
@@ -738,7 +738,7 @@
         Important custom fields (used by RH Bugzilla and maybe others):
         DEFAULTED: 
           bug_file_loc: URL pointing to additional information for bug report. 
-            Ex: http://username.fedorapeople.org/logs/crashlog.txt
+            Ex: http://username.centos.org/logs/crashlog.txt
           reporter: Bugzilla username to use as reporter. 
         OPTIONAL: 
           blocked: List of bug ids this report blocks.
@@ -1130,8 +1130,8 @@
         '''Set any of the assigned_to, reporter, or qa_contact fields to a new
         bugzilla account, with an optional comment, e.g.
         setassignee(reporter='sadguy@brokencomputer.org',
-                    assigned_to='wwoods@redhat.com')
-        setassignee(qa_contact='wwoods@redhat.com',comment='wwoods QA ftw')
+                    assigned_to='wwoods@centos.org')
+        setassignee(qa_contact='wwoods@centos.org',comment='wwoods QA ftw')
         You must set at least one of the three assignee fields, or this method
         will throw a ValueError.
         Returns [bug_id, mailresults].'''
diff -uNr report-0.18.orig/python/report/plugins/RHEL-bugzilla/filer.py report-0.18/python/report/plugins/RHEL-bugzilla/filer.py
--- report-0.18.orig/python/report/plugins/RHEL-bugzilla/filer.py	2010-06-19 20:45:49.000000000 -0400
+++ report-0.18/python/report/plugins/RHEL-bugzilla/filer.py	2010-11-30 04:51:04.000000000 -0500
@@ -24,9 +24,9 @@
 from report import _report as _
 import report.release_information
 
-_hardcoded_default_product = 'Red Hat Enterprise Linux'
+_hardcoded_default_product = 'CentOS'
 _hardcoded_default_version = '6.0'
-_hardcoded_default_product_for_bugzilla = 'Red Hat Enterprise Linux 6'
+_hardcoded_default_product_for_bugzilla = 'CentOS 6'
 
 def getProduct():
     product = report.release_information.getProduct()
diff -uNr report-0.18.orig/python/report/release_information.py report-0.18/python/report/release_information.py
--- report-0.18.orig/python/report/release_information.py	2010-11-30 04:33:34.000000000 -0500
+++ report-0.18/python/report/release_information.py	2010-11-30 05:00:27.000000000 -0500
@@ -51,8 +51,8 @@
         if os.path.exists(each_path):
             file = open(each_path, "r")
             content = file.read()
-            if content.startswith("Red Hat Enterprise Linux"):
-                return "Red Hat Enterprise Linux"
+            if content.startswith("CentOS"):
+                return "CentOS"
 
             if content.startswith("Fedora"):
                 return "Fedora"
em2

em2

2010-12-02 05:18

reporter   ~0012127

There are mass URLs pointing to rh.c that need changing. See an attempt to patch it attached. I have no problem Patching the source rpm but I have noway of knowing the CentOS internal infrastructure unless I am told that. Looking at the example patch will give you the general idea of the problem.

The patch attached is only for example. It is but only half done.
wolfy

wolfy

2010-12-07 09:53

developer   ~0012181

I've found the following items which need changes:
- /etc/report.d/RHEL-bugzilla.redhat.com.conf => points to RH's bugzilla
- /usr/lib*/python2.6/site-packages/report/__init__.py has a hardcoded URL pointing to RH:
 root.attrib["xmlns"] = "http://www.redhat.com/gss/strata"
- /usr/lib*/python2.6/site-packages/report/plugins/RHEL-bugzilla/filer.py contains
 hardcoded_default_product = 'Red Hat Enterprise Linux'
 hardcoded_default_product_for_bugzilla = 'Red Hat Enterprise Linux 6'
/usr/lib*/python2.6/site-packages/report/plugins/RHEL-bugzilla/__init__.py
is dedicated to bugzilla.redhat.com. Offending lines:
 host = "bugzilla.redhat.com"
 bzfiler = filer.BugzillaFiler("https://bugzilla.redhat.com/xmlrpc.cgi","http://bugzilla.redhat.com",filer.getVersion(),filer.getProduct())
On the bright side, I think that bzfiler can be used to disable the plugin, as the plugin seems to bail out if certain conditions are not met.
- /usr/lib*/python2.6/site-packages/report/release_information.py uses
SYSTEM_RELEASE_PATHS = ["/etc/system-release","/etc/redhat-release"]
SYSTEM_RELEASE_DEPS = ["system-release", "redhat-release"]
which might need to be changed if we go to use centos-release
wolfy

wolfy

2010-12-07 09:55

developer   ~0012182

/usr/lib*/python2.6/site-packages/report/plugins/RHEL-bugzilla/bugzillaCopy/rhbugzilla.py also seems to be dedicated to access redhat's bugzilla.
wolfy

wolfy

2010-12-07 10:12

developer   ~0012183

Actually the situation is simpler. The part related to RH bugzilla is isolated in separate binary rpms ( report-plugin-RHEL-bugzilla + report-config-RHEL-bugzilla-redhat-com). I guess that we'll be safe by not shipping those.
em2

em2

2010-12-30 08:09

reporter   ~0012265

These are all related in fashion...As there also related to:
http://bugs.centos.org/view.php?id=4647

This list here needs confirming if it is complete or not.

[root@kernelkiller ~]# rpm -qa|grep -iE 'report|abr'|sort
abrt-1.1.8-2.el6.i686
abrt-addon-ccpp-1.1.8-2.el6.i686
abrt-addon-kerneloops-1.1.8-2.el6.i686
abrt-addon-python-1.1.8-2.el6.i686
abrt-cli-1.1.8-2.el6.i686
abrt-desktop-1.1.8-2.el6.i686
abrt-gui-1.1.8-2.el6.i686
abrt-libs-1.1.8-2.el6.i686
abrt-plugin-bugzilla-1.1.8-2.el6.i686
abrt-plugin-logger-1.1.8-2.el6.i686
abrt-plugin-reportuploader-1.1.8-2.el6.i686
abrt-plugin-sosreport-1.1.8-2.el6.i686
report-0.18-1.el6.i686
report-config-localsave-0.18-1.el6.i686
report-config-RHEL-bugzilla-redhat-com-0.18-1.el6.i686
report-config-scp-0.18-1.el6.i686
report-gtk-0.18-1.el6.i686
report-newt-0.18-1.el6.i686
report-plugin-localsave-0.18-1.el6.i686
report-plugin-RHEL-bugzilla-0.18-1.el6.i686
report-plugin-scp-0.18-1.el6.i686
toracat

toracat

2011-07-05 16:36

manager   ~0012888

bump.
wolfy

wolfy

2011-07-06 22:23

developer   ~0012913

No longer a bug. The offending packages do not exist in current release.

Issue History

Date Modified Username Field Change
2010-11-26 16:22 arrfab New Issue
2010-12-02 05:18 em2 File Added: report-0.18-el6_example.patch
2010-12-02 05:18 em2 Note Added: 0012127
2010-12-07 09:53 wolfy Note Added: 0012181
2010-12-07 09:53 wolfy Status new => confirmed
2010-12-07 09:55 wolfy Note Added: 0012182
2010-12-07 10:12 wolfy Note Added: 0012183
2010-12-30 08:09 em2 Note Added: 0012265
2011-07-05 16:36 toracat Note Added: 0012888
2011-07-05 20:37 toracat Relationship added related to 0004647
2011-07-06 22:23 wolfy Note Added: 0012913
2011-07-06 23:16 kbsingh@karan.org Status confirmed => resolved
2011-07-06 23:16 kbsingh@karan.org Fixed in Version => 6.0
2011-07-06 23:16 kbsingh@karan.org Resolution open => fixed