View Issue Details

IDProjectCategoryView StatusLast Update
0004702CentOS-4yumpublic2011-01-10 10:17
Reportervicafk 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.8 
Target VersionFixed in Version 
Summary0004702: yum fails with segfault after source zlib upgrade
DescriptionSome apps require the latest version of zlib (1.2.5)
After installation from source yum segfaults. (took me ages to figure it out)
Solution, rm -rf /usr/lib/libz.* & reinstall zlib-1.2.3.

Affects all CentOS 4.* and RHEL 4.* versions.
Additional Information[root@SirVic ~]# yum update
Setting up Update Process
Setting up repositories
Segmentation fault

last lines of strace :

_llseek(6, 0, [0], SEEK_CUR) = 0
read(6, "<?xml version=\"1.0\" ?><repomd xm"..., 8192) = 3846
read(6, "", 4346) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
TagsNo tags attached.

Activities

range

range

2011-01-10 10:17

administrator   ~0012321

Not a CentOS problem. Yes, updating random parts of the operating system can lead to errors.

Issue History

Date Modified Username Field Change
2011-01-10 10:14 vicafk New Issue
2011-01-10 10:17 range Note Added: 0012321
2011-01-10 10:17 range Status new => resolved
2011-01-10 10:17 range Resolution open => no change required