View Issue Details

IDProjectCategoryView StatusLast Update
0004752CentOS-6CentOS-6-Pluspublic2011-03-28 20:45
Reporterdcapone 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0004752: Hyper-V Synthetic Drivers
DescriptionWould it be possible to include the Hyper-V synthetic drivers in the CentOS6 Plus kernel?
TagsNo tags attached.

Activities

toracat

toracat

2011-03-04 02:28

manager   ~0012472

I will try enabling the module and rebuild the cplus kernel. The diff seems to be:

@@ -3765,7 +3765,10 @@
 # CONFIG_VT6655 is not set
 # CONFIG_VT6656 is not set
 # CONFIG_FB_UDL is not set
-# CONFIG_HYPERV is not set
+CONFIG_HYPERV=m
+CONFIG_HYPERV_STORAGE=m
+CONFIG_HYPERV_BLOCK=m
+CONFIG_HYPERV_NET=m
 # CONFIG_VME_BUS is not set

 #
toracat

toracat

2011-03-04 02:32

manager   ~0012473

@dcapone

Will you be able to test if I provide the binaries? If so, which arch, x86_64 or i686?
dcapone

dcapone

2011-03-04 02:47

reporter   ~0012474

x86_64...I would be able to setup a test machine for it tomorrow morning.
toracat

toracat

2011-03-04 02:49

manager   ~0012475

No rush. I may or may not have the time to do the work tonight. :)
toracat

toracat

2011-03-04 16:25

manager   ~0012479

OK, the x86_64 kernel is ready to test.

http://centos.toracat.org/kernel/centos6/bug4752plus/x86_64/

( 2.6.32-71.18.1.el6.centos.ayplus.bug4752 )
toracat

toracat

2011-03-04 19:10

manager   ~0012481

The i686 kernel and srpm are also available:

http://centos.toracat.org/kernel/centos6/bug4752plus/
dcapone

dcapone

2011-03-04 21:09

reporter   ~0012483

well...the kernel installed fine

(used rpm -ivh --force kern....bug4752.x86_64.rpm)

rebooted..

The login prompt and uname -a confirm the new kernel is loaded, however...

lsmod | grep hv

outputs nothing indicating the drivers are not loading. Also, reviewed the entire lsmod list to ensure the name didn't appear differently and they still weren't there.

run cat on the kernel config file in /boot:

cat config_.... | grep HYPER

and the

CONFIG_HYPERV=m
CONFIG_HYPERV_STORAGE=m
CONFIG_HYPERV_BLOCK=m
CONFIG_HYPERV_NET=m

lines were in the file, so I'm unsure why they are not loading? In Ubuntu, you need to run a command to update initramfs to get the modules to load, but I believe Cent/Sci use a different architecture where this is done as part of the kernel installation.

For an architecture as close to what CentOS6 will be, I installed the kernel on a Scientific Linux 6.0 installation. I am unsure if this should have been attempted on a CentOS5.5 install but I don't think it should have made a difference.

Don't know if you need anymore information or if providing access to the test VM via SSH would assist in any way...
toracat

toracat

2011-03-04 23:04

manager   ~0012484

If it helps, the actual modules are:

hv_blkvsc.ko
hv_netvsc.ko
hv_storvsc.ko
hv_vmbus.ko

Can you try loading them with modprobe and see if it works (or display any useful error) ?
dcapone

dcapone

2011-03-04 23:47

reporter   ~0012485

Well, the modules loaded fine until I powered off the machine and added a synthetic NIC.

Now when I run modprobe, I get:

VMBUS: Vmbus_Connect() ERROR!! Vmbus connection failed!!...current version (13) not supported
VMBUS_DRV: vmbus_bus_init() ERROR!! ERROR - Unable to add vmbus root device

The above error appears after pressing ^C to halt the loading. When running modprobe without the synthetic NIC installed, hit enter and bang loaded. With the synthetic NIC, it just hangs (I've waited up to 3 minutes). After ^C halt, the above error is displayed.

I am wondering if it is related to 2008 R2 SP1 being installed which uses the newer LIC 2.1 (I think that is the version number).

The Ubuntu version installed on the same machine works fine but that uses kernel 2.6.35 which supposedly has the newer ICs.

I will play around more tonight and see if this VM will run on a different machine without SP1 to confirm that that is the issue.
toracat

toracat

2011-03-05 00:09

manager   ~0012486

In that case, you may want to try kernel-ml from ELRepo:

http://elrepo.org/tiki/kernel-ml

Two versions (2.6.35 and 2.6.37) are available at the moment. Both should run under RHEL/CentOS/SL-5. For further discussion on these kernels, however, you need to go to ELRepo's bug tracker or mailing list.
toracat

toracat

2011-03-05 17:38

manager   ~0012492

@dcapone

I just checked the config of ELRepo's kernel-ml.

# CONFIG_SYS_HYPERVISOR is not set

So, you'd want to file a RFE at http://elrepo.org/bugs/ .

With that note, I am going to close the request here. However if you feel that centosplus kernel should have this module enabled nevertheless, please feel free to repoen this ticket.
toracat

toracat

2011-03-23 17:07

manager   ~0012542

Re-opening this ticket to do a quick addition of a note.

ELRepo's kernel-ml now has Hyper-V enabled and seems to be working according to:

http://elrepo.org/bugs/view.php?id=122

Note, however, that this is for el5.
toracat

toracat

2011-03-28 20:45

manager   ~0012558

Closing again. Please feel free to reopen if you have a note to add.

Issue History

Date Modified Username Field Change
2011-03-03 22:28 dcapone New Issue
2011-03-04 02:28 toracat Note Added: 0012472
2011-03-04 02:32 toracat Note Added: 0012473
2011-03-04 02:32 toracat Status new => feedback
2011-03-04 02:47 dcapone Note Added: 0012474
2011-03-04 02:49 toracat Note Added: 0012475
2011-03-04 02:49 toracat Status feedback => assigned
2011-03-04 16:25 toracat Note Added: 0012479
2011-03-04 19:10 toracat Note Added: 0012481
2011-03-04 21:09 dcapone Note Added: 0012483
2011-03-04 23:04 toracat Note Added: 0012484
2011-03-04 23:47 dcapone Note Added: 0012485
2011-03-05 00:09 toracat Note Added: 0012486
2011-03-05 17:38 toracat Note Added: 0012492
2011-03-05 18:03 toracat Status assigned => closed
2011-03-05 18:03 toracat Resolution open => no change required
2011-03-23 17:07 toracat Note Added: 0012542
2011-03-23 17:07 toracat Status closed => feedback
2011-03-23 17:07 toracat Resolution no change required => reopened
2011-03-23 17:07 toracat Status feedback => assigned
2011-03-28 20:45 toracat Note Added: 0012558
2011-03-28 20:45 toracat Status assigned => resolved
2011-03-28 20:45 toracat Resolution reopened => no change required