View Issue Details

IDProjectCategoryView StatusLast Update
0004806CentOS-6CentOS-6-Pluspublic2011-05-17 18:05
Reportersclark46 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product VersionPre Release 
Target VersionFixed in Version 
Summary0004806: Allow accepting IPV6 router advertisements and sending router solicitations if forwarding is enabled.
DescriptionAdd capability to function according to
Basic Requirements for IPv6 Customer Edge Routers
draft-ietf-v6ops-ipv6-cpe-router-09.

These patches are in the current linux kernel. See:
http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.37.y.git;a=commitdiff;h=65e9b62d4503849b10bedfc29bff0473760cc597;hp=bc8acf2c8c3e43fcc192762a9f964b3e9a17748b

Patch descriptions:
The current IPv6 behavior is to not accept router advertisements while
forwarding, i.e. configured as router.

This does make sense, a router is typically not supposed to be auto
configured. However there are exceptions and we should allow the
current behavior to be overwritten.

Therefore this patch enables the user to overrule the "if forwarding
enabled then don't listen to RAs" rule by setting accept_ra to the
special value of 2.

An alternative would be to ignore the forwarding switch alltogether
and solely accept RAs based on the value of accept_ra. However, I
found that if not intended, accepting RAs as a router can lead to
strange unwanted behavior therefore we it seems wise to only do so
if the user explicitely asks for this behavior.

Signed-off-by: Thomas Graf <tgraf@infradead.org>


Similar to accepting router advertisement, the IPv6 stack does not send router
solicitations if forwarding is enabled.

This patch enables this behavior to be overruled by setting forwarding to the
special value 2.

Signed-off-by: Thomas Graf <tgraf@xxxxxxxxxxxxx>
TagsNo tags attached.

Relationships

child of 0004586 assignedtoracat Build centosplus kernels for CentOS-6 

Activities

toracat

toracat

2011-04-12 16:35

manager   ~0012609

Thank you for submitting this bug report. The patches will be included in the latest C6plus kernel.
toracat

toracat

2011-05-17 18:04

manager   ~0012747

The patch is in the centosplus kernel as of 2.6.32-71.24.1.el6.

centos-linux-2.6-ipv6-cpe-router-bug4806.patch

Issue History

Date Modified Username Field Change
2011-04-12 16:27 sclark46 New Issue
2011-04-12 16:35 toracat Note Added: 0012609
2011-04-12 16:35 toracat Status new => assigned
2011-04-12 17:35 toracat Relationship added related to 0004586
2011-05-11 05:57 toracat Relationship deleted related to 0004586
2011-05-11 05:58 toracat Relationship added child of 0004586
2011-05-17 18:04 toracat Note Added: 0012747
2011-05-17 18:05 toracat Status assigned => resolved
2011-05-17 18:05 toracat Resolution open => fixed