View Issue Details

IDProjectCategoryView StatusLast Update
0004946CentOS-6mirrorspublic2011-07-12 02:01
ReporterGregSwallow 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionwon't fix 
Product Version 
Target VersionFixed in Version6.0 
Summary0004946: can't use yum from centos 5.6 to upgrade to 6.0
DescriptionNot sure if this is supposed to work or not....but in testing I tried to do a yum upgrade from 5.6 to 6.0 (actually SME Server, which uses 5.6) by setting the 6.0 base and updates repositories manually, but ran into an error..

Are the repodata files for the 6.0 mirrors supposed to be compatible with the version of yum from 5.6? I am getting the error:

[Errno -3] Error performing checksum

...when I run 'yum upgrade' on a machine with 5.6 configured with the 6.0 base and updates repositories manually while it checks the base/primary_db

I ran yum clean all, and set http_caching=none and got the same result. I then tried the 3.2.27 version of yum from dev.centos.org and got the same result.
Additional InformationI am guessing it is that the way the repodata is created for Centos 6 that yum from 5.6 can't use the repo's?? Google wasn't much help searching the error, but I found this which may be a clue: http://lists.us.dell.com/pipermail/linux-poweredge/2010-December/043971.html
TagsNo tags attached.

Activities

GregSwallow

GregSwallow

2011-07-11 06:58

updater   ~0012928

Last edited: 2011-07-11 07:03

another more recent reference - http://lists.baseurl.org/pipermail/yum/2011-January/023584.html - suggesting if you ran "createrepo --checksum sha" that would make it backwards compatible

GregSwallow

GregSwallow

2011-07-11 07:27

updater   ~0012929

maybe your version of createrepo ignores that option set....seems to be a problem - https://bugzilla.redhat.com/show_bug.cgi?id=500364
https://bugzilla.redhat.com/show_bug.cgi?id=718218
GregSwallow

GregSwallow

2011-07-11 10:07

updater   ~0012931

installing python-hashlib from EPEL gets rid of the error :-)

A note for the documentation maybe...
kbsingh@karan.org

kbsingh@karan.org

2011-07-11 16:34

administrator   ~0012933

I'm guessing you implied installing python-hashlib on CentOS-5 makes yum on CentOS-5 be compatible with metadata exposed in the CentOS-6 repos.
jussilehtola

jussilehtola

2011-07-11 17:04

reporter   ~0012934

Anyway, upgrade via yum is probably not possible since the payload has changed to xz.

And, since rpm has undergone many bug fixes and gained a lot of speed during the past few years, I'm pretty sure you wouldn't even want to run a yum upgrade, since chances are that it is slower than an upgrade with the installer..
GregSwallow

GregSwallow

2011-07-11 19:05

updater   ~0012935

Last edited: 2011-07-11 19:07

> I'm guessing you implied installing python-hashlib on CentOS-5 makes yum
> on CentOS-5 be compatible with metadata exposed in the CentOS-6 repos.

Yes, at least as far as the yum commands working, I didn't actually upgrade anything.

> Anyway, upgrade via yum is probably not possible since the payload has
> changed to xz.

You are probably right. I was mostly interested in determining what dependencies were unsatisfied and what changes would need to be made to the many non-centos rpms on the system.

herrold

herrold

2011-07-11 19:19

reporter   ~0012936

> can't use yum from centos 5.6 to upgrade to 6.0
> Not sure if this is supposed to work or not.

later:

> determining what dependencies were unsatisfied

It is not a supported path for a lot or reasons (kernel requirements, later python, later RPM supporting xz compression), mentioned on the mailing list by me already
herrold

herrold

2011-07-11 19:22

reporter   ~0012937

not a supported path, not fixable

Issue History

Date Modified Username Field Change
2011-07-11 06:41 GregSwallow New Issue
2011-07-11 06:58 GregSwallow Note Added: 0012928
2011-07-11 07:03 GregSwallow Note Edited: 0012928
2011-07-11 07:20 toracat Project administration => CentOS-6
2011-07-11 07:27 GregSwallow Note Added: 0012929
2011-07-11 10:07 GregSwallow Note Added: 0012931
2011-07-11 16:34 kbsingh@karan.org Note Added: 0012933
2011-07-11 17:04 jussilehtola Note Added: 0012934
2011-07-11 19:05 GregSwallow Note Added: 0012935
2011-07-11 19:07 GregSwallow Note Edited: 0012935
2011-07-11 19:07 GregSwallow Note Edited: 0012935
2011-07-11 19:19 herrold Note Added: 0012936
2011-07-11 19:22 herrold Note Added: 0012937
2011-07-11 19:22 herrold Status new => closed
2011-07-11 19:22 herrold Resolution open => won't fix
2011-07-11 19:22 herrold Fixed in Version => 6.0