View Issue Details

IDProjectCategoryView StatusLast Update
0004951CentOS-6Otherpublic2012-07-11 17:57
Reportergbailey 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version6.0 
Target VersionFixed in Version6.3 
Summary0004951: Files on CentOS DVDs have uid != 0
DescriptionWhen CentOS DVDs are loopback mounted on a running system, several of the files are owned by UID 500, which show up as either "500" or whatever username has UID==500 on the current system. It most likely doesn't affect installs and purely cosmetic, but could be confusing if files are copied from DVD media to populate a local mirror, etc.

Note that this differs from upstream images; I suspect upstream uses "-r" in the mkisofs command, and CentOS uses "-R". (See "-r" option in mkisofs manpage). Suggest using "-r" in the mkisofs command for CentOS media.
TagsQA-6.3

Activities

mharris

mharris

2012-02-16 03:08

reporter   ~0014483

I just encountered this problem with CentOS 6.2 DVD ISOs also. I tried to mount
the image so I can copy it to a tree under my webroot and combine the two images
into one place for PXE installs, but cp wont copy the files due to bad file
ownership of uid=500, gid=502 on many of the files.

Worse yet, is the mount options "uid" and "gid" for iso9660 to forcibly override
the uid/gid do not work at all.

pts/3 root@higgins:~# whoami ; ls -ald /mnt/iso
root
drwxr-xr-x 2 root root 1024 Jul 8 2011 /mnt/iso


pts/3 root@higgins:~# ls -al /mnt/iso
total 4
drwxr-xr-x 2 root root 1024 Jul 8 2011 .
drwxr-xr-x 7 root root 1024 Jul 8 2011 ..


pts/3 root@:~# mount /var/www/iso/CentOS-6.2-i386-bin-DVD1.iso /mnt/iso -t iso9660 -o uid=0,gid=0,loop,ro


pts/3 root@:~# mount |grep /mnt/iso
/var/www/iso/CentOS-6.2-i386-bin-DVD1.iso on /mnt/iso type iso9660 (ro,loop=/dev/loop0,uid=0,gid=0)


pts/3 root@:~# ls -aln /mnt/iso/
total 533
drwxr-xr-x 6 0 0 4096 Dec 16 19:03 .
drwxr-xr-x 7 0 0 1024 Jul 8 2011 ..
-rw-rw-r-- 1 500 502 29 Dec 16 19:01 .discinfo
-rw-rw-r-- 1 500 502 334 Dec 16 19:03 .treeinfo
-rw-rw-r-- 2 500 502 14 Dec 16 18:58 CentOS_BuildTag
-rw-rw-r-- 2 500 502 212 Dec 9 07:57 EULA
-rw-rw-r-- 2 500 502 18009 Dec 9 07:57 GPL
drwxrwxr-x 2 500 502 497664 Dec 16 19:01 Packages
-rw-rw-r-- 2 500 502 1354 Dec 9 07:58 RELEASE-NOTES-en-US.html
-rw-rw-r-- 2 500 502 1706 Dec 9 07:57 RPM-GPG-KEY-CentOS-6
-rw-rw-r-- 2 500 502 1730 Dec 9 07:57 RPM-GPG-KEY-CentOS-Debug-6
-rw-rw-r-- 2 500 502 1730 Dec 9 07:57 RPM-GPG-KEY-CentOS-Security-6
-rw-rw-r-- 2 500 502 1734 Dec 9 07:57 RPM-GPG-KEY-CentOS-Testing-6
-r--r--r-- 1 0 0 3165 Dec 16 19:03 TRANS.TBL
drwxrwxr-x 3 500 502 2048 Dec 14 21:59 images
drwxrwxr-x 2 500 502 2048 Dec 12 21:38 isolinux
drwxr-xr-x 2 0 0 4096 Dec 16 19:03 repodata


pts/3 root:~# cp -a /mnt/iso /var/www/mrepo/centos6-i386/RPMS.os/
cp: cannot create directory `/var/www/mrepo/centos6-i386/RPMS.os/iso': Permission denied


So there are 2 bugs here, the disk images aren't created with proper ownership (the -r option to mkisofs as mentioned in the original report above), and mount ignores the uid/gid options. I'll see if there's another bug for that one already.

Hope this helps.
mharris

mharris

2012-02-16 03:09

reporter   ~0014484

I can confirm this problem as per my previous comment.
mharris

mharris

2012-02-16 03:13

reporter   ~0014485

Workaround for those who don't have commandline fu...

cp -dR --preserve=mode,timestamps /mnt/iso/* /var/www/mrepo/centos6-i386/RPMS.os/
mharris

mharris

2012-02-16 11:54

reporter   ~0014486

Just to highlight it at the bottom here, "mkisofs -r" is the solution to this during ISO builds.
gbailey

gbailey

2012-02-28 14:21

reporter   ~0014571

Opened against CentOS 5 as http://bugs.centos.org/view.php?id=5557
wolfy

wolfy

2012-04-23 08:20

developer   ~0014901

The problem was confirmed and http://bugs.centos.org/view.php?id=5557 was fixed. For CentOS 6 the fix will come starting with release 6.3.
tigalch

tigalch

2012-07-08 20:04

manager   ~0015376

Just checked the /-Folder of the images in QA and this issue seems fixed. PLease confirm once 6.3 is released.
tigalch

tigalch

2012-07-11 17:57

manager   ~0015407

The ISOs of 6.3 now have the correct ownership.

Issue History

Date Modified Username Field Change
2011-07-11 15:12 gbailey New Issue
2012-02-16 03:08 mharris Note Added: 0014483
2012-02-16 03:09 mharris Note Added: 0014484
2012-02-16 03:09 mharris Status new => confirmed
2012-02-16 03:13 mharris Note Added: 0014485
2012-02-16 11:52 arrfab Tag Attached: QA-6.3
2012-02-16 11:54 mharris Note Added: 0014486
2012-02-28 14:21 gbailey Note Added: 0014571
2012-04-23 08:20 wolfy Note Added: 0014901
2012-04-23 08:20 wolfy Status confirmed => acknowledged
2012-07-08 20:04 tigalch Note Added: 0015376
2012-07-11 17:57 tigalch Note Added: 0015407
2012-07-11 17:57 tigalch Status acknowledged => resolved
2012-07-11 17:57 tigalch Fixed in Version => 6.3
2012-07-11 17:57 tigalch Resolution open => fixed