View Issue Details

IDProjectCategoryView StatusLast Update
0004953CentOS-6-OTHERpublic2011-07-20 14:49
Reporteruleodolter Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version6.0 
Fixed in Version6.0 
Summary0004953: upgrade to CentOS 6 using upgradeany option does not upgrade centos-release
Descriptionimplace upgrade to CentOS 6 using DVD and upgradeany option does not upgrade
centos-release because yum thinks centos-release-5-6.el5.centos.1 is newer than
centos-release-6-0.el6.centos.5.x86_64 rpm.

[root@server Packages]# rpm -Uvh centos-release-6-0.el6.centos.5.x86_64.rpm
warning: centos-release-6-0.el6.centos.5.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID c105b9de: NOKEY
Preparing... ########################################### [100%]
        package centos-release-10:5-6.el5.centos.1.x86_64 (which is newer than centos-release-6-0.el6.centos.5.x86_64) is already installed

br
ul
Additional Informationi did the upgrade on my homeserver which has installed gnome desktop and some rpms from rpmforge repo.

after upgrade the system boots and has network connection. this is good :-)
there are a couple of other rpms from 5.6 which are newer then 6.0 packages from dvd image (can't remember them all, maybe i should search my very old
script which helps to find such packages before upgrade :-)

i was able to replace almost all el5 rpms by using "rpm -Uvh --force ...".
now the system has only a few self built el5 rpms installed.

TagsNo tags attached.

Activities

herrold

herrold

2011-07-11 21:55

reporter   ~0012943

As stated in the mailing list, it is desireable to NOT carry unneeded Epoch

'updateany' or 'upgradeany' may exist but are not supported upstream for major version boundries

As ** this package's ** namespace is entirely under CentOS control and we only get one change per major release to fix this kind of matter, please explain why adding an epoch is a win compared to simply documenting the trivial fix
(a) DL the centos-6 version centos-release
(b) rpm -e --nodeps centos-release
(c) rpm -i (local new centos-release file)

Update the Release Notes if you wish -- otherwise this seems to be a WONTFIX

-- Russ herrold
herrold

herrold

2011-07-20 14:49

reporter   ~0013018

Release notes were updated ... no further action anticipated

http://wiki.centos.org/Manuals/ReleaseNotes/CentOS6.0

Issue History

Date Modified Username Field Change
2011-07-11 19:26 uleodolter New Issue
2011-07-11 20:37 toracat Project CentOS-5 => CentOS-6
2011-07-11 20:40 toracat Product Version 5.6 => 6.0
2011-07-11 21:55 herrold Note Added: 0012943
2011-07-20 14:49 herrold Note Added: 0013018
2011-07-20 14:49 herrold Status new => closed
2011-07-20 14:49 herrold Resolution open => fixed
2011-07-20 14:49 herrold Fixed in Version => 6.0