View Issue Details

IDProjectCategoryView StatusLast Update
0004988CentOS-6anacondapublic2011-07-26 09:19
Reporterbigon 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version6.0 
Target VersionFixed in Version 
Summary0004988: Anaconda loose nameserver after install
DescriptionHi,

I'm trying to call a command (puppet) in %post that requires a nameserver to be configured.

During installation, the resolv.conf of the installer is correctly populated (search, nameserver entries and even a comment saying that it was generated by network-manager). During the install the resolv.conf of the chroot only contains a "search" line. At some point between the end of the install and the %post it seems that the resolv.conf of the installer is replaced by the one of the chroot(?), so I have no nameserver configured at all either in the installer or in the chroot.

The installation is using a KS file and DHCP to get the network informations.

This was working fine with CentOS 5.6
TagsNo tags attached.

Activities

herrold

herrold

2011-07-20 14:34

reporter   ~0013017

This looks like a matter already handled in IRC --

Please attach the ks.cfg, and the contents of: /etc/sysconfig/network-scripts/ifcfg-eth* , and a copy of the running: /etc/resolv.conf

-- Russ herrold

2011-07-26 08:55

 

centos60.txt (2,654 bytes)
#version=RHEL6
install
url --url http://wheelo/installation/CentOS-6.0-x86_64/
#url --url http://raiti/installation/centos/6/os/x86_64/
lang en_US.UTF-8
keyboard be-latin1
network --device eth0 --bootproto dhcp
#ask for network config during install
#network --device eth0 --bootproto query
#network --bootproto=static --ip=10.0.3.68 --netmask=255.255.255.0 --gateway=10.0.3.100 --nameserver 10.0.3.1
rootpw "passwd"
firewall --disabled
authconfig --enableshadow --passalgo=sha512
#selinux --disabled
timezone --utc Europe/Brussels
#bootloader --location=mbr --driveorder=vda --append=console=ttyS0
bootloader --location=mbr --driveorder=sda # --append="crashkernel=auto rhgb quiet"
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
clearpart --drives=sda --all --initlabel
part /boot --fstype ext4 --ondisk=sda --asprimary --size=500
part pv.2 --ondisk=sda --asprimary --grow --size=1
volgroup vg_system --pesize=4096 pv.2
logvol / --fstype ext4 --name=lv_root --vgname=vg_system --size=2048 --grow
logvol swap --fstype swap --name=lv_swap --vgname=vg_system --recommended

#enable extra services
#services --enable ntpd,crond,yum-updatesd,acpid,puppet
services --enable ntpd,puppet

repo --name=updates --baseurl=http://raiti/installation/centos/6/updates/x86_64/
repo --name=epel --baseurl=http://raiti/installation/epel/6/x86_64/
#mirrored from http://stahnma.fedorapeople.org/puppetlabs/6/x86_64/
repo --name=puppetlabs --baseurl=http://raiti/installation/puppetlabs/6/x86_64/

reboot

%packages
#epel-release
#puppet
ntp
#avoid installing X libraries
-fprintd
-fprintd-pam
#Drop firmwares
-atmel-firmware-1.3-7.el6.noarch
-b43-openfwwf-5.2-4.el6.noarch
-ipw2100-firmware-1.3-11.el6.noarch
-ipw2200-firmware-3.1-4.el6.noarch
-ivtv-firmware-20080701-20.2.noarch
-iwl1000-firmware-128.50.3.1-1.1.el6.noarch
-iwl3945-firmware-15.32.2.9-4.el6.noarch
-iwl4965-firmware-228.61.2.24-2.1.el6.noarch
-iwl5000-firmware-8.24.2.12-3.el6.noarch
-iwl5150-firmware-8.24.2.2-1.el6.noarch
-iwl6000-firmware-9.176.4.1-2.el6.noarch
-iwl6050-firmware-9.201.4.1-2.el6.noarch
-libertas-usb8388-firmware-5.110.22.p23-3.1.el6.noarch
-rt61pci-firmware-1.2-7.el6.noarch
-rt73usb-firmware-1.8-7.el6.noarch
-zd1211-firmware-1.4-4.el6.noarch
%end

%post --log=/root/postinstall.log
#echo 'nameserver 192.168.110.240' >> /etc/resolv.conf
puppet agent --test --server puppet --waitforcert=60 --pluginsync --report
#2nd call needed with puppet <= 1.7.1
puppet agent --test --server puppet --waitforcert=60 --pluginsync --report
%end
centos60.txt (2,654 bytes)

2011-07-26 09:16

 

resolv.conf (120 bytes)

2011-07-26 09:18

 

ifcfg (191 bytes)
DEVICE=eth0
HWADDR=E4:1F:XX:XX:XX:XX
ONBOOT=yes
BOOTPROTO=dhcp
DEVICE=eth1
HWADDR=E4:1F:XX:XX:XX:XX
ONBOOT=no
NM_CONTROLLED=no
DEVICE=usb0
HWADDR=E6:1F:XX:XX:XX:XX
ONBOOT=no
NM_CONTROLLED=no
ifcfg (191 bytes)

2011-07-26 09:19

 

dhclient-eth0.lease (490 bytes)

Issue History

Date Modified Username Field Change
2011-07-20 12:49 bigon New Issue
2011-07-20 14:34 herrold Note Added: 0013017
2011-07-26 08:55 bigon File Added: centos60.txt
2011-07-26 09:16 bigon File Added: resolv.conf
2011-07-26 09:18 bigon File Added: ifcfg
2011-07-26 09:19 bigon File Added: dhclient-eth0.lease