View Issue Details

IDProjectCategoryView StatusLast Update
0005004CentOS-6Otherpublic2012-08-29 12:21
Reporterchoon Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.0 
Fixed in Version6.3 
Summary0005004: some noarch packages missing in CentOS 6.0 i386 repo?
DescriptionThe following noarch packages found in CentOS 6.0 x86_64 repo but not
in CentOS 6.0 i386 repo:

vgabios-0.6b-3.4.el6.noarch.rpm
gpxe-roms-0.9.7-6.3.el6.noarch.rpm
mvapich-common-1.2.0-0.3562.5.el6.noarch.rpm
gpxe-roms-qemu-0.9.7-6.3.el6.noarch.rpm
perl-XML-DOM-XPath-0.14-4.el6.noarch.rpm
perl-XML-Writer-0.606-6.el6.noarch.rpm
gpxe-bootimgs-0.9.7-6.3.el6.noarch.rpm
perl-Module-Find-0.08-3.el6.noarch.rpm

Thanks.

Kindest regards,
TagsNo tags attached.

Activities

choon

choon

2011-07-24 21:51

reporter   ~0013033

Here are some more findings about missing packages in CentOS 6.0 i386 repo but found in CentOS 6.0 x86_64 repo (ignore about repeated though):

dev86-0.16.17-15.1.el6
febootstrap-2.7-1.2.el6
hivex-1.2.2-1.el6
hivex-devel-1.2.2-1.el6
iasl-20090123-3.1.el6
lzop-1.02-0.9.rc1.el6
ocaml-hivex-1.2.2-1.el6
ocaml-hivex-devel-1.2.2-1.el6
perl-hivex-1.2.2-1.el6
perl-libintl-1.20-1.el6
perl-Module-Find-0.08-3.el6
perl-XML-DOM-XPath-0.14-4.el6
perl-XML-Writer-0.606-6.el6
vgabios-0.6b-3.4.el6

Thanks.

Kindest regards,
choon

choon

2011-07-24 21:59

reporter   ~0013034

I think the following are fine about missing as I guess SL6.0 also missing the following:

gpxe-roms-0.9.7-6.3.el6.noarch.rpm
gpxe-roms-qemu-0.9.7-6.3.el6.noarch.rpm
gpxe-bootimgs-0.9.7-6.3.el6.noarch.rpm

Thanks.

Kindest regards,
kbsingh@karan.org

kbsingh@karan.org

2011-07-24 22:28

reporter   ~0013036

so, what is the bug ?
choon

choon

2011-07-25 10:48

reporter   ~0013044

Bug? I was advised to file report here via centos-devel mailing list. Some third-party packages can't be built for i386/i686 if there are missing but exists in x86_64.
peak

peak

2012-06-19 13:13

reporter   ~0015289

I've just hit the same problem. perl-XML-DOM-XPath was needed. It was installed from base on one system but another system knew nothing about the package. It turned out the former system was x86_64 while the latter was i686.

I can live with a situation when a certain package is missing in base and must be added from another repo but things get pretty messy when the package is missing in base (and needs to be supplied from another repo) on one architecture but present on another.

I understand why packages related to virtualization are x86_64-only (not that I approve) but the only link between virtualization and perl-XML-DOM-XPath is the dependence from virt-v2v and software packages having absolutely no relation with virtualization are affected by the discrepancy.

PS: Can anyone check the upstream?
JohnnyHughes

JohnnyHughes

2012-08-29 12:18

administrator   ~0015715

The following RPMS are not built for i[3,6]86 because it is excluded in the SPEC files for these SRPMS:

dev86
febootstrap
vgabios

The following RPMS are not in i[3,6]86 repos because, even though they build, they are not in the upstream i[3,6]86 repo:

iasl
lzop
perl-Module-Find
perl-XML-DOM-XPath
perl-XML-Writer
gpxe-roms
gpxe-roms-qemu
gpxe-bootimgs

I have no idea why these are NOT in the RHEL i386 repo, but they are not. They are also not in Oracle's i386 repo. So, they are not in ours either.

==========================

That leaves these:
hivex
hivex-devel
ocaml-hivex
ocaml-hivex-devel
perl-hivex
perl-libintl

They have been added to the i386 updates repo in CentOS-6.3 and will be carried forward as long as they remain in the upstream i386 repo.
JohnnyHughes

JohnnyHughes

2012-08-29 12:20

administrator   ~0015716

the rpms that are in the upstream i386 repo are in our updates repo for 6.3 ... the others are not (since they are not upstream).

Issue History

Date Modified Username Field Change
2011-07-24 19:54 choon New Issue
2011-07-24 21:51 choon Note Added: 0013033
2011-07-24 21:59 choon Note Added: 0013034
2011-07-24 22:28 kbsingh@karan.org Note Added: 0013036
2011-07-25 10:48 choon Note Added: 0013044
2012-06-19 13:13 peak Note Added: 0015289
2012-08-29 12:18 JohnnyHughes Note Added: 0015715
2012-08-29 12:20 JohnnyHughes Note Added: 0015716
2012-08-29 12:20 JohnnyHughes Status new => resolved
2012-08-29 12:20 JohnnyHughes Fixed in Version => 6.3
2012-08-29 12:20 JohnnyHughes Resolution open => fixed